Closed Bug 890008 Opened 8 years ago Closed 8 years ago

Add the add-on bar back in Australis

Categories

(Firefox :: Toolbars and Customization, enhancement)

25 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: rexyrexy2, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

opened UX


Actual results:

There was NO add-on bar, and Y'all are mimicking other browsers again!


Expected results:

The add-on bar should be there, and y'all should not be mimicking other browsers (AGAIN!!)
also, one MAJOR reason to have it is so that the navbar (and others) does (do) not get cluttered with add-ons.
Component: Untriaged → Toolbars and Customization
Severity: normal → major
Priority: -- → P4
Hardware: x86_64 → All
Removing the addon bar would be a very bad idea.

The user should be in charge to decide where to place addon icons, and there are good reasons not to clutter the navigation bar.

Simply because Chrome doesn't have an addon bar is no reason to remove it from Firefox. Chrome is a very bad example in terms of user experience (very little customizability). There is a good chance that people who haven't switched from Firefox to Chrome (yet) do so because they like to customize their browser. If you make Firefox less customizable, you kill a very good reason to stick with Firefox and make more people switch to Chrome.

This may apply to other changes planned with Australis as well.
Severity: major → enhancement
OS: Windows 7 → All
Priority: P4 → --
This is a deliberate design decision. See bug 749804.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
(In reply to Justin Dolske [:Dolske] from comment #3)
> This is a deliberate design decision. See bug 749804.

This Australis bullshit is going to lose Firefox many more users, remember my words. That's the logical consequence if you don't listen to user's very legitimate complaints and go forward with stupid decisions which are made before users can even object to them.

Why does Mozilla even ask for feedback if decisions are already final anyway?

Firefox had a big advantage in that it was very customizable. You are about to destroy one of the biggest advantages that Firefox currently has. So how does that make Firefox better?

This is not only about this bug, but about many bug reports which Justin Dolske just WONTFIX'ed.

(BTW, I will stop filing Australis bugs; if you are not interested anyway it's just a waste of my time)
Although there is a design decision behind this, not having the addon bar available in Australis breaks how I use Firefox and the extensions that claim to add a bar to the browser do not work correctly. All extensions being in the top bar will not work when you have as many as I run, and I need another place to put them.

There are also addons that use the addon bar as a place to put labels and other indicators that no longer work as they should.

Please consider putting this back in, it will break Firefox for a lot of people if it is not available for use.
Duplicate of this bug: 990483
(In reply to Justin Dolske [:Dolske] from comment #3)
> This is a deliberate design decision. See bug 749804.

A VERY bad idea, a lot of addons don't move to status bar, so?.
With this "feature" Firefox lacks the "customization" that is the BIG feature of Firefox, so?
(In reply to Steven from comment #5)
> Although there is a design decision behind this, not having the addon bar
> available in Australis breaks how I use Firefox and the extensions that
> claim to add a bar to the browser do not work correctly. All extensions
> being in the top bar will not work when you have as many as I run, and I
> need another place to put them.
> 
> There are also addons that use the addon bar as a place to put labels and
> other indicators that no longer work as they should.
> 
> Please consider putting this back in, it will break Firefox for a lot of
> people if it is not available for use.

I Agree, actually I need a "addon" for restore the addon-bar (using more memory and cpu) because Mozilla team lost the direction and they forget that personalization is strong in Firefox, they will lose many users, or perhaps you want to look like chrome-****?
You need to log in before you can comment on or make changes to this bug.