Remove deprecated use of variables in puppet templates

RESOLVED DUPLICATE of bug 911270

Status

Infrastructure & Operations
RelOps: Puppet
RESOLVED DUPLICATE of bug 911270
5 years ago
5 years ago

People

(Reporter: nthomas, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
eg: on releng-puppet1.srv.releng.usw2.m.c:

Jul  3 21:37:17 releng-puppet1 puppet-agent[6870]: Caching catalog for releng-puppet1.srv.releng.usw2.mozilla.com
Jul  3 21:37:23 releng-puppet1 puppet-agent[6870]: Applying configuration version '7f8a1adc0e8c'
Jul  3 21:37:28 releng-puppet1 puppet-master[6723]: Variable access via 'puppet_atboot_common' is deprecated. Use '@puppet_atboot_common' instead. template[/etc/puppet/production/modules/puppet/templates/puppet-centos-initd.erb]:20
Jul  3 21:37:28 releng-puppet1 puppet-master[6723]:    (at /etc/puppet/production/modules/puppet/templates/puppet-centos-initd.erb:20:in `result')
Jul  3 21:37:40 releng-puppet1 puppet-master[6821]: Variable access via 'puppet_atboot_common' is deprecated. Use '@puppet_atboot_common' instead. template[/etc/puppet/production/modules/puppet/templates/puppet-ubuntu-initd.erb]:18
Jul  3 21:37:40 releng-puppet1 puppet-master[6821]:    (at /etc/puppet/production/modules/puppet/templates/puppet-ubuntu-initd.erb:18:in `result')
Jul  3 21:37:40 releng-puppet1 puppet-master[6821]: Variable access via 'python' is deprecated. Use '@python' instead. template[/etc/puppet/production/modules/packages/templates/tooltool.py]:1
Jul  3 21:37:40 releng-puppet1 puppet-master[6821]:    (at /etc/puppet/production/modules/packages/templates/tooltool.py:1:in `result')
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]: Variable access via 'screen_width' is deprecated. Use '@screen_width' instead. template[/etc/puppet/production/modules/gui/templates/xvfb.conf.erb]:15
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]:    (at /etc/puppet/production/modules/gui/templates/xvfb.conf.erb:15:in `result')
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]: Variable access via 'gpu_bus_id' is deprecated. Use '@gpu_bus_id' instead. template[/etc/puppet/production/modules/gui/templates/xorg.conf.erb]:46
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]:    (at /etc/puppet/production/modules/gui/templates/xorg.conf.erb:46:in `result')
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]: Variable access via 'on_gpu' is deprecated. Use '@on_gpu' instead. template[/etc/puppet/production/modules/gui/templates/Xsession.conf.erb]:7
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]:    (at /etc/puppet/production/modules/gui/templates/Xsession.conf.erb:7:in `result')
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]: Variable access via 'distribution' is deprecated. Use '@distribution' instead. template[/etc/puppet/production/modules/packages/templates/sources.list.erb]:5
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]:    (at /etc/puppet/production/modules/packages/templates/sources.list.erb:5:in `result')
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]: Variable access via 'data_server' is deprecated. Use '@data_server' instead. template[/etc/puppet/production/modules/packages/templates/sources.list.erb]:8
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]:    (at /etc/puppet/production/modules/packages/templates/sources.list.erb:8:in `result')
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]: Variable access via 'data_servers' is deprecated. Use '@data_servers' instead. template[/etc/puppet/production/modules/packages/templates/sources.list.erb]:9
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]:    (at /etc/puppet/production/modules/packages/templates/sources.list.erb:9:in `result')
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]: Variable access via 'ipaddress' is deprecated. Use '@ipaddress' instead. template[/etc/puppet/production/modules/packages/templates/sources.list.erb]:18
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]:    (at /etc/puppet/production/modules/packages/templates/sources.list.erb:18:in `result')
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]: Variable access via 'data_servers' is deprecated. Use '@data_servers' instead. template[/etc/puppet/production/modules/packages/templates/sources.list.erb]:20
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]:    (at /etc/puppet/production/modules/packages/templates/sources.list.erb:20:in `result')
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]: Variable access via 'data_server' is deprecated. Use '@data_server' instead. template[/etc/puppet/production/modules/packages/templates/sources.list.erb]:23
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]:    (at /etc/puppet/production/modules/packages/templates/sources.list.erb:23:in `result')
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]: Variable access via 'url_path' is deprecated. Use '@url_path' instead. template[/etc/puppet/production/modules/packages/templates/sources.list.erb]:24
Jul  3 21:37:42 releng-puppet1 puppet-master[6821]:    (at /etc/puppet/production/modules/packages/templates/sources.list.erb:24:in `result')

rsoderberg emailed about this getting done for existing templates, but was probably referring to IT puppets.
Variable access via 'data_server' is deprecated. Use '@data_server' instead. template[/etc/puppet/production/modules/packages/templates/sources.list.erb]:23 (at /etc/puppet/production/modules/packages/templates/sources.list.erb:23:in `result')
Variable access via 'data_server' is deprecated. Use '@data_server' instead. template[/etc/puppet/production/modules/packages/templates/sources.list.erb]:8 (at /etc/puppet/production/modules/packages/templates/sources.list.erb:8:in `result')
Variable access via 'data_servers' is deprecated. Use '@data_servers' instead. template[/etc/puppet/production/modules/packages/templates/sources.list.erb]:20 (at /etc/puppet/production/modules/packages/templates/sources.list.erb:20:in `result')
Variable access via 'data_servers' is deprecated. Use '@data_servers' instead. template[/etc/puppet/production/modules/packages/templates/sources.list.erb]:9 (at /etc/puppet/production/modules/packages/templates/sources.list.erb:9:in `result')
Variable access via 'distribution' is deprecated. Use '@distribution' instead. template[/etc/puppet/production/modules/packages/templates/sources.list.erb]:5 (at /etc/puppet/production/modules/packages/templates/sources.list.erb:5:in `result')
Variable access via 'gpu_bus_id' is deprecated. Use '@gpu_bus_id' instead. template[/etc/puppet/production/modules/gui/templates/xorg.conf.erb]:46 (at /etc/puppet/production/modules/gui/templates/xorg.conf.erb:46:in `result')
Variable access via 'ipaddress' is deprecated. Use '@ipaddress' instead. template[/etc/puppet/production/modules/packages/templates/sources.list.erb]:18 (at /etc/puppet/production/modules/packages/templates/sources.list.erb:18:in `result')
Variable access via 'on_gpu' is deprecated. Use '@on_gpu' instead. template[/etc/puppet/production/modules/gui/templates/Xsession.conf.erb]:7 (at /etc/puppet/production/modules/gui/templates/Xsession.conf.erb:7:in `result')
Variable access via 'puppet_atboot_common' is deprecated. Use '@puppet_atboot_common' instead. template[/etc/puppet/production/modules/puppet/templates/puppet-ubuntu-initd.erb]:18 (at /etc/puppet/production/modules/puppet/templates/puppet-ubuntu-initd.erb:18:in `result')
Variable access via 'python' is deprecated. Use '@python' instead. template[/etc/puppet/production/modules/packages/templates/tooltool.py]:1 (at /etc/puppet/production/modules/packages/templates/tooltool.py:1:in `result')
Variable access via 'screen_width' is deprecated. Use '@screen_width' instead. template[/etc/puppet/production/modules/gui/templates/xvfb.conf.erb]:15 (at /etc/puppet/production/modules/gui/templates/xvfb.conf.erb:15:in `result')
Variable access via 'url_path' is deprecated. Use '@url_path' instead. template[/etc/puppet/production/modules/packages/templates/sources.list.erb]:24 (at /etc/puppet/production/modules/packages/templates/sources.list.erb:24:in `result')
Duplicate of this bug: 891857
Assignee: nobody → infra
Component: Release Engineering → Infrastructure: Puppet
Product: mozilla.org → Infrastructure & Operations
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 877417
Duplicate of bug: 877418
:bhearsum moved this to infra puppet instead of relops puppet by mistake, its about PuppetAgain not infra manifests. Due to that I'm reopening (unless 877418 is about puppetAgain and I just can't see it)
Assignee: infra → relops
Status: RESOLVED → REOPENED
Component: Infrastructure: Puppet → RelOps: Puppet
Resolution: DUPLICATE → ---
Assignee: relops → dustin
Severity: normal → enhancement
QA Contact: release → dustin
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 911270
Assignee: dustin → relops
Severity: enhancement → normal
You need to log in before you can comment on or make changes to this bug.