Closed Bug 890221 Opened 7 years ago Closed 7 years ago

[FM Radio] pressing Hardware Volume keys don't increase/decrease FM Radio volume

Categories

(Firefox OS Graveyard :: Gaia::FMRadio, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, firefox25 unaffected, b2g18 verified, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd verified)

VERIFIED FIXED
1.1 QE4 (15jul)
blocking-b2g leo+
Tracking Status
firefox25 --- unaffected
b2g18 --- verified
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- verified

People

(Reporter: leo.bugzilla.gaia, Assigned: rlin)

Details

(Whiteboard: [TD-57746][LeoVB+] )

Attachments

(1 file)

1. Title: Not able to change the volume of FM radio with volume hardware keys
2. Precondition: when in homescreen, reduce the volume to fully ZERO
3. Tester's Action: 
		1. Open FM app
		2. Play FM app
		3. Adjust the volume either increase/decrease.
		4. No sound heard(No change in volume's behaviour)
4. Detailed Symptom (ENG.): After setting the volume to zero on home screen, user cannot hear the sound while FM playing(irrespective of increasing or decreasing hardware volume keys)
5. Expected : User should be able to control volume 
6. Reproducibility: Y
1)Frequency Rate : 100%
7.Gaia Master/v1-train : Reproduced
8.Gaia Revision: 0a8b1d7c70c5ec2b48e52c2cd7e463f47fa0b9cb
blocking-b2g: --- → leo+
Priority: -- → P1
Whiteboard: [TD-57746]
Thanks for the report. 
Randy or me will work on it next week.
I know it can`t set fm volume because flag"mFMChannelIsMuted" is true.
-------------------------------------------------------------------------
AudioManager::SetStreamVolumeIndex(int32_t aStream, int32_t aIndex) {
  ...
  if (aStream == AUDIO_STREAM_MUSIC && IsDeviceOn(AUDIO_DEVICE_OUT_FM) && !mFMChannelIsMuted) {
    AudioSystem::setStreamVolumeIndex(static_cast<audio_stream_type_t>(AUDIO_STREAM_FM), aIndex);
    mCurrentStreamVolumeTbl[AUDIO_STREAM_FM] = aIndex;
  }
}
-------------------------------------------------------------------------
Considering AudioChannel, it need to modify.
Assignee: nobody → rlin
Attached patch patch v1Splinter Review
Remove the mFMChannelIsMuted, we already switch off the FMRadio audio path to mute the FMRadio sound.
Attachment #771930 - Flags: review?(mchen)
Comment on attachment 771930 [details] [diff] [review]
patch v1

Review of attachment 771930 [details] [diff] [review]:
-----------------------------------------------------------------

Actually this patch is the same with Bug 868960 and which was already landed to m-c.
So here will land it to b2g18 only based on leo+.

Hi Randy,
Is this align with you?

Thanks.
Attachment #771930 - Flags: review?(mchen) → review+
Yes, just apply this patch to b2g18, thanks.
Unagi
Gaia:     55ed5e08a2250ea2d3571fff860c39e66fabed14
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/6062fdf2deb8
BuildID   20130715070218
Version   18.0
Helix
Gaia:     3042f9ec2fa8f7022647139217ad40560558f496
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/d3094c7c17e0
BuildID   20130715070212
Version   18.0

Verified.
Status: RESOLVED → VERIFIED
Whiteboard: [TD-57746] → [TD-57746][LeoVB+]
You need to log in before you can comment on or make changes to this bug.