Closed Bug 868960 Opened 9 years ago Closed 9 years ago

[FMRadio] FM Radio volume is not updated by headset ejecting.

Categories

(Firefox OS Graveyard :: General, defect, P2)

ARM
Gonk (Firefox OS)

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: leo.bugzilla.gecko, Assigned: rlin)

References

Details

(Whiteboard: c= [TD-23311])

Attachments

(1 file)

[VER.]
BuildID revision="7cb46499e0b91ca20f6aed58d6067d7c451875b9"
gaia revision="5cbb19e4bb78a7ad879fbe4b9a841e1c35714f5c"
gecko revision="950b402b6188bb2f3ce3176e620ed5249719d720"

[Precondition]
- Insert the HEADSET
- Open the FM 
- Play a channel
- Now, make the volune zero from side volume button
-  Remove the HEADSET
-  wait for message to diaply that "FM Radio requires a plugged in headset to recive radio signals "
-  insert the HEADSET
- wait to powen on the FM
- increase the volume 

[Symptoms]
FM volume is not updated. But, other volume is updated.

The resean is "mFMChannelIsMuted" variable in SetStreamVolumeIndex(AudioManager.cpp)
FM Volume usually set AUDIO_STREAM_MUSIC stream by volume up-down button.
But by headset ejecting/inserting, call CanPlayChanged() in FMRadio.cpp and set volume 0 as AUIOD_STREAM_FM. 
You should unify audio stream value(AUDIO_STREAM_MUSIC/AUIOD_STREAM_FM) or change "mFMChannelIsMuted" value

Anyway AudioPolicyService is set AUDIO_STREAM_MUSIC even if FM volume come from FM/MUSIC stream value.
Whiteboard: c= [TD-23311]
Attached patch patch v1Splinter Review
Hi Michael, 
Due to we has implemented the switching-off the audio path when audiochannelService was triggered to mute the FM sound, so those code can be removed and fix this bug.
Assignee: nobody → rlin
Attachment #746263 - Flags: review?(mwu)
Duplicate of this bug: 866500
Depends on: 819858
Attachment #746263 - Flags: review?(mwu) → review+
https://hg.mozilla.org/mozilla-central/rev/64c5d1f3d728
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.