Closed Bug 890259 Opened 7 years ago Closed 7 years ago

Aurora(Firefox 24.0 a2) can not handle PDF form annotation correctly.

Categories

(Firefox :: PDF Viewer, defect, P2)

24 Branch
x86_64
Windows 7
defect

Tracking

()

VERIFIED FIXED
Firefox 26
Tracking Status
firefox23 --- unaffected
firefox24 + verified
firefox25 --- verified
firefox26 --- verified

People

(Reporter: rshimazu, Assigned: bdahl)

References

Details

(Keywords: regression, Whiteboard: [pdfjs-c-rendering][pdfjs-d-annoations][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/3610)

Attachments

(4 files)

Attached file annotation-tx2.pdf
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130629 Firefox/24.0 (Nightly/Aurora)
Build ID: 20130629004016

Steps to reproduce:

With Aurora (Firefox 24.0 a2) and with Firefox beta(23.0), I accessed to the following pdfs.
http://www.broadband-xp.com/test/pdfjs/annotation-tx2.pdf
http://www.broadband-xp.com/test/pdfjs/annotation-tx3.pdf



Actual results:

While Firefox beta(23.0) (PDF.js: 0.8.47) handles form properly,  Aurora(Firefox 24.0 a2) with PDF.js: 0.8.229 can not handle it properly.
With Aurora Form annotation background colors and border colors are not reflected, and  it does not handle multiple-lines annotations properly.


Expected results:

If you open it with Firefox beta or with Adobe Reader, you will see blue background and green borders. But if you open it with pdf.js of Firefox 24.0 a2(PDF.js: 0.8.229), you just see white background and no border.

If you open annotation-tx3.pdf (multi-lines annotation example) with Adobe Reader or with Firefox beta, 4 line comments are shown.
On the other hand if you open it with pdf.js of Firefox 24.0 a2(PDF.js: 0.8.229), there is just one line and annotation is positioned in the middle of the form elements. It should be positioned in the top of the form elements as Adobe Reader.
Attached file annotation-tx3.pdf
An example PDF with multi-lines form texts. Firefox 24 a2 can not handle this form properly while Firefox beta(23.0) has no problem at all.
Attachment #771327 - Attachment mime type: application/octet-stream → application/pdf
Attachment #771329 - Attachment mime type: application/octet-stream → application/pdf
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 741239
This is not a duplicate of bug 741239.
My report says that in my examples annotation itself is displayed but

1. Background color is not correct.
2. Border color is not correct.
3. If form field texts have two or more lines with line feeds,
the form field texts are not shown properly.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9115d8b717e1&tochange=0414d6d0f60d

Bug 878897 - Update pdf.js to version 0.8.229. r=bdahl
Blocks: 878897
Component: Untriaged → PDF Viewer
Keywords: regression
Status: UNCONFIRMED → NEW
Ever confirmed: true
Since pdf.js v0.8.211, the problem started.
Until pdf.js v0.8.207, there was no problem.

I am afraid that
Commit:
https://github.com/mozilla/pdf.js/commit/7b6d247fbc7b2e1d1fd4615a6ebb8f1282939173
is the cause.
Priority: -- → P2
Whiteboard: [pdfjs-c-rendering][pdfjs-d-annoations]
Assignee: nobody → bdahl
I checked this bug with Firefox 24.0 beta1 today and found this bug has not been fixed yet. I am afraid that Firefox 24.0 stable version is to be released in September without this bug being fixed.
Needinfo'ing :bdahl here for next steps here given we only have a couple more beta's to land patches for Fx24.
Flags: needinfo?(bdahl)
Waiting for review on https://github.com/mozilla/pdf.js/pull/3610. Then I'll uplift.
Flags: needinfo?(bdahl)
Whiteboard: [pdfjs-c-rendering][pdfjs-d-annoations] → [pdfjs-c-rendering][pdfjs-d-annoations][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/3610
Attached patch aurora patchSplinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 878897
User impact if declined: some types of annotations will be displayed incorrectly
Testing completed (on m-c, etc.): in pdf.js developer extension for 1 week
Risk to taking this patch (and alternatives if risky): low risk, content permission js changes
String or IDL/UUID changes made by this patch: none
Attachment #797932 - Flags: review?(ydelendik)
Attachment #797932 - Flags: approval-mozilla-aurora?
Attached patch beta patchSplinter Review
[Approval Request Comment]
see above
Attachment #797935 - Flags: review?(ydelendik)
Attachment #797935 - Flags: approval-mozilla-beta?
needinfo'ing Yury here to help with urgent review as this will need to be landed for our next beta , going to build Monday morning PT.

:bdahl, is nightly unaffected or fixed here ?
Flags: needinfo?(ydelendik)
Flags: needinfo?(bdahl)
Attachment #797935 - Flags: review?(ydelendik) → review+
Attachment #797932 - Flags: review?(ydelendik) → review+
Comment on attachment 797935 [details] [diff] [review]
beta patch

Spoke to :bdahl on this, the pdf.js update on m-c should happen soon.I am approving this is parallel for branches to make sure we get this in our next beta going to build Monday.
Attachment #797935 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #797932 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Flags: needinfo?(ydelendik)
Flags: needinfo?(bdahl)
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-aurora/rev/5994a14785f2
https://hg.mozilla.org/releases/mozilla-beta/rev/d15755cbe3cd

Fixed on trunk by bug 912006.
Status: NEW → RESOLVED
Closed: 7 years ago7 years ago
Depends on: 912006
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
Sorry, I am not good at English.
What is the meaning of "Target Milestone: --- → Firefox 26"?

Isn't this fix included in Firefox 24?
Will the next Firefox 24 release version still be affected by this bug?
(In reply to rshimazu from comment #14)
> Sorry, I am not good at English.
> What is the meaning of "Target Milestone: --- → Firefox 26"?
The issue is fixed in Firefox 26

> Isn't this fix included in Firefox 24?
Yes. The fix is uplifted to Firefox 24

> Will the next Firefox 24 release version still be affected by this bug?
No. See "status-firefox24: fixed" tracking flag.
Verified fixed using the testcases on FF 24b9, 25.0a2 (2013-09-05), 26.0a1 (2013-09-05) Win 7
You need to log in before you can comment on or make changes to this bug.