Attachment P7M not showing

NEW
Unassigned

Status

Thunderbird
Message Reader UI
4 years ago
7 months ago

People

(Reporter: Gianluca S., Unassigned)

Tracking

23 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 771404 [details]
an email that I sent to me to reproduce the issue

User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.52 Safari/537.36 OPR/15.0.1147.100 (Edition Next)

Steps to reproduce:

Click on recieved email


Actual results:

the email doesn't show attachments


Expected results:

show the attachment

Updated

4 years ago
Attachment #771404 - Attachment mime type: application/octet-stream → text/plain
Could you please attach here your attachment in order to reproduce the problem ?
(Reporter)

Comment 2

4 years ago
Created attachment 774729 [details]
Just the emali attachment

this is a simple text file but I changed the extension to .pdf.p7m to trigger the bug.
If I attach the same file with another extension everything works fine
I confirm this in Thunderbird 17.0.7 Win 7 x64.
Initially when the email is unread, the attachment icon is displayed next to the subject, but after clicking on it the attachment disappears.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

3 years ago
I confirm this bug, that shows no activity since 2013, but it's still there.

It's clearly in connection with #243833 (duplicate?), but since the
latter is now closed, i write here. Looks like an italian specific problem
and at least #243833 propose a workaround but the root problem it's far from
being solved.  Here in Italy it's really a PITA and makes TB unreliable
from the user POV.
I became aware of this bug because i've heard a collegue discussing with a
customer about a missing attachment, and the customer saying that it was
there.

I'd like to expand the problems presented here, showing more weirdness
related to the p7m handling that i've found in these days.

- When the bug submitter said "the email doesn't show attachments", he means
  that the email looks without attachment. In other word, the user doesn't
  know that the mail he had received has one or more attachments.

- Not all Thunderbird client show this bug. Namely not all Thunderbirs i've
  tested hide p7m attachments.
  Using the same mail, with the same attachment:
  * TB 24.6.0-esr under WinXP hide the p7m attachment;
  * The previous PC upgraded to 31.4.0, keep on hiding the p7m attachment;
  * My Debian Linux box (32 bit) at work with 31.4.0 (official Debian
    package), hide the p7m attachment. But strangely i'm sure that initially
    it was visible then, i don't know why and when, it started hiding p7m
    attachments. Now i can see the attachment only if, as suggested in
    #243833, i create and set the following key in about:config:
    mailnews.p7m_external=true
  * My Debian Linux box at home with 31.4.0 (official Debian package),
    almost identical to my Debian at work but 64 bit, with my surprise,
    *shows* correctly p7m attachments.
  * Two PCs with Windows 7 (one 32 bit, one 64 bit) correctly shows the p7m
    attachment.

- Thunderbird clients that hide p7m attachment, also fail to mark the
  message read. You have to do it manually, for example with "m".

- Thunderbird clients that hide p7m attachment, initially shows the
  attachment clip icon, in the mail list pane. Whenever you click on the
  message, the clip icon disappears.

- Thunderbird clients that hide p7m attachment, don't show also any other
  attachment in the message, which, i believe, increase the gravity of this
  bug.
  For example i've seen a message with a p7m and and an xls file attached:
  both are not showed.

- The problem looks indipendent from the sender mail program: i've tested
  mail sent from Lotus Domino, from a Kerio Mail Server web client and from
  Thunderbird. No difference.

- The problem looks indipendent from the content of the attached p7m file:
  i've tried to send myself a mail with an empty p7m file and also a text
  file with "ciao ciao" as contents and p7m as extension. In both cases my
  Debian box doesn't show the attachment.

- If you try to forward or edit as new the message, the attachment show up.
  But if you try to save them by right-clicking and selecting "Open", the
  filename is somewhat lost. For example i have a mail with a p7m and an xls
  attachment: for the first TB wants to save a "nsmail.bin" file and for the
  latter a "nsmail.xls" file.

To improve the situation, could it be possible at least to address these:
- While i believe that, from a user POV, it's totally unacceptable that a
  mail client doesn't show an attachment and doesn't provide any means to
  notice it, at least it might not hide attachments without p7m extension.
- Could you set "mailnews.p7m_external=false" by default? It's functionally
  the same as now, but at least we don't have to create the key first.
- Could you resolve the mark read problem? When i click on a message with a
  hiddeen p7m attachment, Thunderbird should mark it "read" as every other
  message.

Regards.

Comment 5

3 years ago
Please look at bug https://bugzilla.mozilla.org/show_bug.cgi?id=705059 , there are other considerations.
The problem is, in my opinion, that thunderbird erroneously interpretes the presence of a PKCS7 signed attachment like the whole message was encrypted.
The new feature added thanks to the effort of @intendentedelleacque in https://bugzilla.mozilla.org/show_bug.cgi?id=243833, and the new TB add-in "P7MON" can modify Thunderbird behaviour to handle P7M attachment correctly.
As I can see from discussion in the https://bugzilla.mozilla.org/show_bug.cgi?id=243833 the TB developers have added this feature but with reluctance.

Comment 6

2 years ago
This is a huge problem and still present in TB 38.4.0. Bug #243833 is marked as "fixed", but a hidden preference must be added and set to true (and I knew about that only after deep searching the TB bug database.......).

In Italy .p7m files are getting more and more popular, because the new Electronic Invoice format expects signed XML files (in XAdES-BES or CAdES-BES format) to be exchanged between people. In the latter format, they are sent as .p7m files, which are simply not shown by Thunderbird. This generates a lot of confusion among people.

Comment 7

2 years ago
I confirm the bug with TB 38.5.0 on a Gentoo linux box.
Attachments are shown in the message list, but disappear when opening the message (although they are still there as you can see in several ways, including looking at the source file).
Setting "mailnews.p7m_external=false" in about:config fixes the problem for me.

Comment 8

2 years ago
I was meaning: setting "mailnews.p7m_external=true" (not false) in about:config fixes the problem for me.

Comment 9

a year ago
Thunderbird 38.8.0 on RHEL7/CentOS7 (both!) shows the same bug. Cannot be fixed by setting mailnews.p7m_external to false since in this version the config editor does not provide mailnews.p7m_external in the list of available options.

Comment 10

a year ago
@Veselin: it doesn't show up. You have to create that key yourself (boolean).

Comment 11

9 months ago
Same problem here. I'm on Thunderbird 45.6.0 on Mac OSX 10.11.6.
The p7m attachment does not show up, nor other documents attached to the email are shown.
I can see and download all the attachments of the same email by accessing it using a web client.

Comment 12

7 months ago
I can't believe this bug is not solved yet and that Thunderbird is unable to manage and show p7m attachments. Unbelievable.

Comment 13

7 months ago
The solution suggested by Daniele worked for me. Thanks!

Comment 14

7 months ago
(In reply to plecto from comment #12)
> I can't believe this bug is not solved yet and that Thunderbird is unable to
> manage and show p7m attachments. Unbelievable.

yes, Unbelievable!

I hope someone can fix the problem: 
It seems as ThunderBird does not recognize the encripted attached document, but interprets it as a signature certificate of the message.

I have seen that sending via ThunderBird a message with a document.p7m file attached, the message and is attachment is correctly dislayed on a ThunderBird receiving client.
The (same) message sent via Outlook shows the problems above mentioned (on a ThunderBird receiving client only): namely the message seems initially to have an attachment but, when clicked on, the attachement disappears and the message continue to be marked as unread, despite the evidence that it has been read correctly (excluding the hidden attachment).

Thanks, if someone can face this bug!

Comment 15

7 months ago
(In reply to ViciDiG from comment #14)
> (In reply to plecto from comment #12)

I have found this suggestion (from another similr bug solved):

>In order to simplify italian users, the P7MON Thunderbird extesnsion is available on the Mozilla addon site >(https://addons.mozilla.org/it/thunderbird/addon/p7mon/)
>
>This extension creates and sets the new hidden preference at installation time, so no user intervention is needed

>Giulia

It has worked fine for me
Thanks

Comment 16

7 months ago
(In reply to ced from comment #10)
> @Veselin: it doesn't show up. You have to create that key yourself (boolean).

I don't know what Thunderbird version and platform do you use, but setting this variable does not remove the bug in Thunderbird 45.8.0, on CentOS 7, x86_64. Is there any OpenSource e-mail S/MIME solution that works fine at the moment?
You need to log in before you can comment on or make changes to this bug.