Closed Bug 890382 Opened 11 years ago Closed 11 years ago

Move IDBVersionChangeEvent to Web IDL bindings completely

Categories

(Core :: Storage: IndexedDB, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla25

People

(Reporter: ehsan.akhgari, Assigned: ehsan.akhgari)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(2 files)

      No description provided.
The current event doesn't adhere to the spec (it's missing the ctor).
Summary: Move IDBVersionChangeEvent to Web IDL bindings → Move IDBVersionChangeEvent to Web IDL bindings completely
Attached patch Patch (v1)Splinter Review
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #771476 - Flags: review?(bugs)
Attachment #771476 - Flags: review?(bugs) → review+
I cannot reproduce the test failure locally.  Do any of you guys have an idea why?
Flags: needinfo?(bent.mozilla)
Flags: needinfo?(Jan.Varga)
Because the IDBVersionChangeEvent constructor is not defined on the xpcshell global?
Rather, I'm surprised that the test doesn't fail locally.
Depends on: 890364
TEST_PATH=dom/indexedDB/test/unit/test_setVersion_events.js EXTRA_TEST_ARGS=--verbose make xpcshell-tests

TEST-PASS | /Users/varga/Sources/Marvin/obj-ff-dbg/_tests/xpcshell/dom/indexedDB/test/unit/test_setVersion_events.js | [testSteps : 158] 3 == 3
JS Component Loader: ERROR /Users/varga/Sources/Marvin/obj-ff-dbg/_tests/xpcshell/dom/indexedDB/test/unit/test_setVersion_events.js:160
                     TypeError: IDBVersionChangeEvent is not a constructor
<<<<<<<
TEST-UNEXPECTED-FAIL | Received SIGINT (control-C) during test execution
Flags: needinfo?(Jan.Varga)
Attached patch fixSplinter Review
This fix works perfectly (thanks to bz).

It actually seems that we can get rid of InitWindowless() altogether!
Thanks!
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #10)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/44f8f3e450bc

I had to comment out |const IDBVersionChangeEvent = Ci.nsIIDBVersionChangeEvent| in dom/indexedDB/test/unit/head.js

That's a part of bug 890405, I thought you would land that one first.
oh, never mind, the changeset contains the fix
(In reply to comment #12)
> oh, never mind, the changeset contains the fix

Yeah, I'm still waiting for a review on that bug...
https://hg.mozilla.org/mozilla-central/rev/44f8f3e450bc
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: