[User story][CDMA] Display CDMA information

RESOLVED FIXED

Status

Firefox OS
RIL
P1
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: khu, Unassigned)

Tracking

unspecified
x86
Mac OS X
Dependency tree / graph
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:koi+, firefox26 fixed)

Details

(Whiteboard: [ucid:CDMA12, FT:RIL, KOI:P1])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User story: 

As a user, I need an UI support to display CDMA info record as defined in C.S0005 section 3.7.5.1 and extended Display Info Rec as defined in C.S0005 section 3.7.5.16

Acceptance criteria: 

User should be able to display CDMA info record as defined in C.S0005 section 3.7.5.1 and extended Display Info Rec as defined in C.S0005 section 3.7.5.16
(Reporter)

Updated

5 years ago
blocking-b2g: --- → koi+

Updated

5 years ago
Depends on: 882985

Updated

5 years ago
Depends on: 891755
(Reporter)

Updated

5 years ago
Flags: in-moztrap?
QA Contact: echu

Comment 1

5 years ago
Hi Sandip,

Could you provide more detail about how this should be seen for end user? How to trigger it? What are contents shown on the UI?
Flags: needinfo?(skamat)

Comment 2

5 years ago
@echu, the CDMA display information record needs to be shown as a dialog box just like how a dialog box is shown for presidential alerts by cell broadcast feature in FFOS.

The CDMA signal info record could either be played by dialer using the tone generator that it already has or by RIL. 

Rest of the info records are not supported even by Android at this time so I am not sure if they would need to be for FFOS. Sandip, could you please help find out if the rest of the info records need to be supported?

Comment 3

5 years ago
(In reply to Anshul from comment #2)
> @echu, the CDMA display information record needs to be shown as a dialog box
> just like how a dialog box is shown for presidential alerts by cell
> broadcast feature in FFOS.
> 
> The CDMA signal info record could either be played by dialer using the tone
> generator that it already has or by RIL. 
> 
> Rest of the info records are not supported even by Android at this time so I
> am not sure if they would need to be for FFOS. Sandip, could you please help
> find out if the rest of the info records need to be supported?

At this time (till partners confirm) we will leave it to be consistent with Android implementations.
Flags: needinfo?(skamat)

Comment 4

5 years ago
(In reply to Anshul from comment #2)
> @echu, the CDMA display information record needs to be shown as a dialog box
> just like how a dialog box is shown for presidential alerts by cell
> broadcast feature in FFOS.
How to trigger this CB message? Do you have example screenshot?

> The CDMA signal info record could either be played by dialer using the tone
> generator that it already has or by RIL. 
Can you check is the attached screenshot is what you are asking for? It's triggered by dialer on android phone after dialing customized code(ex:##1234). It will show the signal of 1x, EVDO and GPS.

Comment 5

5 years ago
Created attachment 780236 [details]
Screenshot.png
(Reporter)

Updated

5 years ago
Priority: -- → P1

Comment 6

5 years ago
@echu, I don't think there is a specification on how to display the CDMA info record at least nothing that I could find in C.S0005 section 3.7.5.

I think all we need is a way to display the information with in the info record to the user. How it is done can be Moz specific, I am just telling based on how Android displays the information.
(Reporter)

Updated

4 years ago
Flags: in-moztrap? → in-moztrap?(echu)
(Reporter)

Updated

4 years ago
Whiteboard: [ucid:CDMA12] → [ucid:CDMA12], [FT:RIL]
(Reporter)

Updated

4 years ago
Whiteboard: [ucid:CDMA12], [FT:RIL] → [ucid:CDMA12, FT:RIL, KOI:P1]
(Reporter)

Comment 7

4 years ago
Hi, Anshul, can you provide some examples for us to know what to display? We still don
't know what to display yet.
Flags: needinfo?(anshulj)

Comment 8

4 years ago
@khu, let me try to run this feature on Android and get some snapshot. I am not available for most part of this week so please expect a reply by end of this week.
Flags: needinfo?(anshulj)

Comment 9

4 years ago
(In reply to Anshul from comment #8)
> @khu, let me try to run this feature on Android and get some snapshot. I am
> not available for most part of this week so please expect a reply by end of
> this week.
Anshul, do you have any update for this snapshot?

Updated

4 years ago
Flags: needinfo?(anshulj)

Comment 10

4 years ago
Sorry Ken, I didn't. Let me try to get some test done tomorrow and get you the snapshots. Thanks for the reminder.
Flags: needinfo?(anshulj)

Comment 11

4 years ago
Sandip, we don't have the real environment to do this test. I am thinking if we can only provide webAPI for this bug. And leave partner to finish the Gaia part. The another way is that we do the Gaia part when we have a real partner and know our partner's exactly requirement. Does it make sense to you?
Flags: needinfo?(skamat)

Comment 12

4 years ago
Ken, you guys can finish the gaia part and I can help test it internally. I am still working with the test teams to get me a setup to run this test.

Comment 13

4 years ago
(In reply to Anshul from comment #12)
> Ken, you guys can finish the gaia part and I can help test it internally. I
> am still working with the test teams to get me a setup to run this test.
We need the snapshots to know how to implement this in Gaia. Thanks.
Flags: needinfo?(skamat)

Comment 14

4 years ago
Ken, I am still working with our internal test teams to try to reproduce this scenario. From the code scan it seems like the display information should be shown just like Cell broadcast message, snapshot at https://bug848372.bugzilla.mozilla.org/attachment.cgi?id=756260.

Comment 15

4 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=891755#c9

Since we don't have a detail information to show the information record, I suggest to remove the Gaia implementation from this user story.  We can start Gaia's implementation after having detail information.
Flags: needinfo?(skamat)
This could just be vanilla dialog box containing the network text with an OK/dismiss button at the bottom iirc.  Lets implement that in Gaia for now and if we need to tune the UX later then that's fine.
Flags: needinfo?(anshulj)

Comment 17

4 years ago
Ken, I agree with Micahel that we can just display a dialog box with text message from the network. There is no spec I could find that says how to display the message so a generic message for now would do.
Flags: needinfo?(anshulj)

Comment 18

4 years ago
Vicamo, if we are based on the information of comment 16 and comment 17, is it fine for you to keep reviewing bug 882985?
Flags: needinfo?(vyang)
(In reply to Ken Chang from comment #18)
> Vicamo, if we are based on the information of comment 16 and comment 17, is
> it fine for you to keep reviewing bug 882985?

Ok, will do.
Flags: needinfo?(vyang)

Updated

4 years ago
Flags: needinfo?(skamat)

Comment 20

4 years ago
Not knowing how to setup the test environment at current stage, no test case is ready for now.
Flags: in-moztrap?(echu) → in-moztrap-
(Reporter)

Comment 21

4 years ago
This should be done in this week.

Updated

4 years ago
Component: General → RIL

Comment 22

4 years ago
Add dependent bugs are close, close this user story.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-firefox26: --- → fixed
You need to log in before you can comment on or make changes to this bug.