Closed Bug 891755 Opened 8 years ago Closed 8 years ago

[Gaia] Need to display the record information for CDMA.

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:koi+)

RESOLVED FIXED
blocking-b2g koi+

People

(Reporter: kchang, Assigned: rexboy)

References

Details

(Whiteboard: [UX ETA:9/6], [FT:RIL], [Sprint:4])

Attachments

(1 file)

Android just shows a dialog box on the UI with the information. Firefox OS already has similar capabilities to display message box as part of cell broadcast https://github.com/mozilla-b2g/gaia/pull/10140.
Blocks: 890826
Depends on: 882985
Assignee: nobody → gsvelto
Will use the same way just like cell broadcast message. 

Ivan and Candice, it looks like something in system front end and/or system platform. Can you make sure it's under your radar? Thanks.
blocking-b2g: --- → koi+
Flags: needinfo?(itsay)
Flags: needinfo?(cserran)
Neo, I need your input about the UX flow on this so that we can know which app to support on this.
Flags: needinfo?(itsay) → needinfo?(nhsieh)
Whiteboard: [UX ETA:9/6]
Whiteboard: [UX ETA:9/6] → [UX ETA:9/6], [FT:RIL], [Sprint:4]
Because there aren't CDMA network in NW, Arthur will help this bug in Taipei.
Assignee: gsvelto → arthur.chen
Gecko will send a 'cdma-info-rec-received' system message with the record itself as the parameter.
Steve will help on non-settings CDMA gaia work.
Assignee: arthur.chen → schung
Made some investigation and got details to confirm:
- Do we need to show it *All the same way* with CB messages? CB messages shows with
  below behavior per bug 877751:
   * On locked, it shows a notification which can be tapped to get into a modal dialog.
   * On normal using, the message is shown directly on modal dialog.
   * Notification sound is played when showing message.
- We need to decide a title for the modal dialog.
Anshul, any comment, thanks.
Flags: needinfo?(anshulj)
Reassign to Rex for this feature.
Assignee: schung → rexboy
@rexboy, I don't know if there is a spec that specifies how this message needs to be shown. Perhaps we can start with something simple and then improve on it when we get more information from the carrier.

From the Android code it doesn't seem like the message is not shown in the lock screen but I am not so sure. I am still trying to find a GCF test setup on which I can reproduce the issue to get actual snapshot but this is not a very common use case and hence difficulty in trying to reproduce the scenario.
Flags: needinfo?(anshulj)
I can try to implement it making use of the codes of CB message first. Let me take a check
with Neo first. I think it may be more clear if we have some reproduce step or use case
for UX to make decision (seems we don't have this yet?)
WIP
https://github.com/rexboy7/gaia/commit/d95f250a7f8cc0cffe1a8629f862fa4b1678efe7

There are some test codes inside so it displays something automatically in half a mintes after booting.
The patch make use of the cell broadcast notification so it displays message just like bug 877751.
Attached file patch
This patch refactors original message window of cellbroadcasting to be used on both cellbroadcast and cdma.
Functional works for me. I left some test code inside it since we have no CDMA devices to test here.
The format of cdma-record-info comes from discussion with Chuck Lee earlier.

I'm not sure if we need to add unit-test here.. I can do it if necessary.

Alive and Dale would you take a look on it?
Attachment #803403 - Flags: review?(alive)
Attachment #803403 - Flags: feedback?(dale)
Comment on attachment 803403 [details]
patch

Quality work week + New module = Unit test wanted!
If you have difficulties on writing unit tests please let me know.
Attachment #803403 - Flags: review?(alive)
Comment on attachment 803403 [details]
patch

Just done on unit test and removed manual test part.
May you take a look again?
Attachment #803403 - Flags: review?(alive)
Comment on attachment 803403 [details]
patch

I havent touched this code in a while and not solid on the requirements, but mostly looks good to me and happy to defer details to alive
Attachment #803403 - Flags: feedback?(dale) → feedback+
Comment on attachment 803403 [details]
patch

r+ be careful to travis state. thanks.
Attachment #803403 - Flags: review?(alive) → review+
master
https://github.com/mozilla-b2g/gaia/commit/c4a0b1980784c48b5b720932ae8666a6ae4774ff

Alive and Dale thanks for your reviewing!

The travis error seems unrelated so I merged it directly.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Flags: needinfo?(nhsieh)
Flags: needinfo?(cserran)
You need to log in before you can comment on or make changes to this bug.