Last Comment Bug 891081 - In 2.19 the keystrokes of shift-cmd-p do not enable spell check
: In 2.19 the keystrokes of shift-cmd-p do not enable spell check
Status: RESOLVED FIXED
: late-l10n, regression
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: SeaMonkey 2.17 Branch
: x86 Mac OS X
: -- normal (vote)
: seamonkey2.22
Assigned To: neil@parkwaycc.co.uk
:
Mentors:
Depends on:
Blocks: 837510 897233
  Show dependency treegraph
 
Reported: 2013-07-08 13:05 PDT by reed1003
Modified: 2013-07-23 14:29 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
wontfix
fixed
fixed
fixed


Attachments
Possible patch (1.02 KB, patch)
2013-07-11 16:08 PDT, neil@parkwaycc.co.uk
philip.chee: review+
iann_bugzilla: approval‑comm‑aurora+
bugspam.Callek: approval‑comm‑beta+
Details | Diff | Review

Description reed1003 2013-07-08 13:05:25 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:20.0) Gecko/20100101 Firefox/20.0 SeaMonkey/2.17.1 (Beta/Release)
Build ID: 20130410205209

Steps to reproduce:

shift-cmd-p do not work for spell check in version 2.19


Actual results:

nothing


Expected results:

spell checking
Comment 1 Phoenix 2013-07-09 01:39:05 PDT
What is in Error Console? Expecting dupe for Bug 887010
Comment 2 reed1003 2013-07-09 05:31:09 PDT
The command opens up a browser window with a reference to private browsing.
Comment 3 Philip Chee 2013-07-09 14:21:54 PDT
Probably caused by Bug 837510 Add File - New - Private Window menuitem

It looks like cmd-shift-P is now supposed to open a private browsing window.
Comment 4 Tony Mechelynck [:tonymec] 2013-07-09 14:23:49 PDT
This is a classic case of hotkey collision. Hopefully "Check spelling" was moved to another hotkey but I don't know which one. (Private browsing is a recent invention.)

Ctrl+Shift+P is "New → Private Browsing Window" on Linux also. I don't see any hotkey mentioned for the various spell-related menuitems.

Mozilla/5.0 (X11; Linux i686 on x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 SeaMonkey/2.22a1 ID:20130709003001 c-c:c1021b0b890c m-c:f2de2035f0af
Comment 5 reed1003 2013-07-09 14:25:24 PDT
Boy, I'd sure like a keystroke feature for spell check.  Been using keystrokes for many tasks for years.
Comment 6 Tony Mechelynck [:tonymec] 2013-07-09 14:42:25 PDT
(In reply to reed1003 from comment #5)
> Boy, I'd sure like a keystroke feature for spell check.  Been using
> keystrokes for many tasks for years.

It seems you are ripe for the keyconfig extension. That extension is not found at AMO, but you can get the latest version from the first link at http://forums.mozillazine.org/viewtopic.php?t=72994&f=48 which is also a mutual-help forum about defining keys for whatever you want them to do (if possible).
Comment 7 neil@parkwaycc.co.uk 2013-07-09 15:58:02 PDT
(In reply to Tony Mechelynck from comment #4)
> This is a classic case of hotkey collision. Hopefully "Check spelling" was
> moved to another hotkey but I don't know which one. (Private browsing is a
> recent invention.)

No, it wasn't, and it needs to be, I suppose. Accel+Shift+S is used by Publish, but we could move that to Accel+Shift+H perhaps, unless someone else has any other preference?
Comment 8 neil@parkwaycc.co.uk 2013-07-10 11:34:52 PDT
Ah, so the key is shared with Thunderbird, so it's not easily changeable. I guess we have to change the Private Browsing key instead, which is a shame, because it's the key Firefox uses...
Comment 9 Stefan [:stefanh] 2013-07-10 14:34:34 PDT
Looking at what other browsers do (haven't verifyed myself, just did some quick search):

IE and Firefox: accel+Shift+P
Chrome and Opera: accel+Shift+N

So one option would be to use accel+Shift+N which would in some way be more logical if you look at what the non-shift key combo is.
Comment 10 Stefan [:stefanh] 2013-07-10 14:38:58 PDT
(In reply to Stefan [:stefanh] from comment #9)
> Looking at what other browsers do (haven't verifyed myself, just did some
> quick search):
> 
> IE and Firefox: accel+Shift+P
> Chrome and Opera: accel+Shift+N

Forgot to menation that Safari doesn't seem to have a shortcut for this...
Comment 11 Stefan [:stefanh] 2013-07-11 01:53:38 PDT
Oops, Accel+Shift+N is New Composer Page
Comment 12 neil@parkwaycc.co.uk 2013-07-11 16:08:45 PDT
Created attachment 774329 [details] [diff] [review]
Possible patch

Consensus seems to be to change the key to Ctrl+Shift+B instead.
Comment 13 Philip Chee 2013-07-14 07:53:52 PDT
Comment on attachment 774329 [details] [diff] [review]
Possible patch

r=me for CTRL-SHIFT-B
Comment 14 neil@parkwaycc.co.uk 2013-07-18 15:52:51 PDT
Pushed comm-central changeset d7237cd27263.
Comment 15 neil@parkwaycc.co.uk 2013-07-18 15:55:04 PDT
Comment on attachment 774329 [details] [diff] [review]
Possible patch

[Approval Request Comment]
Regression caused by (bug #): 837510
User impact if declined: Advertised spellcheck keyboard shortcut doesn't work
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky): Low, Private Browsing is a new feature so hopefully nobody will mind that the key changes
String changes made by this patch: One command key
Comment 16 Ian Neal 2013-07-18 16:02:58 PDT
Comment on attachment 774329 [details] [diff] [review]
Possible patch

a=me assuming l10n notification is made
Comment 17 neil@parkwaycc.co.uk 2013-07-21 14:55:50 PDT
http://hg.mozilla.org/releases/comm-aurora/rev/e36eb1b70822
Comment 18 Justin Wood (:Callek) 2013-07-21 21:04:22 PDT
(In reply to Ian Neal from comment #16)
> Comment on attachment 774329 [details] [diff] [review]
> Possible patch
> 
> a=me assuming l10n notification is made

adding late-l10n keyword for anyone who follows that. Thread is at https://groups.google.com/d/msg/mozilla.dev.l10n/jA2CLqUuN8c/4JwpmUIa6wYJ
Comment 19 Justin Wood (:Callek) 2013-07-21 21:04:50 PDT
Comment on attachment 774329 [details] [diff] [review]
Possible patch

Review of attachment 774329 [details] [diff] [review]:
-----------------------------------------------------------------

a-beta=me a-CLOSED_TREE=me
Comment 20 neil@parkwaycc.co.uk 2013-07-22 11:48:39 PDT
http://hg.mozilla.org/releases/comm-beta/rev/6b01d727384d

Note You need to log in before you can comment on or make changes to this bug.