Closed Bug 891118 Opened 6 years ago Closed 6 years ago

Some about: pages are in English in localized builds

Categories

(Firefox for Android :: General, defect)

23 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 25
Tracking Status
firefox22 --- unaffected
firefox23 - verified
firefox24 - verified
firefox25 - verified
fennec 23+ ---

People

(Reporter: unghost, Assigned: Pike)

References

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

Some about: pages are in English in localized build in Fx 23 Beta 3, like:
about:support, about:crashes, about:mozilla, about:plugins, about:healthreport and about:telemetry
Looks like it's been caused by Bug 792077
Blocks: 792077
Severity: minor → normal
tracking-fennec: --- → ?
No longer depends on: 792077
Version: unspecified → Firefox 23
about:healthreport
String are outside of Firefox and the mobile version is still not ready (Fx22 doesn't have that URL enabled).

Confirming the other pages though.

about:support
/toolkit/locales/en-US/chrome/global/aboutSupport.dtd
/toolkit/locales/en-US/chrome/global/aboutSupport.properties

about:crashes
/toolkit/locales/en-US/crashreporter/crashes.dtd
/toolkit/locales/en-US/crashreporter/crashes.properties

about:mozilla
/toolkit/locales/en-US/chrome/global/mozilla.dtd

about:plugins
/dom/locales/en-US/chrome/plugins.properties

about:telemetry
/toolkit/locales/en-US/chrome/global/aboutTelemetry.dtd
/toolkit/locales/en-US/chrome/global/aboutTelemetry.properties
re about:healthreport, one string is inside the browser, but we're covered for that,http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/aboutHealthReport.xhtml
I have tested today the localization on Firefox for Android 23 Beta 4 on Asus Eee Transformers (Android 4.0.4). I did not encountered any issues on about:firefox pages. Can you provide more details on which pages using which language, or if you used the multi languages build. Also there is no Fx 23 Beta 3 for android.
(In reply to Paul Feher from comment #3)
> I have tested today the localization on Firefox for Android 23 Beta 4 on
> Asus Eee Transformers (Android 4.0.4). I did not encountered any issues on
> about:firefox pages. Can you provide more details on which pages using which
> language, or if you used the multi languages build. Also there is no Fx 23
> Beta 3 for android.

Please read comment 1, nobody found problems with about:firefox (not sure where you got that) ;-)
Please see https://bugzilla.mozilla.org/show_bug.cgi?id=890726#c7 for triage's concerns about bug 792077 in FF23.
Taking, and my reply to the concerns is also in bug 792077.
Assignee: nobody → l10n
Just more files, I'm fixing both this bug and the validation bug 890726 in one patch, as that's easier.

I tested the about pages and the validation on the simulator, aside from about:crashes, which isn't enabled on my local build.
Attachment #773937 - Flags: review?(mark.finkle)
tracking-fennec: ? → 23+
Attachment #773937 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/c1443b4d7e51
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
We'll look at an approval request, but no need to track given discussion in bug 890726.
It'd be great if we could get verification on trunk, Italian and French are good languages to test.

Then I'll request uplifts.
Keywords: verifyme
I'm on it, waiting for a new build (2013-07-12 doesn't have the fix)
Verified on Firefox 25.0a1 (2013-07-13)

about:support
about:crashes
about:mozilla
about:plugins
about:telemetry

All these pages appear correctly localized
Status: RESOLVED → VERIFIED
Comment on attachment 773937 [details] [diff] [review]
fix about pages and validation, too

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 792077 made us do sparse l10n for toolkit, and too sparse
User impact if declined: several about: pages aren't localized
Testing completed (on m-c, etc.): verified on nightly
Risk to taking this patch (and alternatives if risky): low, just including more existing files from desktop
String or IDL/UUID changes made by this patch: no new strings, just packaging existing strings.
Attachment #773937 - Flags: approval-mozilla-beta?
Attachment #773937 - Flags: approval-mozilla-aurora?
Attachment #773937 - Flags: approval-mozilla-beta?
Attachment #773937 - Flags: approval-mozilla-beta+
Attachment #773937 - Flags: approval-mozilla-aurora?
Attachment #773937 - Flags: approval-mozilla-aurora+
Already landed on Aurora.
https://hg.mozilla.org/releases/mozilla-aurora/rev/69bdfec92dba

Pike, if you're going to push to the release branches, you must update the bug accordingly per the tree rules so others don't waste their time attempting to do the same.
Verified on Aurora 24.0a2 (2013-01-17)
Verified fixed on:
Build: Firefox for Android 24.0a2( 2013-07-17)
Device: Acer Iconia
OS: Android 3.2
Keywords: verifyme
https://hg.mozilla.org/releases/mozilla-beta/rev/3b4a649104aa, landed on beta, setting status-firefox23 to fixed.
Verified fixed on:
Build: Firefox for Android 23.0b8(2013-07-23)
Device: Samsung Galaxy R
OS: Android 2.3
Blocks: 915721
You need to log in before you can comment on or make changes to this bug.