Closed Bug 891345 Opened 6 years ago Closed 6 years ago

[User Story][Settings] Need an UI for calling line identification restriction

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+)

VERIFIED FIXED
blocking-b2g koi+

People

(Reporter: jaoo, Assigned: jaoo)

References

Details

(Keywords: feature, Whiteboard: [TEF][UCID:Comms29, FT:comms, KOI:P1][Sprint 1][Status: under development] u=commsapps-user c=dialer p=0)

Attachments

(6 files)

We need some bit in gaia for adding support for calling line identification restriction in the setting app. It could be ideally in the setting app under the call settings.
We need the input from our UX friends, adding ni?.
Flags: needinfo?(firefoxos-ux-bugzilla)
blocking-b2g: --- → koi?
Whiteboard: [u=commsapps-user c=dialer p=0]
Whiteboard: [u=commsapps-user c=dialer p=0] → u=commsapps-user c=dialer p=0
Attached image Screenshot 1
Screenshot 1 proposal
Attached image Screenshot 2
Screenshot 2 proposal
Attached image Screenshot 3
Screenshot 3
Flags: in-moztrap?
I'll leave the in-moztrap? here and write some test case for it after the UX pages are confirmed.
Summary: [Settings] Need an IU for calling line identification restriction → [Settings] Need an UI for calling line identification restriction
Jose, is there a need for such a setting in the UI as this is not a very used feature and also because there is an MMI code to do that already supported by commercial RIL and soon to be supported by Moz RIL.
So long as this doesn't take much work, I think there's no harm in easing the users life. Maybe the feature isn't very used because there's no UI for it :).
Clearing the team needinfo and assigning to Neo since Settings is his domain. Neo, please evaluate whether or not you believe the suggested UI is needed here.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(nhsieh)
IMHO there is a need for such setting. Android has this UI and other OSs. I would say people usually don't know about a MMI code (even about MMI codes in general) for enabling/disabling calling line identification restriction feature. We are planning to add that support through MMI code in the reference RIL implementation as well but first let user handle the feature through the setting app.
WIP. Need to get r+ in bug 888904 before requesting review here. We still need the UX team input here.
MozTrap #9013, #9014
Flags: in-moztrap? → in-moztrap+
Keywords: feature
Summary: [Settings] Need an UI for calling line identification restriction → [User Story][Settings] Need an UI for calling line identification restriction
Whiteboard: u=commsapps-user c=dialer p=0 → [UCID:Comms29, FT:comms, KOI:P1] u=commsapps-user c=dialer p=0
blocking-b2g: koi? → koi+
Whiteboard: [UCID:Comms29, FT:comms, KOI:P1] u=commsapps-user c=dialer p=0 → [TEF][UCID:Comms29, FT:comms, KOI:P1] u=commsapps-user c=dialer p=0
Comment on attachment 773947 [details]
Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/10927

Arthur, this PR adds a simple UI for allowing the user to show or hide the caller Id for outgoing calls. The UX input is still pending but I guess it won't change too much from how it is designed. Could you take a look please? Thanks!
Attachment #773947 - Flags: review?(arthur.chen)
Whiteboard: [TEF][UCID:Comms29, FT:comms, KOI:P1] u=commsapps-user c=dialer p=0 → [TEF][UCID:Comms29, FT:comms, KOI:P1][Sprint 1][Status: under development] u=commsapps-user c=dialer p=0
Attached file Call Settings.xlsx
Hi, I think some of the structures has to modify. Please check attached file.
Flags: needinfo?(nhsieh) → needinfo?(arthur.chen)
(In reply to Neo Hsieh from comment #13)
> Created attachment 779054 [details]
> Call Settings.xlsx
> 
> Hi, I think some of the structures has to modify. Please check attached file.

Hey Neo, are you suggesting to change the whole call settings structure? If so, IMHO we should file another bug to deal with this big change and land the work in this bug after landing the change. Moreover the feedback that you've provided is a bit difficult to understand (it includes even panel layout not existing yet) and prone to misunderstandings. Could you please provide some wire frames instead? Thanks.
Flags: needinfo?(nhsieh)
Yes. Because we will have more and more settings add into "Call settings" in the future. I think it's time to optimize the structure. So as you can see, I changed the structure. 
You are right. I need to create another bug to do this.  


About the feedback bug,Please see also this 
bug 851189
Flags: needinfo?(nhsieh) → needinfo?(josea.olivera)
In caller ID part. I think that is better to reduce one level.  I mean, You can jump screenshot 2. 
(Screenshot 1 (Caller ID) --> Screenshot 3 (Select))
(In reply to Neo Hsieh from comment #15)
> Yes. Because we will have more and more settings add into "Call settings" in
> the future. I think it's time to optimize the structure. So as you can see,
> I changed the structure. 
> You are right. I need to create another bug to do this.  

The question is, Must we do this UI refactor before including Caller ID settings?
Flags: needinfo?(josea.olivera)
(In reply to Neo Hsieh from comment #16)
> In caller ID part. I think that is better to reduce one level.  I mean, You
> can jump screenshot 2. 
> (Screenshot 1 (Caller ID) --> Screenshot 3 (Select))

If we do what you suggest we would delete the button in the screenshot #2, that way we change how the rest of select inputs are used in Gaia (with this button I mean). Is that what you suggest?
Having had a read of this conversation I have to agree with Noemi that we need to split the "re-doing call settings structure" into a different bug - 
this new bug should then be added to the nice to have list of the backlog for us to pick from once we have done all items that must be completed for v1.2.

891345 should continue to focus on adding caller ID settings.
Jose, we have similar UI in the settings app. Please refer to the changing language select in the Language panel.
Flags: needinfo?(arthur.chen)
Attached image Screenshot 4
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #18)
> (In reply to Neo Hsieh from comment #16)
> > In caller ID part. I think that is better to reduce one level.  I mean, You
> > can jump screenshot 2. 
> > (Screenshot 1 (Caller ID) --> Screenshot 3 (Select))
> 
> If we do what you suggest we would delete the button in the screenshot #2,
> that way we change how the rest of select inputs are used in Gaia (with this
> button I mean). Is that what you suggest?

Neo, here is a picture that shows how the caller Id item looks. Is that what you want? Thanks.
Flags: needinfo?(nhsieh)
(In reply to Arthur Chen [:arthurcc] from comment #20)
> Jose, we have similar UI in the settings app. Please refer to the changing
> language select in the Language panel.

Arthur, I've updated the code in the PR. I guess it's ready for the review. Could you take a look at it please? Thanks!
Comment on attachment 773947 [details]
Pointer to Github PR: https://github.com/mozilla-b2g/gaia/pull/10927

Thank you for the effort, Jose! r=me with comments addressed.
Attachment #773947 - Flags: review?(arthur.chen) → review+
Yes, Thank you. Looks great.
Flags: needinfo?(nhsieh) → needinfo?(josea.olivera)
Thanks Arthur and Neo!

https://github.com/mozilla-b2g/gaia/commit/c0265432b75c1586bbe0d5fd7366c680951404d6
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(josea.olivera)
Resolution: --- → FIXED
The user story has been tested with satisfactory results. 

The tests have been executed with a SIM Tuenti. We tested several movistar SIMS, but we could not activating you supplementary services to this type of SIM.
Status: RESOLVED → VERIFIED
QA Contact: rafael.marquez
Duplicate of this bug: 845715
Duplicate of this bug: 903954
You need to log in before you can comment on or make changes to this bug.