Old file not cleaned/replaced after being replaced under turbo mode

VERIFIED DUPLICATE of bug 86976

Status

Core Graveyard
Installer: XPInstall Engine
--
critical
VERIFIED DUPLICATE of bug 86976
17 years ago
2 years ago

People

(Reporter: Jimmy Lee, Assigned: dveditz)

Tracking

Trunk
mozilla0.9.3
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] no eta)

(Reporter)

Description

17 years ago
Build: 2001-07-03-06-0.9.2(WIN)

0. Launch browser with turbo mode
1. From http://jimbob/trigger3.html, click on Functional Test Case drop-down and
   choose f_addfile_notepad
2. Click Trigger case button
3. Click OK from Items to Install dialog
5. Click on close box of browser window to exit maintaining turbo mode
6. Go to Netscape directory and open subdirectory, addFile_notepad
7. Launch Notepad
8. Launch browser
9. From http://jimbob/trigger3.html, click on Functional Test Case drop-down and
   choose f_addfile_notepad_inuse
10. Click Trigger case button
11. Click OK from Items to Install dialog
12. Click on close box of browser window to exit maintaining turbo mode
13. Exit Notepad
14. Launch browser

RESULT:
Subdirectory, addFile_notepad, has notepad.old(34kb) and notepad.exe (45kb).
File, notepad.old, is not cleaned up.  If this were a DLL, then we would not
have successfully replaced the file.  Relaunching the browser would launch the
old DLL.  Restarting the machine appears to resolve the problem.

EXPECTED RESULT:
File is replaced and old files are removed.  Launching browser under turbo mode
uses new DLL(s).
(Reporter)

Comment 1

17 years ago
Nominating.  With turbo enabled, this prevents the browser to successfully
replace files.  My test case uses an exe, but the more realistic case has to be
dlls.  We won't launch the new dll's until the old one has been cleaned up.
Keywords: nsbeta1

Updated

17 years ago
Blocks: 89424

Comment 2

17 years ago
updating status whiteboard (per pdt), keywords, and target milestone.
No longer blocks: 89424
Keywords: nsbeta1 → nsbeta1+, nsBranch
Whiteboard: [PDT+]
Target Milestone: --- → mozilla0.9.3

Comment 3

17 years ago
This sounds like a dup of the smartupdate bug.  If it's a unique bug, can you
fill in the whiteboard with eta info?
Whiteboard: [PDT+] → [PDT+] no eta
(Assignee)

Comment 4

17 years ago
Isn't this a duplicate of bug 86976? going once.... going twice...

If not a duplicate it's similar enough that I should work on it.
Assignee: syd → dveditz

Comment 5

17 years ago
Yes indeedy.  'tis a duplicate.
(Assignee)

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 86976 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

17 years ago
Build: 2001-07-17-05-0.9.2(WIN)

We do the right thing now.  Marking Verified.  Will check trunk with Bug 86976.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.