If you set moz-user-select: moz-none and have a scroll box which scrolls the text is selectable

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
P1
major
RESOLVED WORKSFORME
4 years ago
a year ago

People

(Reporter: Chris, Unassigned)

Tracking

22 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

4.96 KB, text/html
Details
(Reporter)

Description

4 years ago
Created attachment 773115 [details]
test.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.116 Safari/537.36

Steps to reproduce:

Web page uses css to stop selectable text in an outer div.
If an innner div is selectable has a scroll and the text overflows when you select the select takes the unselectable text in the outer div as well. The test.html attached works with chrome and IE10 but not firefox.


Actual results:

Using the test.html you can see that you can select text that has been made unselectable by the css if you start within the scrollbox and mouseout.


Expected results:

The selection should have stayed withing the selectable text.
(Reporter)

Updated

4 years ago
Severity: normal → major
Priority: -- → P1
Attachment #773115 - Attachment mime type: text/plain → text/html
Confirmed FF 22, Win 7 x64.
Status: UNCONFIRMED → NEW
Component: Untriaged → DOM: Core & HTML
Ever confirmed: true
Product: Firefox → Core
Duplicate of this bug: 891861

Comment 3

a year ago
No longer reproducing. Text outside of the test case's scrolling element isn't selectable, even when starting the selection inside the element and trying to extend it outside of the element.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.