Closed Bug 891745 Opened 6 years ago Closed 6 years ago

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/content-tabs/test-plugin-crashing.js | test-plugin-crashing.js::test_crashed_plugin_notification_inline

Categories

(Thunderbird :: Testing Infrastructure, defect)

All
Linux
defect
Not set

Tracking

(thunderbird24 fixed, thunderbird25 fixed)

RESOLVED FIXED
Thunderbird 25.0
Tracking Status
thunderbird24 --- fixed
thunderbird25 --- fixed

People

(Reporter: hiro, Assigned: hiro)

Details

(Keywords: intermittent-failure)

Attachments

(3 files)

TEST-START | /home/cltbld/talos-slave/test/build/mozmill/content-tabs/test-plugin-crashing.js | test_crashed_plugin_notification_inline
Step Pass: {"function": "controller.waitFor()"}
Step Pass: {"function": "controller.waitFor()"}
Test Failure: Expected the status to be "noReport" or "please". Instead, it was null
WARNING: NS_ENSURE_TRUE(piTarget) failed: file ../../../../../mozilla/content/events/src/nsEventDispatcher.cpp, line 488
++DOMWINDOW == 42 (0x4f2d268) [serial = 72] [outer = 0x2c96268]
--DOMWINDOW == 41 (0x502d608) [serial = 69] [outer = 0x4f6abe8] [url = about:blank]
--DOMWINDOW == 40 (0x4cb7a48) [serial = 65] [outer = 0x4c863f8] [url = about:blank]
--DOMWINDOW == 39 (0x4e63a88) [serial = 61] [outer = 0x4bbf5d8] [url = about:blank]
--DOMWINDOW == 38 (0x4e4e6f8) [serial = 57] [outer = 0x4e0d4f8] [url = http://localhost:43336/whatsnew1.html]
--DOMWINDOW == 37 (0x4e0d4f8) [serial = 54] [outer = (nil)] [url = http://localhost:43336/whatsnew1.html]
--DOMWINDOW == 36 (0x391adb8) [serial = 53] [outer = (nil)] [url = http://localhost:43336/whatsnew.html]
--DOCSHELL 0x4e09a10 == 16 [id = 20]
--DOCSHELL 0x28ed1b0 == 15 [id = 19]
--DOCSHELL 0x1e1ed50 == 14 [id = 21]
--DOCSHELL 0x4d4b130 == 13 [id = 23]
--DOCSHELL 0x4542800 == 12 [id = 22]
--DOCSHELL 0x4f6c6e0 == 11 [id = 24]
++DOCSHELL 0x50088d0 == 12 [id = 25]
++DOMWINDOW == 37 (0x4f4aaf8) [serial = 73] [outer = (nil)]
++DOMWINDOW == 38 (0x4fff708) [serial = 74] [outer = 0x4f4aaf8]
TEST-START | /home/cltbld/talos-slave/test/build/mozmill/content-tabs/test-plugin-crashing.js | teardownTest
TEST-PASS | /home/cltbld/talos-slave/test/build/mozmill/content-tabs/test-plugin-crashing.js | test-plugin-crashing.js::teardownTest
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/mozmill/content-tabs/test-plugin-crashing.js | test-plugin-crashing.js::test_crashed_plugin_notification_inline
On failure case, pluginProblem.xml is surely loaded but pluginInstanceCrashed is not invoked. So "status" attribute is not set yet there.
Assignee: nobody → hiikezoe
Attachment #773120 - Flags: review?(mbanner)
Comment on attachment 773120 [details] [diff] [review]
Make sure that pluginInstanceCrashed is surely invoked

Looks good, thanks.
Attachment #773120 - Flags: review?(mbanner) → review+
https://hg.mozilla.org/comm-central/rev/9377331eb262
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 25.0
Comment on attachment 773120 [details] [diff] [review]
Make sure that pluginInstanceCrashed is surely invoked

[Triage Comment]
Taken onto aurora for aiding stability.
Attachment #773120 - Flags: approval-comm-aurora+
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The new failure is a regression by bug 876089.
Attached patch Possible fixSplinter Review
I can not reproduce the new failure on local, but I think this patch will solve it.
Attachment #793354 - Flags: review?(mbanner)
Comment on attachment 793354 [details] [diff] [review]
Possible fix

Looks good, thanks.
Attachment #793354 - Flags: review?(mbanner) → review+
https://hg.mozilla.org/comm-central/rev/76da2ac0131f
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
This is either not fixed, or there's a different similar bustage on Linux 32 opt builds.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached patch Port bug899080Splinter Review
I could reproduce the new failure. The failure is the same as other failures of plugin tests.
Attachment #803428 - Flags: review?(mbanner)
Comment on attachment 803428 [details] [diff] [review]
Port bug899080

Yes, I could totally believe this is the problem. Thanks!
Attachment #803428 - Flags: review?(mbanner) → review+
https://hg.mozilla.org/comm-central/rev/f4b1feca2e10
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Comment on attachment 793354 [details] [diff] [review]
Possible fix

I've pushed this one to aurora now:

https://hg.mozilla.org/releases/comm-aurora/rev/d5612311be41
Attachment #793354 - Flags: approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.