Amazon search provider should be at www instead of m.amazon.com

VERIFIED FIXED in Firefox 23

Status

()

VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: danielsi, Assigned: mfinkle)

Tracking

Trunk
Firefox 25
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox23 verified, firefox24 verified, firefox25 verified, fennec+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.89 Safari/537.36

Steps to reproduce:

Looking at https://mxr.mozilla.org/mozilla-central/source/mobile/locales/en-US/searchplugins/amazondotcom.xml


Actual results:

Noticed <Url type="text/html" method="GET" template="http://m.amazon.com/gp/aw/s">


Expected results:

It should say http://www.amazon.com/gp/aw/s instead of http://m.amazon.com/gp/aw/s, otherwise you pay the cost of an HTTP redirect from m to www.
(Reporter)

Comment 1

5 years ago
Here's what happens now:

$ curl -vvv 'http://m.amazon.com/gp/aw/s?k=foo'
* About to connect() to m.amazon.com port 80
*   Trying 205.251.242.54... connected
* Connected to m.amazon.com (205.251.242.54) port 80
> GET /gp/aw/s?k=foo HTTP/1.1
> Host: m.amazon.com
> Accept: */*
> 
< HTTP/1.1 301 Moved Permanently
< Date: Wed, 10 Jul 2013 14:24:14 GMT
< Server: Server
< Location: http://www.amazon.com/gp/aw/s?k=foo

Updated

5 years ago
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
OS: Linux → Android
Hardware: x86_64 → ARM
Bit of history, it seems that we used the current URL for tracking purposes in bug 762046
Created attachment 773321 [details] [diff] [review]
patch v1

I need to test this before putting up for review
Assignee: nobody → mark.finkle
(Reporter)

Comment 4

5 years ago
Thanks for the pointer, Aaron.  I see the comment by Joanne Nagel in bug 762046.  Let me double check this.
(Reporter)

Comment 5

5 years ago
Looks like m.amazon.com just redirects to www now.  Thanks for the heads up though.  Please proceed with the change.
Comment on attachment 773321 [details] [diff] [review]
patch v1

I tested the patch on phone and tablet. It works as it did previously. It shows a phone-centric UI for both phones and tablets.

This is expected, I believe, since we are only removing a server-side redirect with this patch.

Hopefully we'll get tablet-centric UI on tablets at some point.
Attachment #773321 - Flags: review?(bnicholson)
Attachment #773321 - Flags: review?(bnicholson) → review+
(Assignee)

Updated

5 years ago
tracking-fennec: ? → +
https://hg.mozilla.org/mozilla-central/rev/c534cc1cb212
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25

Comment 9

5 years ago
Verified fixed on:
Build: Firefox for Android 25.0a1(2013-07-15)
Device: LG Nexus 4
OS: Android 4.2.2
status-firefox25: --- → verified
(Reporter)

Comment 10

5 years ago
Thanks!
Firefox 22/23/24 are not displaying queried results (bug 898975). I believe we need this patch on 23/24.
I'm testing this patch on Beta - I'll update once I have more info.
Comment on attachment 773321 [details] [diff] [review]
patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 762046 added the current URL, but it's not really a regression. this fix is an optimization.
User impact if declined: extra round trip when doing a search via Amazon
Testing completed (on m-c, etc.): landed on m-c for a bit
Risk to taking this patch (and alternatives if risky): very low risk
String or IDL/UUID changes made by this patch:none
Attachment #773321 - Flags: approval-mozilla-aurora?
Comment on attachment 773321 [details] [diff] [review]
patch v1

See above. This could work for beta too.
Attachment #773321 - Flags: approval-mozilla-beta?
I tested this patch by hand on Aurora and it fixes the issues in bug 898975. I have not ran any automated tests.

I was unable to build on Beta due to the sdk build changes (notably, the missing apkbuilder binary - see bug 874132).
Comment on attachment 773321 [details] [diff] [review]
patch v1

last minute uplift approval.
Attachment #773321 - Flags: approval-mozilla-beta?
Attachment #773321 - Flags: approval-mozilla-beta+
Attachment #773321 - Flags: approval-mozilla-aurora?
Attachment #773321 - Flags: approval-mozilla-aurora+

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox23: fixed → verified
status-firefox24: fixed → verified
You need to log in before you can comment on or make changes to this bug.