[MP] Defect - Intermittent Win8 Metro mochiperf/browser_* command timed out: 1200 seconds without output, attempting to kill

RESOLVED FIXED in Firefox 26
(NeedInfo fromanyone)

Status

defect
P2
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: RyanVM, Assigned: jimm, NeedInfo)

Tracking

({intermittent-failure})

unspecified
Firefox 26
x86
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(firefox24 unaffected, firefox25 unaffected, firefox26 fixed)

Details

(Whiteboard: [preview] feature=defect c=testing u=developer p=3)

Reporter

Description

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=25099529&tree=Mozilla-Inbound

WINNT 6.2 mozilla-inbound opt test mochitest-metro-chrome on 2013-07-09 18:33:05 PDT for push 79d75a5b45cc
slave: t-w864-ix-032

18:36:07     INFO -  *** Start BrowserChrome Test Results ***
18:36:07     INFO -  TEST-INFO | checking window state
18:36:07     INFO -  TEST-START | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js
18:36:07     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | RUN deck offset
18:36:07     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Opening about:mozilla in a new tab
18:36:07     INFO -  ### Content.js loaded
18:36:07     INFO -  ### FormHelper.js loaded
18:36:07     INFO -  ### SelectionPrototype.js loaded
18:36:07     INFO -  ### SelectionHandler.js loaded
18:36:07     INFO -  ### ContextMenuHandler.js loaded
18:36:07     INFO -  ### FindHandler.js loaded
18:36:07     INFO -  ### ConsoleAPIObserver.js loaded
18:36:07     INFO -  MetroWidget::GetDPI
18:36:07     INFO -  MetroWidget::GetDPI
18:36:07     INFO -  TEST-PASS | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | about:mozilla is loaded
18:36:07     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 5000ms
18:36:07     INFO -  * delay load started...
18:36:07     INFO -  * delay load complete.
18:36:07     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: [JavaScript Error: "DEPRECATION WARNING: nsIFormHistory2 is deprecated and will be removed in a future version
18:36:07     INFO -  You may find more details about this deprecation at: https://bugzilla.mozilla.org/show_bug.cgi?id=879118
18:36:07     INFO -  resource://gre/components/nsFormHistory.js 22 FormHistory
18:36:07     INFO -  resource://gre/modules/XPCOMUtils.jsm 271 null
18:36:07     INFO -  chrome://browser/content/browser-ui.js 151 BrowserUI.init/<
18:36:07     INFO -  chrome://browser/content/browser-ui.js 135 BrowserUI.init/</<
18:36:07     INFO -  null 0 null
18:36:07     INFO -  " {file: "resource://gre/modules/Deprecated.jsm" line: 79}]
18:36:07     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1373420167387	Sync.Tracker.Clients	WARN	Changed IDs file clients contains non-object value.
18:36:07     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1373420167394	Sync.Tracker.Bookmarks	WARN	Changed IDs file bookmarks contains non-object value.
18:36:07     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1373420167396	Sync.Tracker.Forms	WARN	Changed IDs file forms contains non-object value.
18:36:07     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1373420167398	Sync.Tracker.History	WARN	Changed IDs file history contains non-object value.

command timed out: 1200 seconds without output, attempting to kill
program finished with exit code 1
Assignee

Comment 1

6 years ago
This appears to be a failure where setTimeout fails to generate a callback. (!)
Assignee

Updated

6 years ago
Blocks: 880298
Blocks: metro-testing, 865451, metrov1defect&change
No longer blocks: 880298
Priority: -- → P3
Whiteboard: feature=defect c=testing u=developer p=0
Blocks: 880298
No longer blocks: metro-testing
Summary: Intermittent Win8 Metro mochiperf/browser_deck_01.js command timed out: 1200 seconds without output, attempting to kill → Defect - Intermittent Win8 Metro mochiperf/browser_deck_01.js command timed out: 1200 seconds without output, attempting to kill
Assignee

Updated

6 years ago
No longer blocks: 865451
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Summary: Defect - Intermittent Win8 Metro mochiperf/browser_deck_01.js command timed out: 1200 seconds without output, attempting to kill → Defect - Intermittent Win8 Metro mochiperf/browser_* command timed out: 1200 seconds without output, attempting to kill
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Reporter

Comment 17

6 years ago
Odd that this seems to have spiked so much lately.
Assignee

Comment 18

6 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #17)
> Odd that this seems to have spiked so much lately.

Yes something is going on here. Looking at the logs, affected tests are pretty random.. Also, looks like a browser freeze.
Assignee

Comment 19

6 years ago
Looking back on b2g-inbound, earliest I've found is

https://tbpl.mozilla.org/?tree=B2g-Inbound&rev=c5946a8bcd5b
Fri Aug 9 16:31:32 2013 PDT

https://hg.mozilla.org/integration/b2g-inbound/pushloghtml?startID=161&endID=162

This has the start tab landing, some misc. metro front end patches, and some omtc gfx work.
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 32

6 years ago
If these were hung tests, we would get a mochitest timeout. I've been getting them running longer iterations of individual test to reproduce. So at this point this is looking like something that is specific to our slaves.
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Updated

6 years ago
No longer blocks: metrov2defect&change
Assignee

Updated

6 years ago
Depends on: 905628
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Jimm, this is now the #1 intermittent failure in automation, across all platforms and test suites (http://brasstacks.mozilla.com/orangefactor/?display=OrangeFactor&endday=2013-08-16&startday=2013-08-13&tree=trunk). Please may you take a look? :-)
Flags: needinfo?(jmathies)
Assignee

Comment 103

6 years ago
(In reply to Ed Morley [:edmorley UTC+1] from comment #102)
> Jimm, this is now the #1 intermittent failure in automation, across all
> platforms and test suites
> (http://brasstacks.mozilla.com/orangefactor/
> ?display=OrangeFactor&endday=2013-08-16&startday=2013-08-13&tree=trunk).
> Please may you take a look? :-)

I'm not sure what to do here. AFAICT this is a browser freeze. It doesn't happen often enough to reproduce reliably on try, so it would be hard to backout patches and try to reproduce there. Will think about it today, see if i can come up with some method of debugging it.

Note, I filed bug 905628 on trying to get stacks but there's been no activity on it.
Flags: needinfo?(jmathies)
Whiteboard: feature=defect c=testing u=developer p=0 → [preview] feature=defect c=testing u=developer p=0
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 105

6 years ago
We could try turning off omtc to see if it goes away. A course approach, but it would isolate the gfx code we leverage that other platforms do not.
Summary: Defect - Intermittent Win8 Metro mochiperf/browser_* command timed out: 1200 seconds without output, attempting to kill → [MP] Defect - Intermittent Win8 Metro mochiperf/browser_* command timed out: 1200 seconds without output, attempting to kill
Assignee

Comment 106

6 years ago
Here's an open ended regression range (the open ended side goes back in time). This excludes everything metro related we landed on fx-team on friday, including the about tab work.

https://tbpl.mozilla.org/?tree=Mozilla-Inbound&showall=1&jobname=winnt%206.2&fromchange=e177c3d6ffc2&tochange=782e74f1c4c6
Thank you for digging into this btw :-)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Updated

6 years ago
Depends on: 906147
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 138

6 years ago
fingers crossed!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Reporter

Updated

6 years ago
Assignee: nobody → jmathies
Target Milestone: --- → Firefox 26
Assignee

Updated

6 years ago
Whiteboard: [preview] feature=defect c=testing u=developer p=0 → [preview] feature=defect c=testing u=developer p=3
Temporarily reopening to add to Iteration #13.
Blocks: metrov1it13
No longer blocks: metrov1backlog
Status: RESOLVED → REOPENED
Priority: P3 → P2
QA Contact: jbecerra
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Is there anything that QA can do here? Could anyone please give any guidelines that can help the QA in verifying this issue? Thanks!
Flags: needinfo?
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.