Closed Bug 892069 Opened 7 years ago Closed 7 years ago

[email] Optimize startup based on app trigger

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+)

RESOLVED FIXED
blocking-b2g koi+

People

(Reporter: jrburke, Assigned: jrburke)

References

Details

(Keywords: perf, Whiteboard: [c= u=1.2 s=2013.08.09])

Attachments

(2 files)

There are a few email app triggers now, like compose, and upcoming with sync, we can optimize the startup to only load the UI and backend for the app trigger.

Initial conversation with asuth: do the switching in mail_app, backfilling card flow after initially setting up the target card. This means mail_app is the holder of navigation flow, which makes sense since it is wires up the app.
Blocks: 892523
blocking-b2g: --- → koi?
Component: Gaia::E-Mail → Gaia::Clock
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/53249271
Component: Gaia::Clock → Gaia::E-Mail
Assignee: nobody → jrburke
Initial pull request:

https://github.com/mozilla-b2g/gaia/pull/11064

See the notes in the pull request for a description of the changes. I believe there is some higher priority work being done at the moment, so I will likely wait until early next week to ask officially for a review.
Attachment #778290 - Attachment mime type: text/plain → text/html
Andrew Sutherland changed story state to started in Pivotal Tracker
blocking-b2g: koi? → koi+
Pull request has been updated with some changes:

* Merges the build changes in bug 890182 that is now on gaia master.
* Removes inlining text resources, and instead just inlines the text with the tmpl! resources, to cut down on an extra hop in the module chain and reduces the size of the built code a bit.
* The email build now creates a digest of all JS/HTML files and uses that for the CACHE_VERSION in the html_cache* modules. So if there is a JS/HTML change, the cache will not be used. This should make it safer to reuse the cache node as the domNode for the message_list card.

Next up is writing some unit tests for some of the standalone modules, which I hope to finish out tomorrow. I will be AFK on Friday and Monday, and possibly part of Tuesday, so if there are serious concerns about the general approach in the current pull request, there is a risk that I will not be able to address them for the end of the sprint next week.
For UX review, use the steps outlined here:

https://github.com/jrburke/gaia-dev-zip#for-the-ux-person
Asking for a formal OK from UX to review the changes. UX approval is required to consider the work "done" for the sprint, which ends tomorrow. I should have updated this sooner. I understand if it cannot be reviewed in time, completely my fault.

See that attached zip for the version of the email app with the changes. Use the process listed here to review it:

https://github.com/jrburke/gaia-dev-zip#for-the-ux-person

Things to notice for the review:

The app should just look the same, but have the following enhancements:

* If click on an email link in Contacts, it should launch the app into Compose without first loading Inbox.
* When doing a cold start, it should be possible to click on Compose or a message in the message list sooner than before this change.
Flags: needinfo?(firefoxos-ux-bugzilla)
Comment on attachment 778290 [details]
Pull request: https://github.com/mozilla-b2g/gaia/pull/11064

Upgrading feedback+ to r=asuth.  Love all the comments!

Setting the ui-review flag too to make it clear that landing this depends on ux-review.  I would call to attention for review that if the message reader card is launched before the back-end is started up, the UI will have a lot of empty fields that will eventually populate.  (If you see the reader UI fully formed when it first displays, you are not clicking fast enough! :)
Attachment #778290 - Flags: ui-review?(rmacdonald)
Attachment #778290 - Flags: review+
Attachment #778290 - Flags: feedback+
Got it. Flagging Rob and Jacqueline (since Rob is traveling) so one of them can review this koi+, and then clear the review+ flag with the appropriate commentary.
Flags: needinfo?(rmacdonald)
Flags: needinfo?(jsavory)
Flags: needinfo?(firefoxos-ux-bugzilla)
Attachment #778290 - Flags: ui-review?(rmacdonald) → ui-review+
Rob and I reviewed with James and the changes look good.
Flags: needinfo?(rmacdonald)
Flags: needinfo?(jsavory)
Merged in gaia master:

https://github.com/mozilla-b2g/gaia/commit/1b307d952381d1f3c88f7f3e99b91764ecc4ebc1
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 768697
Duplicate of this bug: Email-Startup
Duplicate of this bug: 871826
Blocks: 896839
Keywords: perf
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Whiteboard: [c= u=1.2 s=2013.08.09]
Duplicate of this bug: 863988
You need to log in before you can comment on or make changes to this bug.