Closed Bug 892194 Opened 7 years ago Closed 6 years ago

[socorro] Decommission soccoro PHP infrastructure

Categories

(Infrastructure & Operations Graveyard :: WebOps: Socorro, task)

x86
macOS
task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bburton, Assigned: gozer)

References

Details

(Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/462] )

* web servers
* zeus
* dns
See Also: → 875992
* probably want to clean out the config too
-> % svn diff
Index: manifests/nodes/socorro.pp
===================================================================
--- manifests/nodes/socorro.pp	(revision 74575)
+++ manifests/nodes/socorro.pp	(working copy)
@@ -853,40 +853,6 @@
     }
 }

-node /^socorro-web([1-2]).stage.webapp.phx1.mozilla.com$/ {
-    include ldap_users::groups::vpn::vpn_socorro_dev
-    include webapp::socorro::keys::stage
-    class {
-        'webapp::socorro':
-            cluster         => 'socorro-stage',
-            host_type       => 'web',
-            include_apache  => true,
-            include_python  => false,
-            ganglia_addr    => '239.2.11.104',
-            ganglia_cluster => 'Web',
-            webapp_admin    => 'socorroadm.stage.private.phx1.mozilla.com';
-        'webapp::socorro::php':
-            cluster => 'socorro-stage';
-        'memcached':
-            cachesize => "1024";
-    }
-    #realize(Yumrepo["pgdg-92-redhat"])
-
-    #package {
-    # [
-    #    "postgresql92-libs",
-    #  ]:
-    #    ensure  => installed,
-    #    require => Yumrepo["pgdg-92-redhat"];
-    #
-    #  [
-    #    "postgresql",
-    #    "postgresql-libs"
-    #  ]:
-    #    ensure => absent;
-    #}
-}
-
Assignee: server-ops-webops → bburton
Status: NEW → ASSIGNED
Assignee: bburton → server-ops-webops
Assignee: server-ops-webops → gozer
(In reply to Brandon Burton [:solarce] from comment #0)
> * web servers
> * zeus
> * dns

Would be nice to know what this was composed of.

I can infer socorro-web([1-2]).stage.webapp.phx1.mozilla.com, but what about DNS and Zeus?

What was this thing?
Hey :gozer,

According to our docs, crash-stats.allizom.org points to: 

    socorro[1-2].stage.webapp.phx1.mozilla.com

The -web systems were our old PHP UI, and we migrated to a new UI on the new systems. The thing to confirm is that crash-stats.allizom.org all points to socorro[1-2].stage.webapp rather than socorro-web[1-2].stage.webapp. Which, I'm pretty sure is the case. 

Thanks for decommissioning!

On another note, I could use one of these for a stage system for a new metrics workflow for ADI, if they aren't already spoken for.
(In reply to Selena Deckelmann :selenamarie :selena from comment #4)
> Hey :gozer,
> 
> According to our docs, crash-stats.allizom.org points to: 
> 
>     socorro[1-2].stage.webapp.phx1.mozilla.com
> 
> The -web systems were our old PHP UI, and we migrated to a new UI on the new
> systems. The thing to confirm is that crash-stats.allizom.org all points to
> socorro[1-2].stage.webapp rather than socorro-web[1-2].stage.webapp. Which,
> I'm pretty sure is the case. 

Yes, I've confirmed that fact myself. These VMs have seen no traffic since 2013.

> Thanks for decommissioning!

No problem.

> On another note, I could use one of these for a stage system for a new
> metrics workflow for ADI, if they aren't already spoken for.

Well, once these are decomisionned, I imagine you can repurpose them.
Removed from what was left in puppet and powered off:

socorro-web1.stage.webapp.phx1.mozilla.com
socorro-web2.stage.webapp.phx1.mozilla.com

Hosts marked as decomisionned in inventory.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1021923
Per 1021923 (duped here), we need to clean up the sp-web host(s) as well.

If someone could signoff on decom'ing these hosts?

sp-web01.phx1.mozilla.com
sp-web02.phx1.mozilla.com
sp-web03.phx1.mozilla.com
sp-web04.phx1.mozilla.com
sp-web05.phx1.mozilla.com
Status: RESOLVED → REOPENED
Flags: needinfo?(chris.lonnen)
Resolution: FIXED → ---
/ack

drop the hammer
Flags: needinfo?(chris.lonnen)
Whiteboard: [kanban]
Whiteboard: [kanban] → [kanban:https://kanbanize.com/ctrl_board/4/462]
Status: REOPENED → ASSIGNED
Done.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.