[User Story] Email Notification Grouping

RESOLVED FIXED in 1.2 FC (16sep)

Status

Firefox OS
Gaia::E-Mail
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: pdol, Unassigned)

Tracking

({feature})

unspecified
1.2 FC (16sep)
ARM
Gonk (Firefox OS)
feature
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

(Whiteboard: [ucid:Productivity5, FT:Productivity, KOI:P1])

(Reporter)

Description

5 years ago
User Story:

As a user, I want my email notifications to be grouped such that my utility tray is not filled with individual email notifications. 


Acceptance Criteria:

1. If I received more than one email for the same mailbox the notifications for those multiple emails are grouped, visually
2. If I received a new email for a given mailbox after having received a previous notification without clearing it, the notifications are now grouped
3. If email notifications are grouped, I can see the number of emails that I am being notified about
(Reporter)

Updated

5 years ago
Depends on: 892530
Component: Gaia::E-Mail → Gaia::Clock
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/53237783
Component: Gaia::Clock → Gaia::E-Mail
blocking-b2g: koi? → koi+
Blocks: 898160
Whiteboard: [ucid:Productivity5] → [ucid:Productivity5, FT:Productivity, KOI-P1]
Whiteboard: [ucid:Productivity5, FT:Productivity, KOI-P1] → [ucid:Productivity5, FT:Productivity, KOI:P1]

Updated

5 years ago
Duplicate of this bug: 796751

Updated

5 years ago
Depends on: 910915
After UX review with Rob on Friday, we also discussed it being desirable for the email app to remove the notification of new mail if the user clicks into the email app and views that inbox without going through the notification.

For that to work, then we need bug 899574 to land. The email app periodically starts up in the background, syncs, then closes itself, so it cannot retain JS object references to the Notification objects it creates. Getting a list of notifications for the app via the get API in 899574 will allow the email app to get the currently existing notifications for the email app and close the appropriate ones.
Depends on: 899574

Updated

5 years ago
Flags: in-moztrap+
Target Milestone: --- → 1.2 FC (16sep)

Updated

5 years ago
No longer depends on: 899574
This was fixed in the change for bug 892523:

Fixed on master:
https://github.com/mozilla-b2g/gaia/commit/dd9e7936461d00b2b05f7cf59bdd227290aa9766

pull request:
https://github.com/mozilla-b2g/gaia/pull/12174
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Bug 922722 tracks an issue I found with this user story.
Depends on: 922722
You need to log in before you can comment on or make changes to this bug.