Closed Bug 892640 Opened 9 years ago Closed 9 years ago

Selection in Contacts Sidebar now limited to Name and Email address

Categories

(Thunderbird :: Message Compose Window, defect)

17 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 118624

People

(Reporter: office, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

In earlier versions it was possible to select, for example, on the Nickname field in the Contacts Sidebar. I used this the Nickname field to create contact groups, useful for sending an email to a selected group.

This facility (which I have used for years) has now been removed - it is certainly not there in Version 17 - and the alternative of having separate Address Lists for each group is very cumbersome.



Expected results:

IMPROVEMENT PROPOSAL: Provide a couple of extra indexed fields in the address book for grouping contacts, and make these accessible in the Contacts Sidebar.
This is true, it does not search in Nicknames. But maybe it was an intentional change. Does anybody know?
Status: UNCONFIRMED → NEW
Depends on: 529584
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
(In reply to :aceman from comment #1)
> This is true, it does not search in Nicknames. But maybe it was an
> intentional change. Does anybody know?

I don't think that skipping nicknames could be intentional - what's the purpose of nicknames when you can't search for them? Aren't nicknames *only* for searching/addressing?

We have several bugs and/or comments requesting to include nickname field when searching and autocomplete addressing, and I think it's the obvious thing to do with nick names.
David, thanks for reporting this! I think it's not searching nicknames is an old problem going back to 2002, so this bug looks like a duplicate of that.

Bug 118624 - AB quick search should match Nickname field

For searching/indexing more other fields, see:

Bug 298438 - Address book quick search should search in whole address card
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 118624
No longer depends on: 529584
(In reply to David England from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101
> Firefox/22.0 (Beta/Release)
> Build ID: 20130618035212
> 
> Steps to reproduce:
> 
> In earlier versions it was possible to select, for example, on the Nickname
> field in the Contacts Sidebar. I used this the Nickname field to create
> contact groups, useful for sending an email to a selected group.
> 
> This facility (which I have used for years) has now been removed - it is
> certainly not there in Version 17 - and the alternative of having separate
> Address Lists for each group is very cumbersome.

A better, yet still somewhat cumbersome workaround would be to use column picker of main AB and add nickname as a column, then sort by that column to group your contacts. Restore AB window to window size on top of your composition. Select all contacts of one group, then drag them into the recipients field of composition.

> Expected results:
> 
> IMPROVEMENT PROPOSAL: Provide a couple of extra indexed fields in the
> address book for grouping contacts, and make these accessible in the
> Contacts Sidebar.

Free tagging of contacts for any purposes including multiple grouping might eventually land with the new address book that is currently being worked on, but nobody knows when or if it will be released.

In the meantime, it's much easier to fix the regressions/malfunctions of nickname field and related bugs:

Bug 118624 (of which this bug is duplicate) - AB quick search and contacts side bar should match Nickname field

Bug 325458 - Nickname does not get highest precedence for matching address book entries

Bug 400713 - Allow showing any fields from address book as columns in compose message contacts pane (sidebar) [column picker, customize, sorting by organization etc.]

Btw, pending patch for Bug 529584 will go a long way to provide an excellent workaround for free tagging and grouping using existing nickname field, as we'll then do "contains" search on nickname so can put different tags in nickname of one card and then filter for one.
If complemented with Bug 558931, we could provide full flexible tagging via nickname field where you can even filter for combinations of multiple tags.
(In reply to Thomas D. from comment #4)
> Bug 118624 (of which this bug is duplicate) - AB quick search and contacts
> side bar should match Nickname field
> Bug 400713 - Allow showing any fields from address book as columns in
> compose message contacts pane (sidebar) [column picker, customize, sorting
> by organization etc.]
> 
> Btw, pending patch for Bug 529584 will go a long way to provide an excellent
> workaround for free tagging and grouping using existing nickname field,

caveat: ...only if *combined* with bug 118624 and bug 400713, so that you can act on the full result set (as opposed to auto-complete where you might see the full set, but can only act on one result at a time).

> as
> we'll then do "contains" search on nickname so can put different tags in
> nickname of one card and then filter for one.
> If complemented with Bug 558931, we could provide full flexible tagging via
> nickname field where you can even filter for combinations of multiple tags.
You need to log in before you can comment on or make changes to this bug.