[B2G][l10n][Crash Report] Slovak: "Crash Report" Header is truncated

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: dsubramanian, Assigned: rozbora)

Tracking

({l12y, uiwanted})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 774274 [details]
Screenshot

Description:
When the user clicks the link "What's in a crash report?" in the crash report screen, the user sees the header of the "Crash Report" with ellipses.

Repro Steps:
1) Updated to Leo Build ID: 20130711070209
2) Set the language to Slovak
3) Use Cgywin commands to produce a crash 
4) On the Crash Report page, click the link "What's in a crash report?"
5) Crash Report details are displayed

Actual:
Crash Report header with ellipses

Expected:
Crash Report header without ellipses

Environmental Variables
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/aaa74e5efaf1
Gaia: 7cdcc46179d198cab11970964b181ede32a5b683
Platform Version: 18.1

Notes:
Repro frequency: 100%
See attached: Screenshot
(Reporter)

Updated

5 years ago
Blocks: 892075

Updated

5 years ago
No longer blocks: 892075

Updated

5 years ago
Blocks: 892075
Summary: [B2G][l10n][Crash Report] Solvak: "Crash Report" Header is truncated → [B2G][l10n][Crash Report] Slovak: "Crash Report" Header is truncated
Would it be possible to decrease the header font size? Probably to use H2 instead of H1. The "Crash Report" has a well-formed and steady translation used across all the Mozilla products and I don't want to make it different here.
(Reporter)

Updated

5 years ago
Duplicate of this bug: 893044
As per the truncation bug blocker guidelines, nominating as a blocker for koi? as the localizer has found no workaround to shorten the word.
Adding UIwanted keyword for this
blocking-b2g: --- → koi?
Keywords: uiwanted
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 4

5 years ago
Flagging Peter to advise on font size suggestion.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(pla)

Comment 5

5 years ago
We should reduce the font size, but I'm gonna ping Eric for a recommendation on the optimal size (he worked on system-wide font size rework for 1.0).
Flags: needinfo?(pla) → needinfo?(epang)
We opened this bug to solve items like this, Bug 908300.  I've marked this bug dependent on it.  We've proposed to reduce the size of the text to a minimum of 16px (keeping it as close as possible to the original size).  Only if no other translation can be provided.
Depends on: 908300
Flags: needinfo?(epang)
:epang what are the next steps here for 1.2 timeframe ? Is the plan to reduce the font-size in scope for koi ?
Flags: needinfo?(epang)

Comment 8

5 years ago
Bhavana, please ni? Axel or Delphine as to whether or not localization bugs are blocking. I cannot make that call for them. Eric can provide advice in regard to specific bugs, which it sounds like he has addressed in comment #6.
Flags: needinfo?(epang)
(In reply to Stephany Wilkes from comment #8)
> Bhavana, please ni? Axel or Delphine as to whether or not localization bugs
> are blocking. I cannot make that call for them. Eric can provide advice in
> regard to specific bugs, which it sounds like he has addressed in comment #6.

Spoke offline to :delphine, solvak may be out of scope for 1.2 as well , she will clear the flag accordingly once confirmed.

Updated

5 years ago
blocking-b2g: koi? → ---
Created attachment 8350067 [details]
Screen Shot 2013-12-19 at 15.00.14.png

Is this still an issue?  I'm unable to reproduce the screen but I believe with the visual refresh there should be enough space now.  See attached image of mock up.
Pavel, are you still seeing this issue on current master or 1.3?
Flags: needinfo?(pcvrcek)
(In reply to Francesco Lodolo [:flod] from comment #11)
> Pavel, are you still seeing this issue on current master or 1.3?

Wrong person. 

Wladow?
Flags: needinfo?(pcvrcek) → needinfo?(wladow)
Could you please provide me with a repro steps to be able to crash on a keon device. The steps described in comment 0 are not sufficient enough. Thank you.
Flags: needinfo?(francesco.lodolo)
Sorry, I thought there were instructions in the first link
https://wiki.mozilla.org/B2G/QA/Gaia_Test_Plan/Crash

Anyway, you can see the same header in Improve Firefox OS and using the learn more in Crash reports.

Marking as fixed since I've just checked on Keon master.
Flags: needinfo?(wladow)
Flags: needinfo?(francesco.lodolo)
Created attachment 8391150 [details]
Screenshot from master
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.