Move AUTOCFG_JS_EXPORTS to moz.build, install manifests

RESOLVED DUPLICATE of bug 1252093

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 1252093
5 years ago
5 months ago

People

(Reporter: gps, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
AUTOCFG_JS_EXPORTS needs the moz.build treatment. Although, https://mxr.mozilla.org/mozilla-central/search?string=AUTOCFG_JS_EXPORTS says it's only used in one Makefile.in. How this got its own rule in rules.mk I'm not sure. Someone must have been doing something right.

This might also be covered by bug 887958. Filing this bug to track removing export rules from rules.mk.
>> Bug 892747 - Move AUTOCFG_JS_EXPORTS to moz.build, install manifests

WRT the subject on this bug are there two activities involved - convert and add manifests or convert using manifests ?
(Reporter)

Comment 2

5 years ago
We should attempt to produce install manifests as part of the conversion. IMO the incremental effort should be trivial and worth doing at one time.

Updated

5 years ago
See Also: → bug 890097

Updated

5 years ago
Assignee: nobody → joey
drop bug back into the pool since manifest changes are being worked on.  Back to variable conversions.
Assignee: joey → nobody

Updated

5 months ago
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1252093
You need to log in before you can comment on or make changes to this bug.