Debug build fails if theres a space in your username

VERIFIED DUPLICATE of bug 137059

Status

P3
minor
VERIFIED DUPLICATE of bug 137059
18 years ago
14 years ago

People

(Reporter: christopher_brien, Assigned: leaf)

Tracking

Trunk
mozilla1.1alpha
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    

When building a debug build, I always got errors in building 
mozilla\xpcom\typelib\xpt\tests\PrimitiveTest.c saying nonsense like "Cannot 
open file 'Brien'" and fails with a no such file error
It turns out that this problem can be avoided by set my USERNAME evironment 
variable from "Christopher Brien" to its DOS equivalent "christ~1" (I'm aware 
of the pseudo-religous connotations. It's not my fault. Blame Micros~1).

The makefile.win for PrimitiveTest.c includes a line saying
LCFLAGS=-DWIN32_LEAN_AND_MEAN -DEXPORT_XPT_API -DUSE_NSREG
This "USE_NSREG" bit I expect means it looks for your mozilla config. This 
should either be changed or fixed to allow spaces in the USERNAME variable.
This is not the same as failing because of spaces in MOZ_SRC (which is set 
to "Z:\bugzilla"). It shouldn't be using the USERNAME variable at all, rather 
APPDATA.

Reproducible: Always
Steps to Reproduce:
1.Start cmd.exe
2.type "set USERNAME=something with spaces"
3.try to build a debug version of mozilla

Actually, you may need to create a user account with spaces in the user name 
instead of step 2.

Actual Results:  The build breaks at PrimitiveTest.c

Expected Results:  The build shouldn't break

Its probably possible to disable tests to work around this, but its still a 
bug, nonetheless.

Comment 1

18 years ago
windows.
Assignee: cls → leaf

Comment 2

17 years ago
Marking NEw.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Priority: -- → P3
Target Milestone: --- → mozilla1.1

Comment 3

17 years ago
bug cleanup - all leaf's bugzilla bugs should be assigned to leaf@mozilla.org
(not leaf@netscape.com), now and any future bugs created.

this should be a one time change, apologies for the spam.
Assignee: leaf → leaf

Comment 4

17 years ago
cls says "89302 is a dupe of 137059".

*** This bug has been marked as a duplicate of 137059 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
v dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.