Closed Bug 893188 Opened 6 years ago Closed 6 years ago

[Gaia] System messages have stopped working in latest nightly

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:leo+, b2g18 verified, b2g-v1.1hd fixed)

RESOLVED FIXED
blocking-b2g leo+
Tracking Status
b2g18 --- verified
b2g-v1.1hd --- fixed

People

(Reporter: kgrandon, Assigned: kgrandon)

References

Details

Attachments

(1 file)

This was working fine for me on the 7/4/13 nightly build. After upgrading to the 7/11/13 build it appears to be broken.

When navigating to Settings -> Keyboard I'm presented with a blank screen. Instead we should see the list of keyboard settings.

This profile appears to work in normal firefox, but fails in firefox nightly.
A few notes:

This appears to affect every panel in settings. All options bring me to a blank panel.

I don't know if this is affecting it, but I'm now seeing this message in the logs during system app startup:
[14:12:41.276] NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: '[JavaScript Error: "this.initHelper is not a function" {file: "file:///.../gaia/profile-debug/extensions/activities/components/SystemMessageManager.js" line: 195}]' when calling method: [nsIDOMGlobalPropertyInitializer::init] @ http://system.gaiamobile.org:8080/js/icc.js:19
Summary: [Settings] Keyboard panel stopped working in latest nightly → [Settings] Panels have stopped working in latest nightly
I'm not sure if this is the root cause, but bug 889984 landed a patch which removes the initHelper code. Our code is fairly brittle and has a custom activity implementation which references initHelper.

I think ultimately we need to be less brittle. One way we could do this is by implementing stuff in gecko instead of gaia and adding tests for it.

I'm also noticing other features broken as well for this, so updating the name of this bug. Things that are broken include anything that uses system messages. (Alarms, calendar, activites)
Blocks: 889984
Summary: [Settings] Panels have stopped working in latest nightly → [Gaia] System messages have stopped working in latest nightly
I'm really sorry for breaking you guys, but it's pretty tough not to break JS when there are no tests.
Oh, I see, the code I broke lives in Gaia.  How odd!

> I think ultimately we need to be less brittle.

There's definitely an expectation when we're hacking on Gecko that Gaia touches only web-facing APIs.
(In reply to Justin Lebar [:jlebar] from comment #3)
> I'm really sorry for breaking you guys, but it's pretty tough not to break
> JS when there are no tests.

Exactly. I'm sending out a message to the mailing list on this issue to find a solution. I'm not blaming you at all though - this is definitely due to a brittle implementation :) Currently there's no way to know what will happen, and it's something I'd like to find a solution for.
That sounds great; thanks!
Quick band-aid to update our system message manager to be up-to-date with m-c.
Attachment #775038 - Flags: review?(21)
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Landed in master: https://github.com/mozilla-b2g/gaia/commit/2f7fc2d436f3418bf6bcabac84a5f0701b48ef55
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Hi Kevin, all sms mock messages gone after this commit landed, could you check it?
Flags: needinfo?(kgrandon)
Hi Yuren,

Nice observation. I believe this may also be described in bug 894388. Looking into it, thanks!
Flags: needinfo?(kgrandon)
Depends on: 894388
No longer depends on: 894388
Sorry, that bug appears to be for touch events. I've opened bug 894438 to track looking at the shims.
Needed for bug 889984.
blocking-b2g: --- → leo+
Uplifted 2f7fc2d436f3418bf6bcabac84a5f0701b48ef55 to:
v1-train: 7842b1d553f8f5361e27f7f503b1eb9103d7c61e
v1.1.0hd: 7842b1d553f8f5361e27f7f503b1eb9103d7c61e
Verified it' fixed on Leo B2G18 COM RIL,
System messages are panels are working in latest nightly

Environmental  Variables:
Build ID: 20130815041201
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/692d3414bb12
Gaia: 0f1f1ab0ab31a1df8a780baa048b5e7b2854205d
Platform Version: 18.1
RIL Version: 01.01.00.019.190
Firmware verision: D300f080
You need to log in before you can comment on or make changes to this bug.