Closed Bug 893530 Opened 9 years ago Closed 8 years ago

Adopting "Droid Arabic Naskh" font for Arabic usage in Firefox OS or developing an alternative

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: nefzaoui, Unassigned)

References

Details

(Whiteboard: [rtl-meta]visual design, visual-tracking, sverd)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.2; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212




Expected results:

Beauty of apps is one of the main aspects we are obliged to cover while developing Firefox OS. I've been recently working on an Arabic Firefox OS app for the Arabian Mozilla Community, one of the cons that I faced (or the con faced me.. dunno who faced who for sure..) is that the casual and standard font used in Firefox OS looks ugly WHEN used in Arabic, the app looked so boring, so I figured that choosing a famous and open source Arabic font will do the thing, and yes it did as it appears in the attachment.
The font I chose called "Droid Arabic Naskh"
and these are two references for it:
1 http://openfontlibrary.org/en/font/droid-arabic-naskh
2 http://www.google.com/fonts/earlyaccess

I strongly hope and suggest we work on this bug because Arabic fonts either developed by Mozilla or adopted will surely add a *NATIVE* beautiful view.
I think there are two main aspects to consider when choosing an Arabic/Farsi font:
 • readability, of course (and I agree the Droid Arabic Nashk one is much more readable than our current default one);
 • vertical alignment when used along with Roman scripts (e.g. for the Homescreen, where there’s a lot of mixed Roman/Arabic content).

Ahmed, have you checked the vertical alignment for mixed content? Would you mind sending us a screenshot?

Patryk, what are our plans regarding the default font? Are we going to use Feura sans everywhere, and if yes, how does it compare to the screenshot above for Arabic scripts?
Flags: needinfo?(padamczyk)
Agreed Droid Arabic Naskh is the way to go. We do not have plans on commissioning the expansion of our default to cover Arabic unfortunately.
Flags: needinfo?(padamczyk)
So the correct course of action would be Roman characters would use our default (feura) and all arabic would be displayed in Droid Arabic Naskh. I believe the default font on the screenshots is Open Sans.
And how would that be implemented ? specifying the font to be used maybe depending on the "name" string in the manifest, that's what I can think of for homescreen apps names
What about the body of an app ? that's could depend on default_locale or the system language in use ?
Depends on: gaia-rtl
Why can't we just merge Fira Sans and this font suggested here ? this I think is the perfect way to do it ? :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
The best plan of attack currently would be to use Fira Sans as the base font.
And have additional fonts as fall back for these reasons:
+ size, we want to make sure the builds are the smallest possible.
+ copyright, I am pretty sure we can't just take Google's fonts merge them into ours.

"Droid Arabic Naskh" seems to be a nice Arabic font:
http://openfontlibrary.org/en/font/droid-arabic-naskh
http://www.google.com/fonts/earlyaccess

Michael / Jonathan, can we use this as our fall back for arabic?
Flags: needinfo?(mwu)
Flags: needinfo?(jfkthame)
Whiteboard: visual design, visual-tracking, sverd
(In reply to Patryk Adamczyk [:patryk] UX from comment #6)
> The best plan of attack currently would be to use Fira Sans as the base font.
> And have additional fonts as fall back for these reasons:
> + size, we want to make sure the builds are the smallest possible.
> + copyright, I am pretty sure we can't just take Google's fonts merge them
> into ours.

Right - there's no compelling reason to try and "merge" unrelated scripts into a single font, even if licensing might in principle allow it.

> "Droid Arabic Naskh" seems to be a nice Arabic font:
> http://openfontlibrary.org/en/font/droid-arabic-naskh
> http://www.google.com/fonts/earlyaccess
> 
> Michael / Jonathan, can we use this as our fall back for arabic?

To my eyes (with the caveat that although I'm familiar with the script, I'm obviously not a native reader!), it looks like Droid Arabic Naskh has been designed very much with small-screen readability in mind, so it could be a good choice here.

(What do we currently have on the device? Just Droid Sans Arabic, I guess?)

Maybe we could create a test build that uses this font, and get feedback from additional members of the Arabic community. To do this, we'd just need to add the font files to the build; update the default prefs in all.js; and add the new font name to gfxAndroidPlatform::GetCommonFallbackFonts.
Flags: needinfo?(jfkthame)
Hmm, I think we already have Droid Naskh on the device - https://github.com/mozilla-b2g/moztt/blob/master/fonts.mk#L19 . Maybe we need to use a newer one or add it to font list?
Flags: needinfo?(mwu)
Blocks: gaia-rtl
No longer depends on: gaia-rtl
(In reply to Michael Wu [:mwu] from comment #8)
> Hmm, I think we already have Droid Naskh on the device -
> https://github.com/mozilla-b2g/moztt/blob/master/fonts.mk#L19 . Maybe we
> need to use a newer one or add it to font list?

Indeed Droid Naskh *is on* the device
Closing
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Mass Edit: adding the [rtl-meta]
Whiteboard: visual design, visual-tracking, sverd → [rtl-meta]
Whiteboard: [rtl-meta] → [rtl-meta]visual design, visual-tracking, sverd
You need to log in before you can comment on or make changes to this bug.