Puppetize public metrics server

VERIFIED FIXED

Status

Infrastructure & Operations
Infrastructure: Puppet
VERIFIED FIXED
5 years ago
8 months ago

People

(Reporter: sheeri, Unassigned)

Tracking

Details

(Whiteboard: [2013q4])

(Reporter)

Description

5 years ago
Specifically for community metrics server first.
(Reporter)

Updated

5 years ago
Assignee: server-ops-database → infra
Component: Server Operations: Database → Infrastructure: Puppet
Product: mozilla.org → Infrastructure & Operations
QA Contact: scabral → jdow
(Reporter)

Comment 1

5 years ago
The Community VLAN doesn't have puppet by design; the public (but vetted) metrics server will live in the dmz VLAN.
Summary: Puppet for Community VLAN → Puppetize public metrics server
(In reply to PTO until 6 Aug 2013 Sheeri Cabral [:sheeri] from comment #1)
> The Community VLAN doesn't have puppet by design; the public (but vetted)
> metrics server will live in the dmz VLAN.

What are the hostname(s) of the server(s) to be puppeted? Are they existing servers that are being converted to puppet, or newly-installed servers as part of their initial kickstart?
Flags: needinfo?(scabral)
atoll: 

They're existing servers. I don't know all their names, but one I do know is:
mysql1.stage.metrics.scl3.mozilla.com

I learned that today because I was asked to do work on it and couldn't find it in puppet, then had to track it down from the metrics folks. Not clearing the needmoreinfo flag in case sheeri knows of more. :)

hope that helps!
(Reporter)

Comment 4

5 years ago
That metrics stage server is not the public one. 

The public one is metrics1.dmz.scl3.mozilla.com and it's possible Shyam's team already set it up in puppet....they did some stuff right before I left on vacation, and I'm not caught up yet.

Note that the parent bug of this is a parent of other bugs too, so all the information might be in the parent and children of this parent...
Flags: needinfo?(scabral)
As far as we can tell, this was done.

If anyone thinks it isn't, REOPEN with specific servers that still need to be puppetized.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

5 years ago
Verified, I was able to install MySQL packages via puppet today.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.