Filelink: YouSendIt is now Hightail

RESOLVED FIXED in Thunderbird 31.0

Status

Thunderbird
FileLink
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Sören Hentzschel, Assigned: Magnus Melin)

Tracking

17 Branch
Thunderbird 31.0

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

103.01 KB, patch
mconley
: review+
Details | Diff | Splinter Review
(Reporter)

Description

5 years ago
Thunderbird supports YouSendIt as cloud storage provider. the service has a new name. it should be changed.

Comment 1

5 years ago
I suppose for the beginning we could just change the user visible labels.

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

5 years ago
Assignee: nobody → mkmelin+mozilla
(Assignee)

Comment 2

5 years ago
Created attachment 816369 [details] [diff] [review]
proposed fix

This switches it all over. I think just updating everything is easier - localizers can also run the same script and get things automatically switched over. 

This is what i did:

# Update in text refs
find ./ -type f -exec sed -i 's/YouSendIt/Hightail/g' {} \;
find ./ -type f -exec sed -i 's/yousendit/hightail/g' {} \;
find ./ -type f -exec sed -i 's/youSendIt/hightail/g' {} \;

# Change dirs
for file in $(find . -type d -name "*YouSendIt*"); do hg mv $file `echo $file | sed s/YouSendIt/Hightail/`; done
for file in $(find . -type d -name "*yousendit*"); do hg mv $file `echo $file | sed s/yousendit/hightail/`; done

# Change files
for file in $(find . -type f -name "*YouSendIt*"); do hg mv $file `echo $file | sed s/YouSendIt/Hightail/`; done
for file in $(find . -type f -name "*yousendit*"); do hg mv $file `echo $file | sed s/yousendit/hightail/`; done

# Manual updates:
 - a couple of urls
 - reorder the file in mail/components/cloudfile/moz.build

It works, and all the tests still pass.
Attachment #816369 - Flags: review?(mconley)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Comment on attachment 816369 [details] [diff] [review]
proposed fix

Review of attachment 816369 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good, but I think I want to see the following before I r+:

1) Another search/replace for "ysi" (case insensitive) to Hightail or similar, or something more generic
2) Somebody biz-dev related to make sure we're hitting all of the right URLs here in the right way - that the Hightail switch hasn't changed any of the rules on any of the scripts we're hitting.
3) A green Try run.

I'll needinfo Standard8 and Jb for #2.

::: mail/components/cloudfile/cloudFileComponents.manifest
@@ +1,1 @@
> +component {32fd439f-9eb6-4907-ac0b-2c88eb14d98d} nsHightail.js

I have a feeling the uuid's all need to be bumped with the name change, even though the interface itself isn't changing.

::: mail/components/cloudfile/content/Hightail/fileExceedsLimit.js
@@ +11,5 @@
>  Cu.import("resource://gre/modules/XPCOMUtils.jsm");
>  
>  let fileExceedsLimit = {
>    onOK: function AAD_onOK() {
> +    let href = "https://www.hightail.com/prosignup?p_code=pro&s=4001636&cid=pm-4001636";

Do you think we need to clear this with Hightail to make sure our referral codes are being accepted properly by the Hightail code?

Might be worth Cc'ing jb on.

::: mail/components/cloudfile/content/Hightail/settings.xhtml
@@ +21,3 @@
>        <input id="username" type="text" required="true"/>
>        <div id="learn-more" class="float-right">
> +        <a href="https://www.hightail.com/thunderbird-about-yousendit?s=4001583&amp;cid=pm-4001583">&hightailSettings.learnMore;</a>

Hrm. We might want to get the Hightail folks to rebrand this with the new Hightail stuff. Looks super-dated.

::: mail/components/cloudfile/nsHightail.js
@@ +487,2 @@
>    /**
>     * Attempt to find folder by name on YSI website.

YSI -> Hightail

@@ +522,3 @@
>  
>    /**
>     * Attempt to find folder by id on YSI website.

YSI -> Hightail. Same goes for the rest of the file.

@@ +902,5 @@
>  
>    /**
>     * Kicks off the upload procedure for this uploader.
>     */
>    startUpload: function nsYSIFU_startUpload() {

nsHighTailFU_startUpload, I guess

@@ +970,2 @@
>     */
>    _uploadFile: function nsYSIFU__uploadFile() {

nsHightailFU__uploadFile. Same is true for the rest of the function names in this file.

@@ +1129,4 @@
>          failed();
>        }
>        else if (uploadInfo.clickableDownloadUrl) {
>          // We need a kludge here because YSI is returning URLs without the scheme...

YSI -> Hightail

@@ +1188,5 @@
>  
>        if (fileInfo.errorStatus)
>          aFailureCallback();
>        else {
>          // We need a kludge here because YSI is returning URLs without the scheme...

YSI -> Hightail

::: mail/test/mozmill/shared-modules/test-cloudfile-hightail-helpers.js
@@ +298,2 @@
>    this._server = null;
> +  this._ysi = aHightail;

_ysi should probably be renamed.

@@ +379,2 @@
>    this._server = null;
> +  this._ysi = aHightail;

_ysi should probably be renamed.

@@ +458,2 @@
>    this._server = null;
> +  this._ysi = aHightail;

_ysi should probably be renamed.

@@ +519,2 @@
>    this._server = null;
> +  this._ysi = aHightail;

_ysi should probably be renamed.

@@ +572,2 @@
>    this._server = null;
> +  this._ysi = aHightail;

_ysi should probably be _ht, or something more generic.

@@ +595,2 @@
>    this._server = null;
> +  this._ysi = aHightail;

Same as above.
Attachment #816369 - Flags: review?(mconley) → feedback+
Mark / Jb:

We're changing the domain for these referral URLs... do we know if the transition can be this seamless / simple? Also, there's at least one place (https://www.hightail.com/thunderbird-about-yousendit?s=4001583&amp;cid=pm-4001583) that likely needs re-branding from the Hightail folks...

-Mike
Flags: needinfo?(mbanner)
Flags: needinfo?(jb)
I'm trying to find out at the moment.
Flags: needinfo?(jb)
(Assignee)

Comment 6

4 years ago
Any update from the YSI/Hightail contact?
I've poked the contact again today.
Ok, I've still not received a response. I think if everything is still capable of signing up & gives the user the right things, then we can just go with it. If we hear back later, we can always do a follow-up tweak.
Flags: needinfo?(standard8)
(Assignee)

Comment 9

4 years ago
Created attachment 8384254 [details] [diff] [review]
proposed fix, v2

Unbitrotted, and addressed review comments. 
One thin I had to change was that the nsHightail type needs to still be "YouSendIt" since that is in the prefs, so the account would disappear on upgrade if we change it.

Green try run at https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=91eeac74c458
Attachment #8384254 - Flags: review?(mconley)
(Assignee)

Updated

4 years ago
Attachment #816369 - Attachment is obsolete: true
Comment on attachment 8384254 [details] [diff] [review]
proposed fix, v2

Review of attachment 8384254 [details] [diff] [review]:
-----------------------------------------------------------------

I'm fine with this. Let's maybe chuck the function names in nsHightail.js, and see if we can write a comment in the .manifest file. If not, don't worry about it.

::: mail/components/cloudfile/cloudFileComponents.manifest
@@ +1,3 @@
> +component {dd2bce44-ca71-42ce-b806-6fa4e073919c} nsHightail.js
> +contract @mozilla.org/mail/hightail;1 {dd2bce44-ca71-42ce-b806-6fa4e073919c}
> +category cloud-files YouSendIt @mozilla.org/mail/hightail;1

Do .manifest files allow comments? If so, we should document why this is YouSendIt instead of Hightail.

::: mail/components/cloudfile/nsHightail.js
@@ +72,5 @@
>    /**
>     * Used by our testing framework to override the URLs that this component
>     * communicates to.
>     */
> +  overrideUrls: function nsHightail_overrideUrls(aNumUrls, aUrls) {

These function names are no longer required because Spidermonkey now supplies the property name along with the function. So let's not make future work for ourselves, and just remove these function names.

Maybe file a bug to do the same with the rest of the Cloudfile stuff.
Attachment #8384254 - Flags: review?(mconley) → review+
(Assignee)

Comment 11

4 years ago
https://hg.mozilla.org/comm-central/rev/50444e73055a -> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 31.0
(Assignee)

Comment 12

4 years ago
Posted to mozilla.dev.l10n about the scripts to do the switchover.

Updated

4 years ago
Blocks: 1019625
You need to log in before you can comment on or make changes to this bug.