Closed Bug 894972 Opened 7 years ago Closed 7 years ago

Several toolbar menus in Mail & News and Composer windows are collapsed in recent trunk nightly

Categories

(SeaMonkey :: UI Design, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 895129

People

(Reporter: rsx11m.pub, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

Going into the Mail & News window, the "View" menu should show the current selection. Instead, it is collapsed:

 - Windows 7 Default: vertical mini menu without content
 - Windows Classic: a small square without content
 - Linux KDE 4: horizontal mini menu without content

Tested with SeaMonkey's "classic" theme. In addition, with the Windows 7 Default desktop theme, the menu item on the top block with the radiogroup (All, Unread, etc.) shows no text when highlighted.

Recent regression: not seen in a 20130715 Linux build, seen in today's nightly builds.
Attached image Screenshot
SeaMonkey classic theme on Windows 7 Default desktop. Hardware acceleration is enabled here, but it doesn't make a difference.
To be clear: The menu itself is still functional once clicked on, only the display of the current selection is broken.
Not affected: Nightly build 20130716 (linux i686)
Affected: Tinderbox #1373995849, 20130716103049

Thus, a couple of hours before the following changesets:

http://hg.mozilla.org/mozilla-central/rev/5f79304fcefe
http://hg.mozilla.org/comm-central/rev/9cf4459806ca
> Tested with SeaMonkey's "classic" theme. In addition, with the Windows 7
> Default desktop theme, the menu item on the top block with the radiogroup
> (All, Unread, etc.) shows no text when highlighted.

I see this with the current SM 2.19 release already, so that's an independent theme issue and may be pending as such already.
Summary: The "View" menu of the 3-pane window is collapsed in recent trunk nightly → The Mail Views menu of the 3-pane window is collapsed in recent trunk nightly
Not sure if it is related, but in composing a message, the mail composition toolbar is missing the font selection button. Font color, size, etc.. is present but not anymore the font selections button.
Comment #5 was also reported for Thunderbird, so this may be a more wide-spread regression. http://forums.mozillazine.org/viewtopic.php?f=29&t=2730191#p12975971
Ok, confirmed for SeaMonkey's message-composition window and the style selector in the Composer window, so this is a general problem with menulists in toolbars.

Mark, I don't know if it makes sense to open a separate bug for Thunderbird given that it appears to be a cross-application issue, but maybe you have a suggestion for a better component to move this to. I don't see anything matching filed for Toolkit yet, but maybe Firefox doesn't use this kind of construct, thus it won't be as obvious for the Firefox nightly builds.

BTW: Comment #4 is handled in bug 895039.
Component: MailNews: Message Display → UI Design
Summary: The Mail Views menu of the 3-pane window is collapsed in recent trunk nightly → Several toolbar menus in Mail & News and Composer windows are collapsed in recent trunk nightly
This bug here might be related to Bug 895129, have to check in tomorrow's nightly build.
Neil confirmed that.
Depends on: 895129
Comment on attachment 777204 [details]
Screenshot

I saw this on my own build, troubleshooted the problem, and forgot to search Bugzilla before filing bug 895129. Other elements may also be affected.
No problem, let's make this a duplicate then and reopen if it's not fixed in all instances with the next nightly after your patch has landed on mozilla-central.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 895129
Oh, mrbkap wrote that patch (and reviewed it himself, interesting), so that was a simple typo from a prior checkin.
(In reply to rsx11m from comment #12)
> Oh, mrbkap wrote that patch (and reviewed it himself, interesting), so that
> was a simple typo from a prior checkin.

For the record, the patch had r=sicking in person (see also bug 888787 comment 19).
Sure, I figured that there might have been some review shortcut for a typo like this to speed up the procedure, but it looked weird at the moment to see that without any further comment where the r+ came from.
Verified fixed on Linux: SM 2.22a1 tinderbox build #1374246229, and TB 25.0a1 tinderbox build #1374246258; all affected menus in the Mail & News 3-pane and composition windows as well as SeaMonkey's Composer window are fully visible and functional again.
Status: RESOLVED → VERIFIED
No longer depends on: 895129
You need to log in before you can comment on or make changes to this bug.