Closed Bug 895024 Opened 9 years ago Closed 9 years ago

Intermittent test_secondPlugin.html, test_bug593174.html,test_pluginstream_err.html,test_bug73586.html,browser_webconsole_network_panel.js | Exited with code 1 during test run | application crashed [@ GetContextFromObjectOrDefault]

Categories

(Core :: XPConnect, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 891891

People

(Reporter: RyanVM, Unassigned)

Details

(Keywords: crash)

Crash Data

https://tbpl.mozilla.org/php/getParsedLog.php?id=25382910&tree=Mozilla-Inbound

Rev4 MacOSX Lion 10.7 mozilla-inbound opt test mochitest-3 on 2013-07-17 09:12:28 PDT for push 4aed60373019
slave: talos-r4-lion-027

09:29:07     INFO -  25985 INFO TEST-START | /tests/dom/tests/mochitest/bugs/test_bug593174.html
09:29:07     INFO -  iframeLoaded. loadCount=1 identifier='outer'
09:29:07  WARNING -  TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/bugs/test_bug593174.html | Exited with code 1 during test run
09:29:07     INFO -  INFO | automation.py | Application ran for: 0:13:10.057525
09:29:07     INFO -  INFO | zombiecheck | Reading PID log: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmpLjDLGapidlog
09:29:07     INFO -  mozcrash INFO | Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1374070776/firefox-25.0a1.en-US.mac.crashreporter-symbols.zip
09:29:07     INFO -  Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1374070776/firefox-25.0a1.en-US.mac.crashreporter-symbols.zip
09:29:56  WARNING -  PROCESS-CRASH | /tests/dom/tests/mochitest/bugs/test_bug593174.html | application crashed [@ GetContextFromObjectOrDefault]
09:29:56     INFO -  Crash dump filename: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmp0Nmg6k/minidumps/617833F7-6C8A-4571-9C40-3177DD88ED4A.dmp
09:29:56     INFO -  Operating system: Mac OS X
09:29:56     INFO -                    10.7.2 11C74
09:29:56     INFO -  CPU: amd64
09:29:56     INFO -       family 6 model 23 stepping 10
09:29:56     INFO -       2 CPUs
09:29:56     INFO -  Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
09:29:56     INFO -  Crash address: 0x0
09:29:56     INFO -  Thread 18 (crashed)
09:29:56     INFO -   0  XUL!GetContextFromObjectOrDefault [xpcprivate.h:4aed60373019 : 458 + 0x0]
09:29:56     INFO -      rbx = 0x000000010f309aa0   r12 = 0x0000000117612780
09:29:56     INFO -      r13 = 0x000000010324656c   r14 = 0x0000000117612780
09:29:56     INFO -      r15 = 0x000000010f309aa0   rip = 0x00000001023d38ba
09:29:56     INFO -      rsp = 0x000000010f309800   rbp = 0x000000010f309910
09:29:56     INFO -      Found by: given as instruction pointer in context
09:29:56     INFO -   1  XUL!nsXPCWrappedJSClass::DelegatedQueryInterface(nsXPCWrappedJS*, nsID const&, void**) [XPCWrappedJSClass.cpp:4aed60373019 : 624 + 0x7]
09:29:56     INFO -      rbx = 0x000000010f309aa0   r12 = 0x0000000117612780
09:29:56     INFO -      r13 = 0x000000010324656c   r14 = 0x000000010f309ae8
09:29:56     INFO -      r15 = 0x000000010f309aa0   rip = 0x00000001023d3391
09:29:56     INFO -      rsp = 0x000000010f309920   rbp = 0x000000010f309a70
09:29:56     INFO -      Found by: call frame info
09:29:56     INFO -   2  XUL!nsQueryReferent::operator()(nsID const&, void**) const [nsWeakReference.cpp:4aed60373019 : 56 + 0x8]
09:29:56     INFO -      rbx = 0x000000010f309aa0   r12 = 0x00000001173e1890
09:29:56     INFO -      r13 = 0x0000000000000001   r14 = 0x000000010f309ae8
09:29:56     INFO -      r15 = 0x0000000103e6a040   rip = 0x0000000101679024
09:29:56     INFO -      rsp = 0x000000010f309a80   rbp = 0x000000010f309a90
09:29:56     INFO -      Found by: call frame info
09:29:56     INFO -   3  XUL!nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const&, nsID const&) [nsCOMPtr.cpp:4aed60373019 : 110 + 0x11]
09:29:56     INFO -      rbx = 0x000000010f309b00   r12 = 0x00000001173e1890
09:29:56     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000001
09:29:56     INFO -      r15 = 0x0000000103e6a040   rip = 0x000000010167599b
09:29:56     INFO -      rsp = 0x000000010f309aa0   rbp = 0x000000010f309ab0
09:29:56     INFO -      Found by: call frame info
09:29:56     INFO -   4  XUL!nsDocLoader::DoFireOnStateChange(nsIWebProgress*, nsIRequest*, int&, tag_nsresult) [nsCOMPtr.h:4aed60373019 : 727 + 0xb]
09:29:56     INFO -      rbx = 0x0000000100370168   r12 = 0x00000001173e1890
09:29:56     INFO -      r13 = 0x0000000000000001   r14 = 0x0000000000000001
09:29:56     INFO -      r15 = 0x0000000103e6a040   rip = 0x000000010243a887
09:29:56     INFO -      rsp = 0x000000010f309ac0   rbp = 0x000000010f309b30
09:29:56     INFO -      Found by: call frame info
Summary: Intermittent test_bug593174.html | Exited with code 1 during test run | application crashed [@ GetContextFromObjectOrDefault] → Intermittent test_bug593174.html,test_pluginstream_err.html | Exited with code 1 during test run | application crashed [@ GetContextFromObjectOrDefault]
https://tbpl.mozilla.org/php/getParsedLog.php?id=25814626&tree=Mozilla-Central
Depends on: 891891
Summary: Intermittent test_bug593174.html,test_pluginstream_err.html | Exited with code 1 during test run | application crashed [@ GetContextFromObjectOrDefault] → Intermittent test_bug593174.html,test_pluginstream_err.html,test_bug73586.html | Exited with code 1 during test run | application crashed [@ GetContextFromObjectOrDefault]
Summary: Intermittent test_bug593174.html,test_pluginstream_err.html,test_bug73586.html | Exited with code 1 during test run | application crashed [@ GetContextFromObjectOrDefault] → Intermittent test_secondPlugin.html, test_bug593174.html,test_pluginstream_err.html,test_bug73586.html | Exited with code 1 during test run | application crashed [@ GetContextFromObjectOrDefault]
Crash Signature: [@ GetContextFromObjectOrDefault]
Depends on: 904474
https://tbpl.mozilla.org/php/getParsedLog.php?id=26648661&tree=Mozilla-Inbound
Summary: Intermittent test_secondPlugin.html, test_bug593174.html,test_pluginstream_err.html,test_bug73586.html | Exited with code 1 during test run | application crashed [@ GetContextFromObjectOrDefault] → Intermittent test_secondPlugin.html, test_bug593174.html,test_pluginstream_err.html,test_bug73586.html,browser_webconsole_network_panel.js | Exited with code 1 during test run | application crashed [@ GetContextFromObjectOrDefault]
Status: NEW → RESOLVED
Closed: 9 years ago
No longer depends on: 891891, 904474
Resolution: --- → DUPLICATE
Duplicate of bug: 891891
You need to log in before you can comment on or make changes to this bug.