Closed Bug 895243 Opened 6 years ago Closed 6 years ago

Defect - Monocles not being dismissed when dismissing App bar while OSK visible

Categories

(Firefox for Metro Graveyard :: Input, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 25

People

(Reporter: kjozwiak, Assigned: jimm)

References

Details

(Whiteboard: feature=defect u=metro_firefox_user c=content_features p=1)

Attachments

(2 files, 1 obsolete file)

When you have the "App" bar opened with the OSK visible, dismissing the "App" bar by sliding it downwards will leave the OSK and the monocles behind. (Not 100% but could be related to Bug 894713)

- Attached a video to illustrate this issue occurring

Steps to reproduce the issue:

1) Open Firefox Metro
2) Go to wikipedia.org
3) Once the website has loaded, select the URL bar (the OSK should slide into view)
4) Select the text in the URL text field and ensure that you have monocles visible
5) Once the monocles are visible, dismiss the "App" bar by sliding it out of view at the bottom (Notice that the OSK & the monocles are being left behind)

Current Behavior:

- When dismissing the "App" bar by sliding it back to the bottom, the OSK and the monocles will be left behind

Expected Behavior:

- Not 100% sure if the OSK should also be dismissed (makes sense though), but the monocles should definitely be dismissed
Attached patch fix (obsolete) — Splinter Review
Assignee: nobody → jmathies
Attached patch fixSplinter Review
This hides the monocles when we receive MozAppbarDismissing (which we get before the transition starts) and shows them on transition end when we move the nav bar back up.
Attachment #777800 - Attachment is obsolete: true
Attachment #777803 - Flags: review?(mbrubeck)
Blocks: metrov1it11
Whiteboard: feature=story u=metro_firefox_user c=content_features p=0 → feature=story u=metro_firefox_user c=content_features p=1
No longer blocks: metrov1defect&change
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Whiteboard: feature=story u=metro_firefox_user c=content_features p=1 → feature=defect u=metro_firefox_user c=content_features p=1
Comment on attachment 777803 [details] [diff] [review]
fix

Review of attachment 777803 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/metro/base/content/helperui/ChromeSelectionHandler.js
@@ +276,5 @@
> +    if (!this._targetElement) {
> +      return false;
> +    }
> +    let selection = this._getSelection();
> +    return !selection ? false : !selection.isCollapsed;

Suggestion: "return (selection && !selection.isCollapsed);" is clearer to me.
Attachment #777803 - Flags: review?(mbrubeck) → review+
Duplicate of this bug: 895546
https://hg.mozilla.org/mozilla-central/rev/ecd1ef725d29
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:25.0) Gecko/20100101 Firefox/25.0
Build ID: 20130805030205

WFM
Tested on Windows 8 for iteration-11 using latest nightly built from http://hg.mozilla.org/mozilla-central/rev/482b9d04974a

I followed steps provided in comment0 and got expected result.
OSK didn't dismissed, but the monocles dismissed.
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130815030203
Built from http://hg.mozilla.org/mozilla-central/rev/a8daa428ccbc

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in comment0 and got expected result.
Went through the following "Defect" for iteration #13 without any issues. Used the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-09-09-03-02-04-mozilla-central/

- Went through the original test cases added in comment #0 without any issues
- Ensured that dismissing the OSK using the Windows Charm cleared the monocles without any issues
- Ensured that switching to Desktop then coming back to Firefox Metro cleared the monocles without issues
- Ensured that dismissing the OSK by tapping on the website cleared the monocles without any issues
- Went through all of the above test cases using both full & filled views
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.