Closed Bug 895409 Opened 6 years ago Closed 6 years ago

Pref on SkiaGL canvas

Categories

(Firefox for Android :: Toolbar, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 25
Tracking Status
relnote-firefox --- 26+

People

(Reporter: snorp, Assigned: snorp)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
Attachment #777781 - Flags: review?(blassey.bugs)
This of course depends on a whole bunch of bugs, but mainly 858237.
Depends on: 858237
Attachment #777781 - Flags: review?(blassey.bugs) → review+
Backed out in the hope that this will fix the Android 2.2 reftest failures of form:
https://tbpl.mozilla.org/php/getParsedLog.php?id=25471979&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=25472104&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=25481187&tree=Mozilla-Inbound

...and that I can avoid having to back out the rest of the push.

Out of curiosity, did this patch set get sent to try? I've looked in several of the mentioned bugs, but couldn't find a link.

Backout:
remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/6b3289859dd1
Ugh. Thanks for not backing out all of them. The pref one should do the trick.

We've been developing on the graphics branch, and had a couple green runs there.
Duplicate of this bug: 895789
https://hg.mozilla.org/mozilla-central/rev/bdd1a266176f
Assignee: nobody → snorp
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Depends on: 898768
Depends on: 902426
Hey Erin, should we be communicating this as a perf win, or something different?
Flags: needinfo?(elancaster)
Hi Alex, sorry to just be getting back to you. I don't have quantitative data but I can say:
*This is the first iteration of SkiaGL support for devices with NVIDIA GPUs (only)
*We expect canvas perf improvements in general, one immediate example could be increased FPS with sites such as:
**http://www.craftymind.com/factory/guimark2/HTML5GamingTest.html
**http://ie.microsoft.com/testdrive/Performance/FishBowl/Default.html
*Snorp working to turn SkiaGL on for more devices and therefore, our scope of testing will increase
*Not to pass the buck, but I am need-infoing blassey and snorp to weigh in on how much we should message today. This is certainly interesting from a development point of view and will be more so for users as we increase support/test/stabilize
Flags: needinfo?(snorp)
Flags: needinfo?(elancaster)
Flags: needinfo?(blassey.bugs)
Don't worry too much about the timeline all, we can change the notes throughout the Aurora cycle.
I think relnote-wise we should talk about the perf win for nvidia devices. We should probably wait until 26 to any PR noise about it since it is a bit nuanced (perf win on certain canvas ops on certain devices)
Flags: needinfo?(blassey.bugs)
Depends on: 904483
Depends on: 915938
Flags: needinfo?(snorp)
Depends on: 982489
You need to log in before you can comment on or make changes to this bug.