Closed Bug 895655 Opened 9 years ago Closed 9 years ago

Error from pageaction api

Categories

(Firefox for Android Graveyard :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 25

People

(Reporter: wesj, Assigned: wesj)

References

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
We accidently used old style message passing for pageactions. We should remove the unnecessary gecko object. We should also use resolveGeckoUri to allow addons to use chrome url's.
Attachment #778103 - Flags: review?(margaret.leibovic)
Attachment #778103 - Attachment is patch: true
Comment on attachment 778103 [details] [diff] [review]
Patch

Review of attachment 778103 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/chrome/content/browser.js
@@ +1596,5 @@
>        sendMessageToJava({
> +        type: "PageActions:Add",
> +        id: id,
> +        title: aOptions.title,
> +        icon: resolveGeckoUri(aOptions.icon),

Nit: I don't like the trailng comma.
Attachment #778103 - Flags: review?(margaret.leibovic) → review+
You should land this! :P
Assignee: nobody → wjohnston
Duplicate of this bug: 900687
https://hg.mozilla.org/mozilla-central/rev/82c3a4ad5d69
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Please can bugs changing these parts of the tree land on fx-team in the future to help balance load & avoid conflicts (for more info see Gavin's newsgroup post: https://mail.mozilla.org/pipermail/firefox-dev/2013-July/000618.html). Thank you :-)
Depends on: 901408
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.