Closed Bug 895896 Opened 8 years ago Closed 8 years ago

Firefox OS Browser jitters and jumps when you try to pan or zoom

Categories

(Core :: Graphics: Layers, defect)

defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 883646
blocking-b2g hd+

People

(Reporter: eeepc904, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.71 Safari/537.36

Steps to reproduce:

Open the browser, go to any web site and try to pan or zoom.


Actual results:

The page started to jitter and jump instead of scrolling/zooming.


Expected results:

The page should have scrolled/zoomed.
Severity: normal → critical
Here's a little video describing the issue: https://dl.dropboxusercontent.com/u/12174296/VID_00000001.mp4

I'm running 1.1.0.0hd-prerelease (Build ID 20130719101740) on a Geeksphone Peak.
Severity: critical → normal
Summary: Firefox OS Browser is jitters and jumps when you try to pan or zoom → Firefox OS Browser jitters and jumps when you try to pan or zoom
Severity: normal → critical
I'd like to add that links are also not clickable, which I think is related.
Geeksphone Peak with Firefox OS 1.1.0.0hd-prerelease (Build ID 20130721003719):
- Scrolling does not work as expected: most of the times the whole page jumps to the right and you can't reach the bottom of the page.
- With most pages zooming does not work at all.
- When clicking on an URL most of the times nothing happens. Sometimes the browser will open another URL that's linked from the page but never the one you've selected. This is not only annoying but a security risk!

For now the browser is not usable anymore.
Same problems as mentioned by michael@psychopope.de with my Peak and Firefox OS 1.1.0.0hd-prerelease.

I had this same issue in the past when using the Geeksphone nightly builds.
Same problem here with 1.1. The Firefox browser is effectively useless, but the installed apps work nicely.
Same problem. 

OS Version: 1.1.0.0hd-prerelease
Hardware revision: qcom
Build: 20130719101740
Device: Geeksphone Peak

The browser is completely unusuable as a result. Saving a site to the phone's homepage as an "app" results in the problem not being present when used as an app. But in the browser the hyperlink-clicking issue and scroll jitters make it almost impossible to browse at all.
Build 20130723003438: no significant changes
Build 20130724103623: zooming works better but all other problems are still there (scrolling, black screen, URLs not working, wrong URLs opening)
Build 20130725003518: same as 20130724103623
OS Version: 1.1.0.0hd-prerelease
Hardware revision: qcom
Build: 20130725003518
Device: Geeksphone Peak 

I haven't seen much change with this build.

Browser page moves sideways and flickers on/off showing a black screen while attempting to scroll down. URLs, when clicked, either don't work or the browser instead activates a different URL on the page.

Contrary to my report above, I've found that saving the page to the home screen does not alleviate or alter the behavior when loaded in that fashion.

Effectively incapable of using the browser at all.
seems to only happen in the hd branch.

qawanted to know if that happens on other branches, nominating hd? in the mean time.

bug 880578 was uplifted to the b2g18 branch the 19th of July, so to me this is the most obvious culprit. (note: it was uplifted to fix bug 892088).

Needinfo Benoit as Anthony is away until monday.
blocking-b2g: --- → hd?
Component: Gaia::Browser → Graphics: Layers
Flags: needinfo?(bgirard)
Keywords: qawanted
Product: Boot2Gecko → Core
Severity: critical → major
QA Contact: sparsons
This issue does not reproduce on Leo Build ID: 20130726070208

Environmental Variables
Build ID: 20130726070208
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d6e518d3ef28
Gaia: 9c868050bcc6f522f54f4afc0f0e4aa9a6149771
Platform Version: 18.1
RIL Version: 01.01.00.019.171 

Browser does not jump and jitter when trying to pan or zoom.
Keywords: qawanted
(In reply to Sarah Parsons from comment #11)
> This issue does not reproduce on Leo Build ID: 20130726070208
> 
> Environmental Variables
> Build ID: 20130726070208
> Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/d6e518d3ef28
> Gaia: 9c868050bcc6f522f54f4afc0f0e4aa9a6149771
> Platform Version: 18.1
> RIL Version: 01.01.00.019.171 
> 
> Browser does not jump and jitter when trying to pan or zoom.

I am still experiencing this issue with Build ID 20130726003708
Platform version: 18.1

Was your test on the Peak hardware? I've only heard of problems on that specific device.

I don't know how to get the Gecko, Gaia, and RIL Version information to say for sure if it's the same as what you tested on or not.
We are not checking on the Peak hardware, we are checking on the b2g18. We currently don't have access to the HD devices.

I have heard that the HD browser is currently experience issue with scrolling.

Devices we currently have access to are: Buri, Leo, Unagi, and Inari
(In reply to Darren from comment #13)
> We are not checking on the Peak hardware, we are checking on the b2g18. We
> currently don't have access to the HD devices.
> 
> I have heard that the HD browser is currently experience issue with
> scrolling.

What kind of logs or other information we, unhappy users of Peak, could provide you to help you to resolve this issue?
Thanks Sarah/Darren, at least we now know that it happens only with hd devices.
needinfo Anthony as well, for when he comes back ;)
Flags: needinfo?(ajones)
blocking-b2g: hd? → hd+
Build 20130729003826: no improvements. After playing around with this bug I'm pretty sure that the browser doesn't know the actual screen resolution und thus misinterprets the position of touch events.

A good site to start is google.com: When you touch the screen the page jumps to the right and can't be moved back. And you can't zoom out to see the whole of the misplaced website. Links won't work either.

On longer pages you can't scroll to the end. Additionally the screens starts switching to black and back again while scrolling. Sometimes parts of the page stay blank (not flash content but half rendered text and images).

Hope this helps to find the cause of this trouble...
Suppose to be fixed after bug 883646 is backported.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 883646
Hi Wayne,

Since this bug can be fixed by bug 883646 and which one is hd+ also.
So maybe we can cancel the hd+ here.
Flags: needinfo?(wchang)
Looks like my info is no longer needed here.
Flags: needinfo?(bgirard)
Looks like my info is no longer needed either.
Flags: needinfo?(ajones)
Thanks for your help!
I cannot reproduce this bug on the following build.
* Test build:(Mozilla-b2g18_v1_1_0_hd-helix/2013-08-12-04-22-03)
  + Mercurial-Information
    - Gecko revision="afd50da34b9f"
  + Git-information
    - Gaia revision="134356dc21d0627455f8bc536b140a18f39e20e9"
clearing my ni
Flags: needinfo?(wchang)
You need to log in before you can comment on or make changes to this bug.