Closed Bug 896223 Opened 6 years ago Closed 6 years ago

Remove the version 1 manifest from the mar creation scripts

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(firefox29 fixed, firefox30 fixed)

RESOLVED FIXED
Tracking Status
firefox29 --- fixed
firefox30 --- fixed

People

(Reporter: rstrong, Assigned: rstrong)

References

Details

Attachments

(1 file)

Since all users must update to Firefox 12 before they update to newer versions the version 1 update.manifest is no longer needed.
I would like to make these changes at the same time as bug 759469 so adding dependency
Depends on: 759469
Attached patch patch rev1Splinter Review
Nick, not sure who would be best to review this so feel free to pass this review onto someone else.
Attachment #784053 - Flags: review?(nthomas)
I'll take a closer look at this tomorrow, but eyeballs fine from a high level.
Sorry for the delay, I've been unwell and will get to this as soon as I can.
No problem Nick and I hope you feel better soon.
Comment on attachment 784053 [details] [diff] [review]
patch rev1

Review of attachment 784053 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Attachment #784053 - Flags: review?(nthomas) → review+
Product: mozilla.org → Release Engineering
Pushed to mozilla-central
https://hg.mozilla.org/mozilla-central/rev/c6123402c5f6
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 784053 [details] [diff] [review]
patch rev1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): None
User impact if declined: Releng will need to perform additional work to create update mar files for additional cycles to update beta users to release bits.
Testing completed (on m-c, etc.): This has been on m-c for several days, I've manually verified thoroughly, tests in bug 759469
Risk to taking this patch (and alternatives if risky): Minimal
String or IDL/UUID changes made by this patch: None
Attachment #784053 - Flags: approval-mozilla-aurora?
Attachment #784053 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.