Closed Bug 896224 Opened 6 years ago Closed 6 years ago

Remove support for the version 1 manifest from the updater

Categories

(Toolkit :: Application Update, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed

People

(Reporter: rstrong, Assigned: rstrong)

References

Details

Attachments

(1 file, 1 obsolete file)

Since all users must update to Firefox 12 before they update to newer versions the version 1 update.manifest is no longer needed.
I would like to make these changes at the same time as bug 759469 so adding dependency
Depends on: 759469
Attached patch patch rev1 (obsolete) — Splinter Review
I'll fix up the tests when I add support for bug 759469. That way I don't have to generate new mars twice.
Attachment #784056 - Flags: review?(netzen)
Comment on attachment 784056 [details] [diff] [review]
patch rev1

Review of attachment 784056 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/mozapps/update/updater/updater.cpp
@@ +3591,5 @@
>    if (rb == NULL) {
>      LOG(("AddPreCompleteActions: error getting contents of precomplete " \
>           "manifest"));
> +    // Applications are required to have a precomplete manifest.
> +    return PARSE_ERROR;

we may want to track this error differently, but I'll leave it up to you.  I think we're really close to the max telemetry errors though so if we exceed that we'd have to great a new histogram there.

@@ +3686,5 @@
>        continue;
>      }
> +    else {
> +      LOG(("DoUpdate: type not found in manifest"));
> +      return PARSE_ERROR;

ditto above
Attachment #784056 - Flags: review?(netzen) → review+
Both of these errors shouldn't happen so I'm fine with using the generic error
yep that's fine, if we seen a spike then we'd know where it came from anyway.
Attached patch bug896224Splinter Review
I changed it so the precomplete manifest isn't required by the updater and instead made the mar generation scripts error if there isn't a precomplete manifest. I think this way is safer.
Attachment #784056 - Attachment is obsolete: true
Attachment #8377349 - Flags: review?(netzen)
Attachment #8377349 - Flags: review?(netzen) → review+
Pushed to mozilla-central
https://hg.mozilla.org/mozilla-central/rev/6230354e8d05
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Comment on attachment 8377349 [details] [diff] [review]
bug896224

[Approval Request Comment]
Bug caused by (feature/regressing bug #): None
User impact if declined: Releng will need to perform additional work to create update mar files for additional cycles to update beta users to release bits.
Testing completed (on m-c, etc.): This has been on m-c for several days, I've manually verified thoroughly, tests in bug 759469
Risk to taking this patch (and alternatives if risky): Minimal
String or IDL/UUID changes made by this patch: None
Attachment #8377349 - Flags: approval-mozilla-aurora?
Attachment #8377349 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.