Last Comment Bug 896348 - "Eisu" (英数) key of JIS keyboard for Mac shouldn't be mapped with "RomanCharacters"
: "Eisu" (英数) key of JIS keyboard for Mac shouldn't be mapped with "RomanCharac...
Status: RESOLVED FIXED
[u= c= p=0]
: dev-doc-complete, inputmethod
Product: Core
Classification: Components
Component: DOM: Events (show other bugs)
: Trunk
: x86_64 All
: -- normal (vote)
: mozilla37
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan) (Offline: 9/19, 9/22-9/25, 9/28))
:
Mentors:
Depends on: 936315
Blocks: 842927 900372
  Show dependency treegraph
 
Reported: 2013-07-22 01:15 PDT by Masayuki Nakano [:masayuki] (Mozilla Japan) (Offline: 9/19, 9/22-9/25, 9/28))
Modified: 2016-08-23 15:15 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Support "Eisu" key value on Mac, Android and Gonk (2.77 KB, patch)
2014-06-24 07:36 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan) (Offline: 9/19, 9/22-9/25, 9/28))
bugs: review+
smichaud: review+
nchen: review+
mwu.code: review+
Details | Diff | Splinter Review

Description Masayuki Nakano [:masayuki] (Mozilla Japan) (Offline: 9/19, 9/22-9/25, 9/28)) 2013-07-22 01:15:41 PDT
I think that my mapping in bug 842927 is wrong for the "Eisu" (英数) key of JIS keyboard for Mac.

The key doesn't make "Roman character input mode" enable. The key closes IME on Mac (I'm not sure how it works with Android 4.1 and later). So, the key should be "Alphanumeric" or something new key name.

I posted this to the bugzilla of w3.org.
https://www.w3.org/Bugs/Public/show_bug.cgi?id=22750

Anyway, we need to remap the key name in the future.
Comment 1 Masayuki Nakano [:masayuki] (Mozilla Japan) (Offline: 9/19, 9/22-9/25, 9/28)) 2014-06-24 07:36:52 PDT
Created attachment 8445202 [details] [diff] [review]
Support "Eisu" key value on Mac, Android and Gonk

Japanese keyboard layout has two different Eisu (英数) keys. One is the left of KeyA of PC keyboard. The other is the left of space key of Mac keyboard. I.e., they are never existing on same physical keyboard (usually).

They work really different. The former is typically used for changing IME input mode to ASCII capable. The latter is typically used for closing IME. Therefore, D3E-key defines "Alphanumeric" for the former and "Eisu" for the latter.

These names are messy. But since they have really different purpose, D3E-key value should distinguish them.

https://dvcs.w3.org/hg/dom3events/raw-file/tip/html/DOM3Events-key.html#key-Eisu
https://dvcs.w3.org/hg/dom3events/raw-file/tip/html/DOM3Events-key.html#key-Alphanumeric
Comment 2 Masayuki Nakano [:masayuki] (Mozilla Japan) (Offline: 9/19, 9/22-9/25, 9/28)) 2014-06-24 07:41:11 PDT
FYI: We've already mapped them as "RomanCharacters" (which has already renamed to "Romaji"). The definition of the key by renaming the key name causes this mapping is really wrong. Therefore, "Eisu" is defined for the Mac keyboard's "Eisu" key.
Comment 3 Steven Michaud [:smichaud] (Retired) 2014-06-24 08:46:41 PDT
Comment on attachment 8445202 [details] [diff] [review]
Support "Eisu" key value on Mac, Android and Gonk

This looks reasonable to me.  But there are some things I don't understand.

What are we going to do about the "Alphanumeric" key?  Why isn't the Android key name "Alphanumeric" instead of "Eisu"?  (I assume Android would use what you've called a "PC keyboard".)
Comment 4 Masayuki Nakano [:masayuki] (Mozilla Japan) (Offline: 9/19, 9/22-9/25, 9/28)) 2014-06-24 09:57:33 PDT
(In reply to Steven Michaud from comment #3)
> What are we going to do about the "Alphanumeric" key?  Why isn't the Android
> key name "Alphanumeric" instead of "Eisu"?  (I assume Android would use what
> you've called a "PC keyboard".)

Good point.

The Eisu key on PC keyboard is also CapsLock key. On Windows, Eisu key causes changing IME input mode to ASCII capable mode in most IMEs. Additionally, Shift + Eisu is CapsLock.

On Linux, it depends on system settings. On some environments, the key works as like the key on Windows. On others, the key works just as CapsLock key.

On Android, it works just a CapsLock key. Therefore, in software level, there is no PC-Eisu key on Android. However, Android has a key code for Eisu key of Japanese Mac Keyboard. The key code is used only for the key.
Comment 5 Masayuki Nakano [:masayuki] (Mozilla Japan) (Offline: 9/19, 9/22-9/25, 9/28)) 2014-12-29 17:57:20 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/62246121651b
Comment 6 Wes Kocher (:KWierso) 2014-12-30 15:55:41 PST
https://hg.mozilla.org/mozilla-central/rev/62246121651b
Comment 7 Eric Shepherd [:sheppy] 2016-07-29 07:57:56 PDT
This has been corrected on the KeyboardEvent.key page on MDN during a total rewrite I'm doing there. KeyboardEvent.code has not been done yet.
Comment 8 Eric Shepherd [:sheppy] 2016-07-29 08:01:25 PDT
This has also been noted now (at last) on Firefox 37 for developers. Still need to update KeyboardEvent.code. It's on my to-do list.
Comment 9 Eric Shepherd [:sheppy] 2016-08-23 15:15:51 PDT
This has now been updated in KeyboardEvent.code. This is now doc complete.

Note You need to log in before you can comment on or make changes to this bug.