Garbage in window titles on 0.9.2+ builds

VERIFIED DUPLICATE of bug 88384

Status

()

Core
Editor
VERIFIED DUPLICATE of bug 88384
17 years ago
17 years ago

People

(Reporter: Francisco León, Assigned: rubydoo123)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2+) Gecko/20010706
BuildID:    2001070608

If i open an email with the subject "Re: something", weird characters appear in
the mail window title

Reproducible: Always
Steps to Reproduce:
1.Open an email with Re: something subject in it


Actual Results:  Weird chars show up on the mail title

Expected Results:  The exact subject
(Reporter)

Comment 1

17 years ago
Created attachment 41436 [details]
What mail title looks like when clicking on a Re: mail
I think this is a dup.

note, it works fine for mail with ASCII subjects.
(Reporter)

Comment 3

17 years ago
Yuck, other windows are affected too after clicking on Re: mails
Talk about catfood...
Keywords: nsCatFood
(Reporter)

Comment 4

17 years ago
The only similar bug involving this is to try and download new fonts for
japanese encoding. The window that showed up had some weird chars. But this is
different. 
I get this on all types of emails that have a Re: subject, it has nothing to do
with language encoding

Comment 5

17 years ago
I have noticed this too in linux over the past month but it happens in browser
titles as well (not just mail).  I can not seem to figure out what triggers this
because not every page suffers from this.  Does anyone else see this on browser
windows?

This has to be a dupe... why I have not made a report.
(Reporter)

Comment 6

17 years ago
As i have said, when you click on a mail with Re: in the subject, it makes this
bug happen, and it replicates itself to the other windows.. Really dont know
why, but i dont think this is a dupe.
bug 87991 is the closest one i found, but it's a different one

Comment 7

17 years ago
This did not exist in 0.9.2, but does exists in 2001070115 mozilla.org RPMs. 

I am not sure what triggers it, but once it is triggered, all windows are
affected, not just MailNews. In particular, right now this Bugzilla window has a
title "??@! - Garbage..." instead of "Bug 89651 - Garbage..."

I am currently running 2001070610 (installed from mozilla.org RPMs) on RedHat
Linux 7.1 under KDE with LANG=ru_RU.KOI8-R
Keywords: regression

Comment 8

17 years ago
I can reproduce this without starting MailNews at all. If I just start "mozilla
-browser", it displays the correct title "Mozilla..." for a second, than goes to
my home page (http://www.cs.cornell.edu/cucs/) and displays either empty title
or "?". 

When I tried it for several times in a row (exiting rigth after it finishes
loading the home page), the "?" and enty title were strictly alternating which
suggests that there is something in profile that interacts with it.
Component: Mail Window Front End → Browser-General
Product: MailNews → Browser
(Reporter)

Comment 9

17 years ago
Component->Editor
Reassigning. I am starting to believe that all titles that have chars different
than a to z cause this problem, for example, semicolons, dashes, etc
That would explain why Re: messages make this look ugly

Hmm i guess i am wrong, your college's webpage does not have anything special in
the title, i dont know then
Updating summary
Adding keywords
Windows and Mac users, please confirm
Assignee: sspitzer → beppe
Component: Browser-General → Editor
Keywords: mozilla0.9.3, nsbeta1
QA Contact: esther → sujay
Summary: Garbage in mail title window when looking Re: mails → Garbage in window titles on 0.9.2+ builds

Comment 10

17 years ago
Could this bug be caused by patches from bug 9449?

Could this bug be confined to some particular window managers? Just in case, I
see it under KDE 2.1.1 (from RedHat 7.1 kde*-2.2.1-8 RPMs)

Comment 11

17 years ago
I suspect this bug is a dup of 88384, and yes, it is caused by the change to
nsWindow.cpp under 9449
(Reporter)

Comment 12

17 years ago
You're right
Marking dupe
I use kde 2.1.1 and xfree 4.1.0

*** This bug has been marked as a duplicate of 88384 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 13

17 years ago
I knew that this had to be a dupe.

verf.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.