Closed Bug 896679 Opened 7 years ago Closed 5 years ago

Figure out another way to uninstall webapps on Linux

Categories

(Firefox Graveyard :: Web Apps, defect, P3)

All
Linux
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: marco, Unassigned)

References

Details

(Keywords: uiwanted)

Currently we're using a freedesktop standard that is supported only on Unity (and looks like the other DEs aren't adding support soon).
We should find a better way to handle uninstallations on Linux, at least on GNOME.
Duplicate of this bug: 899360
I don't see many options here:
1) Firefox specific UI (I know a native solution would be preferred, but if there isn't one we need somehow to let users uninstall apps)
2) A privileged application that uses the mozApps.mgmt API to manage other apps (bug 899994)
3) Create two icons for apps during installation, one to launch the app and the other to uninstall it
firefox listapps

 - app name: app id

firefox uninstallapp <app id>

^ something like that would be interesting.
(In reply to Shuhao Wu [:Pwnna] from comment #3)
> firefox listapps
> 
>  - app name: app id
> 
> firefox uninstallapp <app id>
> 
> ^ something like that would be interesting.

This isn't so userfriendly :D

GNOME 3.10 will finally support desktop actions: http://ftp.gnome.org/pub/GNOME/core/3.9/3.9.5/NEWS

It's still worth to find another uninstall method for other DEs and probably to explain better to the user how to uninstall an application, as it is an unconventional method (maybe for the first 2-3 installs we could write an explanatory message to the install notification).
I think it is assumed that linux are users are (currently) mostly technical.

If Linux becomes more popular... the major DEs needs to agree and implement on a standard like this so that people can implement those for their applications..

But without applications will Linux get popular? Maybe a chicken or egg problem here.
Duplicate of this bug: 902854
Keywords: uiwanted
Priority: -- → P3
I hate polluting the bug report with this, but since I don't know where else to ask and other people are probably looking for this here as well: how, then, does one uninstall webapps on Unity? 

(Also, as I can't find it out -the app is not listed in the Software Center or in the Dash- this might be able to be made more discoverable.)
(In reply to Vincent from comment #7)

It should appear in the dash. Please open another bug, no need to reference here the new bug you open, just add me to the CC list.
With bug 1000315 and the linked bugs to allow third-party homescreens, we could provide on Linux an app that allows people to manage their installed apps. It would be something like about:apps but as a webapp instead of a Firefox about: page. We could, for example, automatically install this management app when an user installs its first app.
Myk, what do you think?
Flags: needinfo?(myk)
@marco Hmm, after I clicking around I found an entry in the launcher that allows you to uninstall an app [1] - is that what you meant? I could not find a link in the dash, although it would make sense there (see arrow in [2]).The management app makes sense, although integration in e.g. PackageKit would be more intuitive, as that is the usual place that applications are uninstalled (and definitely not from their quicklists).

[1] http://i.imgur.com/aFgAtiJ.png
[2] http://i.imgur.com/RQwhbfr.png
(In reply to Marco Castelluccio [:marco] from comment #9)
> With bug 1000315 and the linked bugs to allow third-party homescreens, we
> could provide on Linux an app that allows people to manage their installed
> apps. It would be something like about:apps but as a webapp instead of a
> Firefox about: page. We could, for example, automatically install this
> management app when an user installs its first app.
> Myk, what do you think?

I like the idea of an "app manager" app.  I'm not sure it should be installed by default when a user installs their first app, since that resembles junkware; although perhaps it's justified on Linux (or at least Linux distributions that haven't implemented the freedesktop standards).

But at the very least, we could host it in the Marketplace and refer it to users who want to manage their apps.  Perhaps it could even be the Marketplace app itself, if its developers think it makes sense to add this functionality to that app.

But in Android runtime bug 989086 we've talked about an interface for users to manage app permissions, which desktop users would presumably also want; and I don't think another app would be able to do that.  So our current thinking is to build it into about:apps, which we've implemented on Android; and perhaps it's time to revisit about:apps for desktop.
Flags: needinfo?(myk)
(In reply to Myk Melez [:myk] [@mykmelez] from comment #11)
> I like the idea of an "app manager" app.  I'm not sure it should be
> installed by default when a user installs their first app, since that
> resembles junkware; although perhaps it's justified on Linux (or at least
> Linux distributions that haven't implemented the freedesktop standards).
>
> But at the very least, we could host it in the Marketplace and refer it to
> users who want to manage their apps.  Perhaps it could even be the
> Marketplace app itself, if its developers think it makes sense to add this
> functionality to that app.

Yes, that could be annoying. Suggesting users to install the app looks a good solution. (The solution we have now is quite different than what people are used to, so it probably makes sense also on DEs that support the standard).

> But in Android runtime bug 989086 we've talked about an interface for users
> to manage app permissions, which desktop users would presumably also want;
> and I don't think another app would be able to do that.  So our current
> thinking is to build it into about:apps, which we've implemented on Android;
> and perhaps it's time to revisit about:apps for desktop.

If we decide to revisit about:apps, then the management app becomes useless.

(In reply to Vincent from comment #10)
> @marco Hmm, after I clicking around I found an entry in the launcher that
> allows you to uninstall an app [1] - is that what you meant? I could not
> find a link in the dash, although it would make sense there (see arrow in
> [2]).The management app makes sense, although integration in e.g. PackageKit
> would be more intuitive, as that is the usual place that applications are
> uninstalled (and definitely not from their quicklists).
> 
> [1] http://i.imgur.com/aFgAtiJ.png
> [2] http://i.imgur.com/RQwhbfr.png

Yes, that is what I meant. I think it's impossible for us (or any other non-Canonical software) to be integrated in the dash, at least for the time being.
The main problem with package managers is that each distribution rolls its own package management system.
We could support uninstalling from GNOME Software, but some GNOME devs weren't happy when I suggested this (and anyway GNOME Software is GNOME specific).
Blocks: 1111077
Per bug 1238079, we're going to disable the desktop web runtime and remove it
from the codebase, so we won't fix these bugs in the integration between Firefox and the runtime.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.