The default bug view has changed. See this FAQ.

"Fix" bug 896776 in a way that is safe for leo

RESOLVED FIXED

Status

Firefox OS
Gaia::System
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: khuey, Assigned: khuey)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

Details

(Whiteboard: [MemShrink:P1][LeoVB+])

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #896776 +++

What I really want to do in bug 896776 is probably too invasive for leo.  So let's do something simpler.
Created attachment 779594 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/11107

Pointer to Github pull-request
Attachment #779594 - Flags: review?(alive)
blocking-b2g: --- → leo?
Blocks a blocker.
blocking-b2g: leo? → leo+
Attachment #779594 - Flags: review?(alive) → review+
As I said I'm working on a new system to resolve this kind of problems.
I want to know:
* The problem is closeCallback isn't reset to null or isn't invoked?
* How if we have a static closeCallback for each frame and won't modify that callback after transition?
(In reply to Alive Kuo [:alive][Paris work week 7/22-26] from comment #3)
> As I said I'm working on a new system to resolve this kind of problems.
> I want to know:
> * The problem is closeCallback isn't reset to null or isn't invoked?

It is not invoked.  closeCallback calls removeFrame, and if it is never invoked the iframe is never removed from the DOM.

> * How if we have a static closeCallback for each frame and won't modify that
> callback after transition?

We need to ensure that we invoke the callback.  That is the real problem here.
Yeah I know this problem...sigh it's not totally resolved by some workaround. So I'm working a brand-new transition control to fix all this kind of problems. Thanks for investigation.
> How about if we have a static closeCallback for each frame and won't modify that callback 
> after transition?

That could work, but you would have to be careful not to leak closeCallback, because closeCallback would probably keep the iframe alive.
In bug 896776 Alive says he has a plan to change a lot of code so as to fix this on master.  That's great, but then I think we should land this on master as well as b2g18, so both trees are leak-free.
(In reply to Justin Lebar [:jlebar] from comment #7)
> In bug 896776 Alive says he has a plan to change a lot of code so as to fix
> this on master.  That's great, but then I think we should land this on
> master as well as b2g18, so both trees are leak-free.

Sure!
Whiteboard: [MemShrink] → [MemShrink:P1]
Pushed to master: https://github.com/mozilla-b2g/gaia/commit/3d64d2aefaa80919d183c95c2fd95a94f2b7702a
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Whiteboard: [MemShrink:P1] → [MemShrink:P1][LeoVB+]
Uplifted 3d64d2aefaa80919d183c95c2fd95a94f2b7702a to:
v1-train: 25c7466682f1148da685abc1f2177a3221290d84
status-b2g18: --- → fixed
v1.1.0hd: 25c7466682f1148da685abc1f2177a3221290d84
status-b2g-v1.1hd: --- → fixed
You need to log in before you can comment on or make changes to this bug.