[B2G][Helix][Camera]The time between pressing the capture button and resume to preview is too long

RESOLVED DUPLICATE of bug 866109

Status

RESOLVED DUPLICATE of bug 866109
5 years ago
5 years ago

People

(Reporter: ysdingyu2013, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; Tablet PC 2.0)

Steps to reproduce:

1.Open the camera app 
2.take a snapshot


Actual results:

2.The time between pressing the capture button and resume to preview is too long


Expected results:

2.Compare to android phone, the time is much less
(Reporter)

Comment 1

5 years ago
Analye the camera.js, there is 500ms delay between takePictureSuccess and restartPreview. Can we delay less time??
Dale, can you answer to the question in comment #1?
Flags: needinfo?(dale)
The 500ms delay has been removed on master in https://bugzilla.mozilla.org/show_bug.cgi?id=866109, its wasnt marked blocking therefore hasnt been uplifted, closing as a dupe, will need to get the other bug leo+ to uplift
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(dale)
Resolution: --- → DUPLICATE
Duplicate of bug: 866109
(Reporter)

Comment 4

5 years ago
Dale, Through telephone communication with mozilla, the modify in bug 866109 had not merged to the helix 1.1hvga. Can it merge to the helix 1.1hvga as soon as possible.
DingYu,
at the moment we do not plan to merge this change to v1.1/v1.1HD.
It will however be part of v1.2.
You need to log in before you can comment on or make changes to this bug.