Closed Bug 897073 Opened 10 years ago Closed 2 years ago

About:firefox and about:privatebrowsing text is not translated in multi (ok in separate builds)

Categories

(Firefox for Android Graveyard :: General, defect)

23 Branch
ARM
Android
defect
Not set
normal

Tracking

(firefox22 unaffected, firefox23- affected, firefox24- affected, firefox25- affected, fennec-)

RESOLVED INCOMPLETE
Tracking Status
firefox22 --- unaffected
firefox23 - affected
firefox24 - affected
firefox25 - affected
fennec - ---

People

(Reporter: ioana.chiorean, Unassigned)

Details

Build: Firefox 23.0b8 07/23
Device: LG Nexus 4 (4.2.2), Galaxy Nexus (4.2.2), Galaxy Nexus(4.1)

Steps to reproduce:
1. Install app from ftp ftp://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/23.0b8-candidates/build1/android/multi
2. Open app
3. Change language of the phone in for ex.: es, it, fr, hu, etc
4. Go to about:firefox  or open private new tab - about:privatebrowsing
5. Install app from ftp ftp://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/23.0b8-candidates/build1/android/es-ES/ or /fr/ or /hu/ etc
6. Repeat steps 2 and 4.

Expected Results: 
- Text from about:privatebrowsing and about:firefox is translated in both types of build.

Actual Results:
- Text from about:privatebrowsing and about:firefox is not translated even if in the separate ftp builds is translated
Perhaps not all 'about:' pages were considered in bug 891118.
tracking-fennec: --- → ?
Flags: needinfo?(l10n)
Looking at the multi from ftp,


<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE html [
<!ENTITY % brandDTD SYSTEM "chrome://branding/locale/brand.dtd" >
%brandDTD;
<!ENTITY % globalDTD SYSTEM "chrome://global/locale/global.dtd">
%globalDTD;
<!ENTITY % fennecDTD SYSTEM "chrome://browser/locale/about.dtd">
%fennecDTD;
]>


and in Polish, 

unzip -p omni.ja chrome/pl/locale/pl/browser/about.dtd
<!ENTITY aboutPage.title                        "O programie &brandShortName;">
<!ENTITY aboutPage.warningVersion               "Program &brandShortName; jest w wersji testowej i może być niestabilny.">
<!ENTITY aboutPage.telemetryStart               " Informacje na temat wydajności, użycia, sprzętu i dokonanych zmian są automatycznie wysyłane do organizacji ">
<!ENTITY aboutPage.telemetryMozillaLink         "&vendorShortName;">
<!ENTITY aboutPage.telemetryEnd                 ", aby uczynić program &brandShortName; lepszym.">
<!ENTITY aboutPage.checkForUpdates.link         "Aktualizacja">


Similar for /fr/. That should work from what I can tell.
Flags: needinfo?(l10n)
Single locale build for Italian with Samsung Galaxy S II, works fine.
ftp://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/23.0b8-candidates/build1/android/it/

Same goes for the multi-locales build
ftp://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/23.0b8-candidates/build1/android/multi 

about:privatebrowsing is ok on both normal and private tabs.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
Works for me too, I just tested fr
So I find it odd. You are both right partially . 

In description I installed multi having en-US as lang for device. Changing the device's lang to other produced the above mentioned bug. 
After, I had Spanish on device and installed the multi - pages were translated. Switched to En-Us the device - the mentioned pages remained in Spanish. 

It seems that the l10n for this 2 pages remains blocked at the first one. 
Video: http://www.youtube.com/watch?v=dxTjaNfdfFI

Reproducing on Lg Nexus 4 with 4.2.2 on which after changing language it opens last page. (I tried on Galaxy Nexus - also 4.2.2 but on this device , after changing lang - Firefox loads about:home)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Can you just quit the app and restart, instead of actually reinstalling?

I think I saw Firefox restart on language change to avoid situations like this, but from the video it doesn't look like it did for you.
I can't reproduce this myself using beta 8 and a Nexus 4 or a Galaxy S 4. But I agree with Axel's assessment.
Hey, 
After further investigations I looked at the Developer options and the Nexus 4 had the "Don't keep activities " checked so that's why it opens the same tab. 
It seems the app with that doesn't repaint well the page.
Status: REOPENED → NEW
tracking-fennec: ? → -
We have completed our launch of our new Firefox on Android. The development of the new versions use GitHub for issue tracking. If the bug report still reproduces in a current version of [Firefox on Android nightly](https://play.google.com/store/apps/details?id=org.mozilla.fenix) an issue can be reported at the [Fenix GitHub project](https://github.com/mozilla-mobile/fenix/). If you want to discuss your report please use [Mozilla's chat](https://wiki.mozilla.org/Matrix#Connect_to_Matrix) server https://chat.mozilla.org and join the [#fenix](https://chat.mozilla.org/#/room/#fenix:mozilla.org) channel.
Status: NEW → RESOLVED
Closed: 10 years ago2 years ago
Resolution: --- → INCOMPLETE
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.