Work - Circular Progressbar Images

RESOLVED FIXED

Status

defect
RESOLVED FIXED
6 years ago
6 months ago

People

(Reporter: emtwo, Assigned: sfoster)

Tracking

Details

(Whiteboard: [preview])

Attachments

(5 attachments)

Reporter

Description

6 years ago
Posted image progress.png
Stephen, would we be able to get some images for the circular downloads progress indicator? I've attached a screenshot from the downloads doc here https://bug876019.bugzilla.mozilla.org/attachment.cgi?id=761217

We need a full blue circle that looks similar to the one in the image. Also, perhaps a grey circle that would go behind the blue one or an entire download image which includes the grey circle. Either works. Thanks!
Reporter

Updated

6 years ago
Assignee: nobody → shorlander
Reporter

Updated

6 years ago
Blocks: 883959
Whiteboard: [preview]
Reporter

Updated

6 years ago
Blocks: 905641
Reporter

Updated

6 years ago
Duplicate of this bug: 905641
Assignee

Comment 4

6 years ago
I ended up adding a track/background element in the binding to take the ring-background image. That made it easier to toggle it with the "progress" attribute. 
I also found some scaling/skewing of the image due to a mismatch of image/element size and was able to clean that up.
Assignee: shorlander → sfoster
Status: NEW → ASSIGNED
Attachment #795712 - Flags: review?(mbrubeck)
Assignee

Comment 5

6 years ago
This is how it ends up looking.
Comment on attachment 795712 [details] [diff] [review]
Update downloads progress ring graphics

Review of attachment 795712 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/metro/base/content/bindings/circularprogress.xml
@@ +11,5 @@
>    <binding id="circular-progress-indicator">
>      <content>
>        <xul:stack>
>          <xul:toolbarbutton anonid="progressButton" class="circularprogressindicator-progressButton appbar-secondary"/>
> +        <html:div anonid="progressTrack" class="circularprogressindicator-progressTrack"></html:div>

Suggestion: You could use inherits="progress" here to simplify the CSS selectors.
Attachment #795712 - Flags: review?(mbrubeck) → review+
Assignee

Comment 7

6 years ago
Good thought mbrubeck. Done (or at least I think that's what you had in mind) 

On fx-team: https://hg.mozilla.org/integration/fx-team/rev/f30dadf4c937
https://hg.mozilla.org/mozilla-central/rev/f30dadf4c937
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED

Updated

6 months ago
Product: Tracking → Tracking Graveyard
You need to log in before you can comment on or make changes to this bug.