The default bug view has changed. See this FAQ.

Double-click opens properties dialog

RESOLVED FIXED in Thunderbird 24.0

Status

MailNews Core
Composition
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Thunderbird 24.0
regression

Thunderbird Tracking Flags

(thunderbird24 fixed, seamonkey2.19 wontfix, seamonkey2.20 affected, seamonkey2.21 fixed, seamonkey2.22 unaffected)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Due to bug 879838 the change from checking clickCount to using dblclick events broke double-clicking on text, which now opens the properties dialog for the containing element. Although this is fixed on trunk we have to work around it on branches.
(Assignee)

Comment 1

4 years ago
Created attachment 780634 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #780634 - Flags: review?(iann_bugzilla)
Attachment #780634 - Flags: feedback?(mconley)

Updated

4 years ago
Duplicate of this bug: 894808

Updated

4 years ago
Attachment #780634 - Flags: review?(iann_bugzilla) → review+
Comment on attachment 780634 [details] [diff] [review]
Proposed patch

Sorry for the wait!
Attachment #780634 - Flags: feedback?(mconley) → feedback+
(Assignee)

Comment 4

4 years ago
Comment on attachment 780634 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 827017 (because of bug 879838)
User impact if declined: Unexpected property dialogs when double-clicking
Testing completed (on m-c, etc.): N/A 879838 was fixed in Gecko 25
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #780634 - Flags: feedback?(mbanner)
Attachment #780634 - Flags: approval-comm-beta?
Moving to mailnews as this affects both of us.
Component: Composer → Composition
Product: SeaMonkey → MailNews Core
Version: SeaMonkey 2.19 Branch → 24
Comment on attachment 780634 [details] [diff] [review]
Proposed patch

a=Standard8
Attachment #780634 - Flags: feedback?(mbanner)
Attachment #780634 - Flags: feedback+
Attachment #780634 - Flags: approval-comm-beta?
Attachment #780634 - Flags: approval-comm-beta+
This already landed as part of:

http://hg.mozilla.org/releases/comm-beta/rev/4748f12ac8a1
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-seamonkey2.21: affected → fixed
status-thunderbird24: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 24.0
You need to log in before you can comment on or make changes to this bug.