Closed Bug 897696 Opened 7 years ago Closed 6 years ago

Defect - Geolocation doesn't work in metrofx

Categories

(Firefox for Metro Graveyard :: Browser, defect, P1)

x86
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 25

People

(Reporter: Samvedana, Assigned: jimm)

References

()

Details

(Whiteboard: feature=defect c=Info_app_bar u=metro_firefox_user p=1)

Attachments

(3 files)

Attached image locate me.PNG
Tested user story of bug 831949 on Windows 8.1 preview for Metro Firefox.
When I opened http://ie.microsoft.com/TESTdrive/HTML5/Geolocation/Default.html in latest nightly and click on locate me. It didn't give me location.

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:25.0) Gecko/20130724 Firefox/25.0
Build ID: 20130724030204
Blocks: 831949
Summary: Defect - [8.1] Site permission info app bars → Defect - [8.1] Geolocation fails to find a location
No longer depends on: metrov1defect&change
Whiteboard: [8.1] feature=defect c=Info_app_bar u=metro_firefox_user p=0
This doesn't work on desktop either.
Component: General → Geolocation
Product: Firefox for Metro → Core
Version: 25 Branch → Trunk
Summary: Defect - [8.1] Geolocation fails to find a location → Defect - Geolocation fails to find a location
Whiteboard: [8.1] feature=defect c=Info_app_bar u=metro_firefox_user p=0 → feature=defect c=Info_app_bar u=metro_firefox_user p=0
(In reply to Jim Mathies [:jimm] from comment #1)
> This doesn't work on desktop either.

Works on Win7, but not Win8.
OS: Windows 8 Metro → Windows 8
Summary: Defect - Geolocation fails to find a location → Geolocation fails on Windows 8
Maybe this is just with the wifi adpater or has something to do with using nightly to test. Log output:

[08:55:13.497] *** WIFI GEO: startup called.  testing mode isfalse

[08:55:13.497] *** WIFI GEO: watch called

[08:55:13.504] *** WIFI GEO: onChange called

[08:55:13.504] *** WIFI GEO: Filtering out Tigger

[08:55:13.504] *** WIFI GEO: Filtering out Tigger5G

[08:55:13.504] *** WIFI GEO: Filtering out 323

[08:55:13.505] *** WIFI GEO: ************************************* Sending request:
https://www.googleapis.com/geolocation/v1/geolocate?key=no-google-api-key


[08:55:13.505] *** WIFI GEO: ************************************* ------>>>> sending {"wifiAccessPoints":[{"macAddress":"60-a4-4c-20-11-20","signalStrength":-30},{"macAddress":"snip","signalStrength":-83},{"macAddress":"snip","signalStrength":-100}]}

[08:55:13.565] POST https://www.googleapis.com/geolocation/v1/geolocate?key=no-google-api-key [HTTP/1.1 400 Bad Request 495ms]
[08:55:14.008] *** WIFI GEO: gls returned status: 400 --> {"error":{"errors":[{"domain":"usageLimits","reason":"keyInvalid","message":"Bad Request"}],"code":400,"message":"Bad Request"}}
Although nightly on Win7 works fine from the same location FWIW. Both devices are connected via network adapters.
Doug, any ideas as to what's going wrong here?
Flags: needinfo?(doug.turner)
Summary: Geolocation fails on Windows 8 → Defect - Geolocation fails on Windows 8
yeah, the builders aren't using the right google key.  This is a releng bug.
Flags: needinfo?(doug.turner)
Summary: Defect - Geolocation fails on Windows 8 → Geolocation fails on Windows 8 - not using correct GLS key
Ok, so I've been able to reproduce bugs in our geolocation test page on win7 and win8. U can confirm thatafter a few refreshes I was able to get IE's demo working in desktop, but not in metro.
OS: Windows 8 → Windows 8 Metro
Priority: -- → P5
Summary: Geolocation fails on Windows 8 - not using correct GLS key → IE's geolocation page doesn't work in metrofx
Priority: P5 → --
See Also: → 831949
Attached file geolocation test page
Ok, after bouncing this around, I can confirm we do in fact have an issue with geolocation in the metro browser. The posted test page is useful in testing.
Component: Geolocation → Browser
Priority: -- → P1
Product: Core → Firefox for Metro
Summary: IE's geolocation page doesn't work in metrofx → Geolocation doesn't work in metrofx
Whiteboard: feature=defect c=Info_app_bar u=metro_firefox_user p=0 → feature=defect c=Info_app_bar u=metro_firefox_user p=2
Blocks: 831949
Attached patch fixSplinter Review
Unfortunately, I can't test this in a local build, afaict. %GOOGLE_API_KEY% gets filled in with 'no-google-api-key'. But I'm betting in a Nightly this will get populated correctly.
Assignee: nobody → jmathies
Attachment #781101 - Flags: review?(doug.turner)
Blocks: metrov1it11
No longer blocks: metrov1defect&change
Status: NEW → ASSIGNED
QA Contact: jbecerra
Yeah, looks like we add this when we build - 

http://mxr.mozilla.org/mozilla-central/source/configure.in#4404
See Also: 831949
Comment on attachment 781101 [details] [diff] [review]
fix

I think doug is trying to tell me he can't do this review, not sure but just to be safe.
Attachment #781101 - Flags: review?(doug.turner) → review?(mbrubeck)
Comment on attachment 781101 [details] [diff] [review]
fix

Doug, should we make the default in modules/libpref/src/init/all.js?  Will Fennec or B2G need this too?
Attachment #781101 - Flags: review?(mbrubeck) → review+
Whiteboard: feature=defect c=Info_app_bar u=metro_firefox_user p=2 → feature=defect c=Info_app_bar u=metro_firefox_user p=1
https://hg.mozilla.org/mozilla-central/rev/b71e4f85dad6
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Summary: Geolocation doesn't work in metrofx → Defect - Geolocation doesn't work in metrofx
Mozilla/5.0 (Windows NT 6.2; rv:25.0) Gecko/20130728 Firefox/25.0

Verified as fixed on the latest Nightly build using the steps from the description. The location is now visible.
Status: RESOLVED → VERIFIED
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130808030205
Built from http://hg.mozilla.org/mozilla-central/rev/fd4cf30428b0

WFM
Tested on windows 8 using latest nightly for iteration-11 for bug831949. Followed steps provided in user story and didn't provide geolocation.

It is also not working for desktop Firefox.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Depends on: 897699
No longer depends on: 897699
See Also: → 897699
Moving follow-up fix to Bug 898795.
Status: REOPENED → RESOLVED
Closed: 7 years ago6 years ago
Resolution: --- → FIXED
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130819030205
Built from http://hg.mozilla.org/mozilla-central/rev/c8c9bd74cc40

WFM
Tested on windows 8.1 using latest nightly. Followed steps provided in comment0 and got expected result.
Status: RESOLVED → VERIFIED
While testing for iteration #15, this doesn't work with latest Nightly and both desktop and Metro mode (build ID: 20131006030201)
While testing for iteration #17, this doesn't work with latest Nightly in Metro mode, but it does work with Nightly in desktop mode. (build ID: 20131101030205)
(In reply to Manuela Muntean [:Manuela] [QA] from comment #22)
> While testing for iteration #17, this doesn't work with latest Nightly in
> Metro mode, but it does work with Nightly in desktop mode. (build ID:
> 20131101030205)

Dupe of bug 933075?
(In reply to Jim Mathies [:jimm] from comment #23)
> (In reply to Manuela Muntean [:Manuela] [QA] from comment #22)
> > While testing for iteration #17, this doesn't work with latest Nightly in
> > Metro mode, but it does work with Nightly in desktop mode. (build ID:
> > 20131101030205)
> 
> Dupe of bug 933075?

I think that bug 933075 depends on this one, bug 897696. (but I don't think they are duplicates)
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.