[UMS] storage rescan error after unplug UMS

RESOLVED DUPLICATE of bug 901919

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 901919
5 years ago
5 years ago

People

(Reporter: leo.bugzilla.gecko, Unassigned)

Tracking

unspecified
1.1 QE5
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TD-69702] )

(Reporter)

Description

5 years ago
1. Title : storage rescan error after unplug UMS 
2. Precondition :  Have songs and videos stored on both memories (internal and external). Enable sharing all memories.
3. Test Action : 1) Open music & video. and check file list.
                 2) Go to home. and plug USB.
                 3) After a while (30 sec) unplug the cable
                 4) Go to Music and check 'All Songs' tab view.
                 5) Check also Video app.
4. Detailed Symptom : only internal SD file list show.
5. Expected : music show internal and external file list
6. Reproducibility: Y
1) Frequency Rate : 100%
7. gecko : mozilla/gecko-18
8. gecko Revision:  cf227870efbed2b1e7ce9bde4e1245e90f6c6b6a
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo+
Whiteboard: [TD-69702]
I can guess what's happening here.

I think that mediadb isn't really setup to think of scanning individual volumes.

When the USB cable is unplugged, then the internal volume becomes available first, which triggers a scan. Then the external volume becomes avaliable, probably while the scan of the internal volume is happening, and mediadb doesn't realize that it needs to scan the external volume.
dup of bug 836783; I reopened bug 830191 in terms of a valid method of transferring a file
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 836783
(Reporter)

Comment 3

5 years ago
It is not dup of bug 830191.
please test my test version. 

Test Version Info.
Device : leo
Gaia revision = "c60e3507d9df160e006d2e25967d26df2dc543cb"
Gecko revision = "b70519784430835a3e5a1d417eb3a818340c1c1c"
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: [TD-69702] → [TD-69702]
(Reporter)

Updated

5 years ago
Depends on: 876782
I'll confirm that the STR makes this NOT a duplicate of either bug 836783 or bug 830191 (both of those bugs relate to adding new files and having the new files not being seen).

This bug is talking about not seeing files on the sdcard period.
I removed the dependency on bug 876782 since the this problem and that problem are completely unrelated.
No longer depends on: 876782

Comment 6

5 years ago
Leo, is this still a blocker for you? I think you've gone to build with final builds already.
blocking-b2g: leo+ → leo?
Flags: needinfo?(leo.bugzilla.gecko)
Dave,

Is this still an issue? Comment if it is a blocker indeed!!
Flags: needinfo?(dhylands)
I'm pretty confident that this is a dup of 901919, so I'm marking it as such (and that bug has more useful information in it than this one).
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Flags: needinfo?(dhylands)
Resolution: --- → DUPLICATE
Duplicate of bug: 901919

Updated

5 years ago
blocking-b2g: leo? → ---
(Reporter)

Comment 9

5 years ago
normal operation after that reflect Bug 878310.
Flags: needinfo?(leo.bugzilla.gecko)
You need to log in before you can comment on or make changes to this bug.