Closed Bug 898194 Opened 6 years ago Closed 6 years ago

Disable testLayout/testNavigateFTP.js due to crash on all platforms

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, major)

All
Linux
defect
Not set
major

Tracking

(firefox25 fixed, firefox26 fixed, firefox27 fixed)

RESOLVED FIXED
Tracking Status
firefox25 --- fixed
firefox26 --- fixed
firefox27 --- fixed

People

(Reporter: whimboo, Assigned: AndreeaMatei)

References

Details

(Keywords: regression)

Attachments

(2 files, 3 obsolete files)

As of our latest mozmill-ci results we fail in the non-restart testrun after testNavigateFTP.js. Reason is that Firefox crashes when trying to access the FTP server, which is done through the Squid proxy.

We have to disable the test for now as best on Linux 32bit only.

Andreea, can you please take that?
Attached patch skip.patch (obsolete) — Splinter Review
This is skipping the test on Ubuntu 12.04 (has kernel 3.2.0), x86 only.
Attachment #781587 - Flags: review?(hskupin)
Attachment #781587 - Flags: review?(dave.hunt)
Comment on attachment 781587 [details] [diff] [review]
skip.patch

Review of attachment 781587 [details] [diff] [review]:
-----------------------------------------------------------------

Make the suggested change in both files and get it landed ASAP. Thanks.

::: tests/functional/testLayout/manifest.ini
@@ +1,2 @@
>  [testNavigateFTP.js]
> +disabled = "Disabled test due to crash on Ubuntu 12.04 32bit"

Missing bug number.
Attachment #781587 - Flags: review?(hskupin)
Attachment #781587 - Flags: review?(dave.hunt)
Attachment #781587 - Flags: review+
Attached patch skip.patch (obsolete) — Splinter Review
Updated patch and landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/7083efb47cfe (default)
Attachment #781587 - Attachment is obsolete: true
Attachment #781598 - Flags: review+
Attachment #781598 - Flags: checkin+
Whiteboard: [mozmill-test-skipped]
Hm, today we had another test crash the same way:
http://mm-ci-master.qa.scl3.mozilla.com:8080/job/mozilla-central_functional/8006/
http://mozmill-daily.blargon7.com/#/functional/report/180cf2548ef2865af3ae441d61fc4eca

Between testLayout/testNavigateFTP.js and testPopups/testPopupsAllowed.js are other tests, but only these 2 ran. If we'll have other occurrences I'll prepare a skip for it as well.
This test was run before the testNavigateFTP.js skip patch has been landed. So please keep an eye on upcoming test results.
Duplicate of this bug: 901901
Attached patch skipFTP.patch (obsolete) — Splinter Review
We'll need this applied on (default) and (mozilla-aurora)
Attachment #781598 - Attachment is obsolete: true
Attachment #799594 - Flags: review?(dave.hunt)
So this has started failing on other platforms as well.
We'll need to skip this test on all of them.

See bug 911976 for more information.
I think I'll might just mark that as a duplicate of this one after we land the skip and backout the skip commits from bug 911976.

It is exactly the same issue.
Summary: Disable testLayout/testNavigateFTP.js due to crash on Ubuntu 12.04 32bit → Disable testLayout/testNavigateFTP.js due to crash on all platforms
Comment on attachment 799594 [details] [diff] [review]
skipFTP.patch

Review of attachment 799594 [details] [diff] [review]:
-----------------------------------------------------------------

::: tests/functional/testLayout/testNavigateFTP.js
@@ +33,5 @@
>   * Map test functions to litmus tests
>   */
>  // testNavigateFTP.meta = {litmusids : [7962]};
> +
> +setupModule.__force_skip__ = "Bug 911976 - Disabled test due to Disconnect Error failures. r=dhunt"

No need to include a reviewer on a skip message. Also, can we keep the same skip message as before? "Bug 898194 - Disabled test due to crash"
Attachment #799594 - Flags: review?(dave.hunt) → review-
Attached patch skipFTP 2Splinter Review
Updated message.
Also in the manifest.

> No need to include a reviewer on a skip message.
Whoops, copy/pasted if from the commit message.
Attachment #799594 - Attachment is obsolete: true
Attachment #799617 - Flags: review?(dave.hunt)
Comment on attachment 799617 [details] [diff] [review]
skipFTP 2

Review of attachment 799617 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, let's get this landed.
Attachment #799617 - Flags: review?(dave.hunt) → review+
Attachment #799617 - Flags: checkin+
Duplicate of this bug: 911976
Can anyone please check on the affected machines today, what has been caused this massive problem across all platforms yesterday? Is it only Nightly and Aurora or is Beta also affected? Please test this before we get the next beta candidate builds later today. I don't want to run into the same problem for that branch. If it's really happening for Nightly and Aurora only a recent checkin might be the cause. We have to find that ASAP. Thanks.
Flags: needinfo?(mario.garbi)
Flags: needinfo?(andrei.eftimie)
From evidence until now just Nightly and Aurora are affected.

Not sure if its the same problem initially seen in this bug that only manifested itself on Linux 32b, which now started across all other platforms.

(That might explain why it initially only failed on Linux 32b - we might have had some changes to only those machines? And the recent proxy issues and changes might have needed the same changes on other platforms?)

I will look into it more.
Flags: needinfo?(andrei.eftimie)
Or yes, maybe a recent checkin related to the thumbnail service might be the cause...
In three testruns we don't seem to get Disconnect failures in the non-restart tests with Beta branch. This is without the FTP skip. I'll run a few more just to be sure.

http://mozmill-crowd.blargon7.com/#/functional/report/fb97b6210ae70da1b9ace674453211f4
Flags: needinfo?(mario.garbi)
(In reply to Andrei Eftimie from comment #16)
> (That might explain why it initially only failed on Linux 32b - we might
> have had some changes to only those machines? And the recent proxy issues
> and changes might have needed the same changes on other platforms?)
 
I think updating the proxy settings across the other platforms might indeed have been caused that. Just check the builds from the original regression range.
Testrun on CI with a Firefox build from 2nd September (we didn't log any Disconnect Failures that day on mozmill-daily):
http://mozmill-crowd.blargon7.com/#/functional/report/fb97b6210ae70da1b9ace674453481e1

Same failure seen as in the 4th Sept.
Strong indication that cause is _not_ a recent changeset in Firefox.

I'm betting my money on bug 898156 + recent Proxy changes + Squid
I got the pushlogs from 03.09 to 04.09 to see if there were any changesets that might have caused a regression:

Nightly pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d54e0cce6c17&tochange=e3785e299ab6

Aurora pushlog:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=aeac941ac517&tochange=35934f1b4a45

We only had 3 changesets on Aurora between those days and since we had this issue on both branches it should have been something landed on both. As far as I could tell there were no similar changesets landed on both branches.
Duplicate of this bug: 912363
Attached patch unskip patchSplinter Review
Hi, here is the unskip patch.

http://mozmill-crowd.blargon7.com/#/remote/report/dc3d4d2f66af31b9e75e291fa0e53077
Attachment #806014 - Flags: review?(andrei.eftimie)
Attachment #806014 - Flags: review?(andreea.matei)
Comment on attachment 806014 [details] [diff] [review]
unskip patch

Review of attachment 806014 [details] [diff] [review]:
-----------------------------------------------------------------

http://hg.mozilla.org/qa/mozmill-tests/rev/ffee58c83544 (default)

The unskip to aurora will be done in the merge following up.
Attachment #806014 - Flags: review?(andrei.eftimie)
Attachment #806014 - Flags: review?(andreea.matei)
Attachment #806014 - Flags: review+
Andreea, this also has to be backported to beta, given that we already merged aurora to beta.
You're correct, patch applied cleanly:
http://hg.mozilla.org/qa/mozmill-tests/rev/e2921625ee35 (beta)

Aurora had the test enabled already by the merge.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [mozmill-test-skipped]
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.