Closed Bug 911976 Opened 7 years ago Closed 7 years ago

Test failure "Disconnect Error: Application unexpectedly closed" in /testPopups/

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P1)

defect

Tracking

(firefox24 unaffected, firefox25 disabled, firefox26 disabled)

RESOLVED DUPLICATE of bug 898194
Tracking Status
firefox24 --- unaffected
firefox25 --- disabled
firefox26 --- disabled

People

(Reporter: mario.garbi, Assigned: mario.garbi)

References

()

Details

(Whiteboard: [mozmill-test-failure][mozmill-test-skipped])

Attachments

(3 files, 1 obsolete file)

Attached file jenkins.txt
This started happening today across Mac 10.6 and 10.7 with Aurora 25(it, fr, en-US and de) and it fails constantly.

http://mozmill-daily.blargon7.com/#/functional/report/3c3cd991de01b704f3f65783a1d91502

Attached to the bug is the Jenkins log for future investigation.
This also failed on Mac 10.8 and Windows
OS: Mac OS X → All
Hardware: x86_64 → All
I was able to reproduce this on the failing machine:
http://mozmill-crowd.blargon7.com/#/functional/report/3c3cd991de01b704f3f65783a1dcc9dc
Attached patch skipPatch.patch (obsolete) — Splinter Review
Created skip patch until we can figure out the issue here.
Attachment #798811 - Flags: review?(andrei.eftimie)
Attachment #798811 - Flags: review?(andreea.matei)
Attached patch skipPatch.patchSplinter Review
Small typo in the previous patch.
Attachment #798811 - Attachment is obsolete: true
Attachment #798811 - Flags: review?(andrei.eftimie)
Attachment #798811 - Flags: review?(andreea.matei)
Attachment #798814 - Flags: review?(andrei.eftimie)
Attachment #798814 - Flags: review?(andreea.matei)
Comment on attachment 798814 [details] [diff] [review]
skipPatch.patch

Review of attachment 798814 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.

Landed as: http://hg.mozilla.org/qa/mozmill-tests/rev/e721f00c022f (mozilla-aurora)
Attachment #798814 - Flags: review?(andrei.eftimie)
Attachment #798814 - Flags: review?(andreea.matei)
Attachment #798814 - Flags: review+
Attachment #798814 - Flags: checkin+
Again, please don't forget to set the right flags. It will make it harder to query for open issues.
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure][mozmill-test-skipped]
It started failing on Nightly too unfortunately, the skip patch will work for default branch too:
http://mozmill-daily.blargon7.com/#/functional/report/3c3cd991de01b704f3f65783a1de83e0
Summary: Test failure "Disconnect Error: Application unexpectedly closed" in /testPopups/testPopupsAllowed.js → Test failure "Disconnect Error: Application unexpectedly closed" in /testPopups/
Both tests from the testPopups folder are failing, updating the bug and adding the dashboard report link for testPopupsBlocked.js here:
http://mozmill-daily.blargon7.com/#/functional/failure?branch=All&platform=All%20NT&from=2013-09-03&test=%2FtestPopups%2FtestPopupsBlocked.js&func=testPopUpBlocked
Attached patch skip.patchSplinter Review
Skip patch for testPopupBlocked.js that work with both Default and Aurora branches.
Attachment #798845 - Flags: review?(andrei.eftimie)
Attachment #798845 - Flags: review?(andreea.matei)
The failures might be related to this error we have popping up in the Jenkins log, does anyone know what this is about?

tests\tests\functional\testPopups\testPopupsBlocked.js | testPopupsBlocked.js::teardownModule
[Child 3508] ###!!! ABORT: ActorDestroy by IPC channel failure at LayerTransactionChild: file e:/builds/moz2_slave/m-cen-w32-ntly-000000000000000/build/gfx/layers/ipc/LayerTransactionChild.cpp, line 89

###!!! [Child][AsyncChannel] Error: Channel error: cannot send/recv

TEST-UNEXPECTED-FAIL | Disconnect Error: Application unexpectedly closed
INFO Passed: 65
INFO Failed: 1
INFO Skipped: 9
Ok, this looks like a Firefox regression, see other filed bugs with this failure:
bug 881641, bug 890840, bug 908442
Comment on attachment 798845 [details] [diff] [review]
skip.patch

Review of attachment 798845 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.

Landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/f5a7c6498093 (default)
http://hg.mozilla.org/qa/mozmill-tests/rev/a86300ee5dfa (mozilla-aurora)
Attachment #798845 - Flags: review?(andrei.eftimie)
Attachment #798845 - Flags: review?(andreea.matei)
Attachment #798845 - Flags: review+
Attachment #798845 - Flags: checkin+
So far seems Linux is not affected
I managed to reduce the tests needed to reproduce this to 3 tests on a WinXP CI machine: 
testNavigateFTP.js,
testPopupsAllowed.js,
testPopupsBlocked.js

Could this be related to a proxy issue with the FTP and localhost? I noticed that by changing the location of the "popup_trigger.html" from a local repository to http://mozqa.com and that stopped the failures. That also happens by skipping the testNavigateFTP.js.

I will further into this.
Assignee: nobody → mario.garbi
This is actually a duplicate of bug 898194
So lets backout the skipped tests commits, and mark this bug as a duplicate.
Backed out skip patches:
http://hg.mozilla.org/qa/mozmill-tests/rev/9ce79ad6523e (default)
http://hg.mozilla.org/qa/mozmill-tests/rev/1901613498c4 (default)
http://hg.mozilla.org/qa/mozmill-tests/rev/20b290122d80 (mozilla-aurora)
http://hg.mozilla.org/qa/mozmill-tests/rev/f4499216103d (mozilla-aurora)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 898194
Andrei, thank you for all the hard work today in getting this done that late your time! I really appreciate that.
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.