Closed Bug 898366 Opened 8 years ago Closed 8 years ago

[User Story] Silence After 10 Minutes

Categories

(Firefox OS Graveyard :: Gaia::Clock, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: pdol, Assigned: oconnore)

References

Details

(Keywords: feature, Whiteboard: [ucid:Productivity47])

User Story:

As a user I want to the alarm to automatically be silenced after sounding for 10 minutes in the event that I do not press snooze or dismiss the alarm so that my alarm does not continue sounding forever.


Acceptance Criteria:

1. If my alarm has been sounding for greater than 10 minutes (in one instance, not an aggregate of sounding time periods from multiple snooze presses), the alarm sound ceases.
Accidental nom.  Not a blocking feature.
blocking-b2g: koi? → ---
Blocks: 898456
Blocks: 898354
No longer blocks: 898456
Assignee: nobody → eric
This is done in the patch for Bug 898354: https://github.com/mozilla-b2g/gaia/pull/14665
Flags: needinfo?(mike)
Currently, an Alarm will sound for 15 minutes before automatically silencing, but a Timer will sound indefinitely. In fixing the behavior for Timer, Eric's patch for bug 898354 will also address this by unifying the "silence timeout" to 10 minutes for both cases.

Since the functionality described in comment 0 is neither dependent on nor a duplicate of bug 898354, we should leave this bug open until that one lands. At that time, we should close this bug as "RESOLVED - WORKSFORME".
Flags: needinfo?(mike)
Fixed as part of Bug 898354
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.