Defect - Horizontal scroll bar visible in settings and about panels

VERIFIED FIXED in Firefox 25

Status

defect
P2
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: kapranov98, Assigned: jimm)

Tracking

25 Branch
Firefox 25
All
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=defect c=Settings_pane_options_and_about u=metro_firefox_user p=1)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

There was a horizontal scroll in the settings panel and about, which are not needed. Appeared after the application of fixation https://hg.mozilla.org/mozilla-central/rev/1cf7aa4b2626
(Reporter)

Updated

6 years ago
OS: All → Windows 8 Metro
Summary: There was a horizontal scroll in the settings panel and about, which are not needed. → Defect - There was a horizontal scroll in the settings panel and about, which are not needed.
Whiteboard: feature=defect c=tbd u=tbd p=0
(Reporter)

Comment 1

6 years ago
FIX:
diff --git a/browser/metro/theme/flyoutpanel.css b/browser/metro/theme/flyoutpanel.css
.flyoutpanel-contents[input="precise"] {
 overflow: scroll;
 overflow-x: hidden;
 }
I see this too in the latest nightly with a standard dpi display.
Blocks: 831955, 831958
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Whiteboard: feature=defect c=tbd u=tbd p=0 → feature=defect c=Settings_pane_options_and_about u=tbd p=0
Whiteboard: feature=defect c=Settings_pane_options_and_about u=tbd p=0 → feature=defect c=Settings_pane_options_and_about u=metro_firefox_user p=0
(Assignee)

Comment 3

6 years ago
My mistake I guess, thought we wanted scrollbars to be visible in panels like this when in precise mode. Thanks for posted the fix Kapranov.
(Assignee)

Comment 4

6 years ago
(In reply to Jim Mathies [:jimm] from comment #3)
> My mistake I guess, thought we wanted scrollbars to be visible in panels
> like this when in precise mode. Thanks for posted the fix Kapranov.

Oh nm, it's the horizontal bar that's the issue.
Assignee: nobody → jmathies
(Assignee)

Updated

6 years ago
Summary: Defect - There was a horizontal scroll in the settings panel and about, which are not needed. → Defect - Horizontal scroll bar visible in settings and about panels
(Assignee)

Updated

6 years ago
Blocks: 896294
(Assignee)

Comment 5

6 years ago
Posted patch fix (obsolete) — Splinter Review
(Assignee)

Updated

6 years ago
Attachment #783114 - Attachment is obsolete: true
(Assignee)

Comment 6

6 years ago
Posted patch fixSplinter Review
Fixes a mistake I made in bug 896294.
Attachment #783117 - Flags: review?(tabraldes)
(Assignee)

Updated

6 years ago
Whiteboard: feature=defect c=Settings_pane_options_and_about u=metro_firefox_user p=0 → feature=defect c=Settings_pane_options_and_about u=metro_firefox_user p=1
Blocks: metrov1it12
No longer blocks: metrov1defect&change
Status: NEW → ASSIGNED
QA Contact: jbecerra
Comment on attachment 783117 [details] [diff] [review]
fix

I should have caught that in review; sorry about that!
Attachment #783117 - Flags: review?(tabraldes) → review+
(Assignee)

Updated

6 years ago
Duplicate of this bug: 900239
(Assignee)

Updated

6 years ago
Blocks: 900072
https://hg.mozilla.org/mozilla-central/rev/0ef8b0214e7e
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Please can bugs changing these parts of the tree land on fx-team in the future to help balance load & avoid conflicts (for more info see Gavin's newsgroup post: https://mail.mozilla.org/pipermail/firefox-dev/2013-July/000618.html). Thank you :-)
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130819030205

WFM
Tested on Windows 8 32bit and 64bit using latest Nightly for iteration #12. Horizontal scroll bar isn't visible in Settings and About flyouts.
Status: RESOLVED → VERIFIED
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.